suse 10.1 sono un pò perplesso

Ritratto di ap1978
ap1978
(Guru)
Offline
Guru
Iscritto: 01/10/2004
Messaggi: 2972

Discussioni simili a questa furono fatte anche in corrispondenza dell'uscita di SuSE 10.0.

Ripropongo una domanda. Come valutate ora SuSE 10.0?

Ciao

ap Big Grin

Ritratto di desaparesido
desaparesido
(Junior)
Offline
Junior
Iscritto: 20/05/2006
Messaggi: 6

Quote:

ap1978 ha scritto:
Onestamente penso che stiate esagerando la situazione.
........
Ciao

Senza dubbio non arriverò al suicidio....
Sono solo "moderatamente" preoccupato e attento a come Novell intende coniugare gli interessi legati alla gestione di una grande azienda quale è con le necessità reali di chi ha adottato Suse come s.o.
Semplicemente mi infastidisce essere "forzato" a cambiamenti se questi fossero unicamente legati alle necessità commerciarli di Novell.
In verità ho abbandonato qualcun'altro proprio per questo motivo...

Detto questo mi ripeto: a mio modestissimo giudizio, a parte la questione "repo & yast" , la 10.1 è un gioiellino.

"Ma però", potremmo andare avanti così in eterno e rischiamo che la discussione diventi sterile...
Ciao a tutti
Smile

Ritratto di ap1978
ap1978
(Guru)
Offline
Guru
Iscritto: 01/10/2004
Messaggi: 2972

Quote:

desaparesido ha scritto:
In realtà lascia a desiderare sole nelle parti che precludono al cambiamento . Per il resto è un "gioiellino".
Quello che dice gzimo, a parte il tono rabbioso, non è infondato ma molto, molto vicino al vero!
Nulla contro i cambiamenti (anche se faticherò a lasciare KDE e non sò se lo farò) ma che questi siano almeno all'altezza di ciò che si vuole cambiare.
E per il momento, a mio modesto parere,non ci siamo!
Smile Sad

Il problema di SuSE 10.1 si riconduce al package manager, che da ancora qualche problema. Per il resto, è una distribuzione che funziona.
I vantaggi del nuovo package manager sono tanti: dalla gestione di più tipi di repository alla possibilità di usare i cataloghi ad un motore più ricco di funzioni e solido.
Ci sono dei bug, ma li risolveranno. Del resto Fedora è stata per parecchio tempo con Up2Date che se si bloccava, corrompeva il database RPM a volte irreparabilmente. SuSE non è a questi livelli. Ci sono difficoltà nella gestione delle fonti di pacchetti, ma nulla che comprometta né la stabilità né l'usabilità del sistema.

Per gli utenti KDE manca l'integrazione tra Yast e KDE control center. Ma Yast fa tutto ciò che faceva prima. Si può usare quello.

Ciao

ap Big Grin

Ritratto di brozz87
brozz87
(Junior)
Offline
Junior
Iscritto: 27/01/2006
Messaggi: 43

Oi oi raga Smile non voglio alzare un polverone...

Quello che ho detto ovviamente sono solo pareri personali Smile

Sarà il mio centrino che si sta bruciando... Poretto...

[ Linux SuSE 10.0 - XFCE 3.4 - Intel Centrino 1.70 Ghz - ATI Radeon 9700 M - TUX Powered ]

Ritratto di Krystyan
Krystyan
(Monster)
Offline
Monster
Iscritto: 08/01/2005
Messaggi: 218

Dai ragazzi, alla fine questa 10.1 non è niente male... anzi, con essa ho risolto i vari bug che mi capitavano allo spegnimento del sistema...

Il problema più grande secondo me, e zen, non mi piace per niente come package manager... assolutamente si poteva fare di meglio, tipo integrare apt nella distro... ma perchè non lo fanno? sarebbe tutto pìù semplice...

Personalmente dopo aver smanettato un pò ho installato sia smart che apt... e vanno una favola! Big Grin

Suse Linux 10.0 su P4 3.2 Ock 4.3Ghz - Motherboard asus P4C800 Dlx - Ram 512x2 Vdata utt @250 2.2.2.5 - Video Nvidia6800ultra

Ritratto di ap1978
ap1978
(Guru)
Offline
Guru
Iscritto: 01/10/2004
Messaggi: 2972

Quote:

Krystyan ha scritto:
Il problema più grande secondo me, e zen, non mi piace per niente come package manager... assolutamente si poteva fare di meglio, tipo integrare apt nella distro... ma perchè non lo fanno? sarebbe tutto pìù semplice...

Apt è considerato superato. I motivi della sua caduta in disuso in SuSE sono stati discussi ai tempi della 10.0.

Zen altro non è che un frontend per rug, che ha potenzialità nettamente superiori ad apt, ma è anche relativamente giovane. Prova a dare un'occhiata al suo help e ad usarlo un po'.

Alcuni comandi rug:

- Installare un pacchetto: rug in nome_pacchetto
- Rimuovere un pacchetto: rug rm nome_pacchetto
- Aggiungere un repository: rug sa -type=ZYPP Url Nome (sostituire ZYPP con altro se necessario)
- Help: rug

Ciao

ap Big Grin

Ritratto di leo72
leo72
(Guru)
Offline
Guru
Iscritto: 27/12/2004
Messaggi: 689

Vi aggiorno su Zen...

Oggi, dopo aver inserito i repository consigliati qui ho lanciato l'aggiornamento di 114 pacchetti (praticamente tutto KDE 3.5.2 ed un po' di altre cose) e sono uscito di casa... Torno dopo diverse ore e trovo Zen bloccato all'1% dell'installazione dei pacchetti...

Riavviato il sistema, ho di nuovo tutti i 114 pacchetti da scaricare... col timore che poi NON li installi nuovamente...

Leo.
------------------
Scegli software open-source: il mio sistema Suse Linux esegue OpenOffice, Mozilla Firefox e Thunderbird, The Gimp...

Ritratto di ilmaltoso
ilmaltoso
(Geek)
Offline
Geek
Iscritto: 11/03/2005
Messaggi: 105

Io sono 3 giorni che tento di aggiornare con zen, si blocca sempre.
Ho messo su smart

Ritratto di ap1978
ap1978
(Guru)
Offline
Guru
Iscritto: 01/10/2004
Messaggi: 2972

Zen va in crash con un eccezione non gestita durante il controllo delle dipendenze delle patch. Potete scaricare gli aggiornamenti con Yast Online Update.

114 pacchetti di KDE mi sembrano troppi. Hai attivato dei repository addizionali? Fai attenzione.

Ciao

ap Big Grin

Ritratto di leo72
leo72
(Guru)
Offline
Guru
Iscritto: 27/12/2004
Messaggi: 689

I repository sono quelli consigliati in questo 3d.
I 114 pacchetti erano in pratica KDE 3.5.2.
Ma la cosa buffa è che nonostante il crash, i pacchetti sembrano installati.... nel senso che riavviato il sistema dopo il 2° tentativo (anch'esso conclusosi con un crash) adesso ho KDE 3.5.2.

Oggi ho trovato un'altra decina di aggiornamenti... Lancio Zen, scarica i pacchetti e... va in crash durante l'installazione!
Riavvio il sistema e trovo i pacchetti installati!
Ora la cosa che mi preoccupa è che Zen abbia installato solo i pacchetti prima del crash ma che segni anche tutti gli altri come installati.

Mah...

Leo.
------------------
Scegli software open-source: il mio sistema Suse Linux esegue OpenOffice, Mozilla Firefox e Thunderbird, The Gimp...