Suse non si avvia dopo un update

8 risposte [Ultimo messaggio]
Ritratto di AndreaCatania
AndreaCatania
(Newbie)
Offline
Newbie
Iscritto: 06/07/2013
Messaggi: 4

Salve a tutti sono nuovo di questo Forum,

Vi scrivo perchè il mio problema è molto strano (forse perche sono niubbo)

Ho installato OpenSuse 12.3 in un PC alienware M17xR3 con scheda grafica 460m e Processore i7

in dual boot con win7, la versione di suse e la 12.3 KDE e prima avevo installato mint 14 e durante l'installazione ho rimpizzato le partizioni di mint con quelle di susse

Dopo l'installazione tutto OK ho riavviato più volte il sistema senza nessun problema di nessun genere...

Ho successivamente fatto gli update che il sistema stesso richiede ma non riesce ad installarli nemmeno tutti perchè mi dice:
"errore operazione interrotta dall'utente"
(ho formattato 2 volte il PC e 2 volte non toccavo il PC quando facevo questi UPDATE, quindi non penso di essere stato io ad interrompere la procedura).

Riavvio dopo aver il messaggio precedente e ottengo una schermata d'errore che dice: (aprite il link all'immagine qui sotto Please)

https://copy.com/b0nT6xacN1nV

Come risolvo????? diamine... At Wits End Crying

GRAZIE UN MILIONE in ANTICIPOO ve ne sono veramente grato io sono troppo nabbo e non ho idea di cosa fare posso solamente riformattare per la 3 volta oggi...

Andreaa

Ritratto di wal7er
wal7er
(Guru)
Offline
Guru
Iscritto: 21/09/2007
Messaggi: 572

Sembrerebbe che durante l'aggiornamento si è rotto qualcosa, come hai segnalato, e per questo non è stato possibile riconfigurare correttamente il nuovo kernel. Comunque di solito la "vecchia" versione del kernel viene lasciata: dai un sguardo alle voci che compaiono all'avvio, magari quello nuovo non funziona e puoi comunque avviare il sistema con la versione precedente.

Quando il sistema ti segnala che ci sono aggiornamenti, dai un controllata e aggiorna solo i programmi e poi, alla fine, prova a fare il solo aggiornamento del kernel (lo so è una rottura andare a controllare uno per uno ma così puoi vedere passo passo cosa rompe tutto).

Una cosa: ma hai installato la versione a 32 bit o quella a 64 bit di OpenSuse?

PS:
Se formatti n volte e dopo fai le stesse operazioni alla fine otteni lo stesso risultato. Smile

HP Pavilion dv5-1110el powered by OpenSUSE 13.2 64bit

http://linuxcounter.net/cert/432576.png

Ritratto di AndreaCatania
AndreaCatania
(Newbie)
Offline
Newbie
Iscritto: 06/07/2013
Messaggi: 4

Sto installando la versione a 64 bit da penna usb ...

Da nabbo penso... Ma se è veramente il kernel rovinato... Perché come si danneggia non crasha tutto?

Oltre al kernel potrebbe essere colpa del bios installato sul PC? O deli driver video?

Ritratto di aksaf
aksaf
(Guru)
Offline
Guru
Iscritto: 08/03/2011
Messaggi: 957

Però è strano, dall'immagine inviata il kernel panic mi pare riferito alla versione 3.7.10-1.1, che è quella installata quando si installa il sistema operativo, mentre con gli aggiornamenti si passa alla versione 3.7.10-1.16 (con una 3.7.10-1.4 intermedia). Inoltre ho visto un "arch/x86" che magari non significa nulla, ma che lascia pensare ad un kernel a 32 bit (invece che a 64).
Una volta installato aggiorni direttamente dal vassoio di sistema, con Apper, oppure usi YaST? Inoltre la tua scheda è una NVidia, mi pare, però non hai installato i driver di NVidia, giusto? (te lo chiedo solo a scopo informativo).

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1706

Non è che usasti le partizioni di Mint (se non sbaglio u derivata da Ubunto) SENZA formattarle??? In tal caso il Kernel nuovo di Suse si trova in difficoltà scrittura/lettura per via di un bug Debian.
Raised Eyebrow

Poi come era la partizione: Unica? Un guaio per i sistemi non debian.

Ti conviene eliminare proprio la partizione Linux e installare Suse dicendogli di fare le sue partizioni e quindi se li formatta lui nel modo giusto.

Nota: Questo forum permette di mettere le immagini senza metterle in server di immagini esterno. Guarda in basso dopo il box dove scrivi.

SO: Linux desktop Sistema: OpenSUSE Leap 15.1 (64bit) KDEE 5.12
SO: Linux desktop Sistema: OpenSUSE Tumbleweed (64bit) KDE 5
Miao

Ritratto di AndreaCatania
AndreaCatania
(Newbie)
Offline
Newbie
Iscritto: 06/07/2013
Messaggi: 4

Buongiorno a tutti Grazie per le risposte,

non So onestamente come ho aggiornato il tutto se con yast o apper (mi spunta la notifica faccio review e aggiorno) adesso che lo sto riformattando Crying ti faccio sapere

Intando partiamo da cosa ho fatto e poi rispondo a "mauriziod"

Prima usavo per l'installazione la chiavetta USB e se facevo check installation media si bloccava il che suggerisce che i file nel supporto non sono in ottimo stato,
prima avevo scaricato la versione da ~900MB con desktop KDE e non quella completa da 4.7GB

Adesso ho scaricato la versione 4.7GB e masterizzata in un DVD, adesso facendo chaeck installation media e non fallisce e mi dice ch'è tutto ok.

Dopo l'installazione ho seguito un consiglio datomi prima, e cioè d'installare a poco a poco gli aggiornamenti per vedere il risultato.

Prima di tutto ho installato gli update del kernel, senza problemi riavvio tutto ok.
Poi ho installato gli aggiornamenti (credo) dei driver video (In poche parole ho installato tutti gli aggionamenti con dicitura "X" rifacendomi al server X) ho riavviato nessun problema.

A questo punto spavaldo di me stesso (pensando che il problema fosse la pendrive) seleziono il resto dei 115 UPDATE rimasti e li faccio partire... fino a che mi ha dato il solito errore

https://copy.com/uWoVlW1ni2w8

Riavvio e ottengo questa schermata:

https://copy.com/mUexjCoYlXAq

Potrebbe essere che tutti questi aggiornamenti vanno in conflitto??
Adesso Provo ad aggiornare il grub per vedere se è lui il problema...

In questo momento ho riformattato il PC e come sempre ho formattato tutti i dischi dove c'era Mint (del cavolo) senza però cancellare completamente e ricreare la partizione da 0 (cosi facendo perderei tutti i dati di windows..)

https://copy.com/OgFZ1gZSncbv

Questa foto rappresenta tutti le partizioni del PC prima di formattare.

Per quanto riguarda i Driver video per il momento ho installato solamente gli update e nientaltro... e la scheda video è nVidia..

Fatemi sapere le vostre idee perche onestamente io non ho idea di cosa fare!!!!!
Grazie ancora !!!!!!

Andrea

Ritratto di AndreaCatania
AndreaCatania
(Newbie)
Offline
Newbie
Iscritto: 06/07/2013
Messaggi: 4

Finalmente ho trovato cosa mi da questo errore!!!!

https://www.copy.com/s/uWoVlW1ni2w8/20130707_095339.jpg

Quando cerco di fare l'update di KDE 4.10.2 "opensuse-2013-353" Ci sono 116 pacchetti da scaricare ed installare... io penso che sono troppi e APPER non li installa puo essere???

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1706

Io dicevo di eliminare solo le partizioni Linux e non quelle Windows, l'installer di Suse le avrebbe ricreate e formattate.

Apper è una utilità di KDE (non Suse)... Io lo disinstallato e faccio gli aggiornamenti con Yast (mai un problema), altri con il comando da shell zypper proprio perchè è troppo pieno di bug e un centinaio di aggiornamenti mi paiono troppi!!!

SO: Linux desktop Sistema: OpenSUSE Leap 15.1 (64bit) KDEE 5.12
SO: Linux desktop Sistema: OpenSUSE Tumbleweed (64bit) KDE 5
Miao

Ritratto di greywolf82
greywolf82
(Monster)
Offline
Monster
Iscritto: 07/07/2008
Messaggi: 240

Apper secondo me non ha mai funzionato a dovere, ci sono sempre problemi. Anche io l'ho rimosso dal sistema, con YaST mai un problema e soprattutto hai sempre il controllo della situazione di cosa installa e cosa no.