Utilizzare scanner (tramite Xsane) come utente normale (non root)

18 risposte [Ultimo messaggio]
Ritratto di D_RuLeZ
D_RuLeZ
(Junior)
Offline
Junior
Iscritto: 23/12/2005
Messaggi: 39

Orbene sto cercando di far funzionare il mio scanner Epson Perfection 1670 su openSUSE 11 e, dopo molte tribolazioni, direi di avercela quasi fatta!

Il fatto è che scannerizzando con Xsane da utente root funziona tutto, ma appena apro Xsane come utente normale non funziona nulla. Thinking

Qualcuno di voi sa dove diavolo devo cambiare i permessi per far funzionare Xsane (e scannerizzare) come utente normale?

Ritratto di D_RuLeZ
D_RuLeZ
(Junior)
Offline
Junior
Iscritto: 23/12/2005
Messaggi: 39

Anche tramite Kooka (bel programminoi) riesco a scannerizzare solo da root...

HELP! Sad Sad Sad

Ritratto di anubis
anubis
(Guru)
Offline
Guru
Iscritto: 07/04/2007
Messaggi: 3656

prova qui:

http://www.suseitalia.org/modules/newbb/viewtopic.php?topic_id=16329&forum=3&post_id=90934#forumpost90934

OpenSUSE Member,Packman Packager, Education Project Admin, LXDE Project Admin
Powered by http://en.opensuse.org/HP_Pavilion_dv6855el

Ritratto di D_RuLeZ
D_RuLeZ
(Junior)
Offline
Junior
Iscritto: 23/12/2005
Messaggi: 39

No niente, cambiato nulla...

Ritratto di anubis
anubis
(Guru)
Offline
Guru
Iscritto: 07/04/2007
Messaggi: 3656

fai parte del gruppo video (o di quello a cui appartiene la periferica) vero?

OpenSUSE Member,Packman Packager, Education Project Admin, LXDE Project Admin
Powered by http://en.opensuse.org/HP_Pavilion_dv6855el

Ritratto di D_RuLeZ
D_RuLeZ
(Junior)
Offline
Junior
Iscritto: 23/12/2005
Messaggi: 39

daniele@linux-29m9:~&gt; groups<br />users dialout video

Altrimenti (bypassando il problema) c'è un modo per fare partire xsane (o kooka) come root, ma senza dover inserire nessuna password?

Ritratto di D_RuLeZ
D_RuLeZ
(Junior)
Offline
Junior
Iscritto: 23/12/2005
Messaggi: 39

Up! Sad

Nessuno ha qualche idea neanche su come far partire xsane o kooka come root al volo?

Ritratto di Il_Cjargnel
Il_Cjargnel
(Guru)
Offline
Guru
Iscritto: 04/08/2005
Messaggi: 1886

aveva fatto lo stesso a me la dx 7400 e la 84000

ho risolto così!

http://www.suseitalia.org/modules/newbb/viewtopic.php?topic_id=17410&forum=3&post_id=97909#forumpost97909

mandi!

p.s. non ti chiedo nemmeno se hai installato i drivers e firmware xkè lo do x escluso che tu lo abbia fatto (O FORSE NON OCCORRE??) adesso mica mi ricordo.... ahh la vecchiaia!!! Thinking

OpenSuse 11.0+ OpenSuse 11.2

Ritratto di D_RuLeZ
D_RuLeZ
(Junior)
Offline
Junior
Iscritto: 23/12/2005
Messaggi: 39

Nulla... Sad

Nel file /etc/udev/rules.d/50-udev-default.rules avevo già messo il "666" e nel file /etc/udev/rules.d/55-libsane.rules avevo già queste due linee (a cui ho modificato il campo in "666"):

<br /><br /># Epson GT-8400UF | Epson Perfection 1670 | Epson Perfection 1670 PHOTO<br /># Epson Perfection 1670<br />SYSFS{idVendor}==&quot;04b8&quot;, SYSFS{idProduct}==&quot;011f&quot;, MODE=&quot;0666&quot;, GROUP=&quot;lp&quot;, ENV{libsane_matched}=&quot;yes&quot;<br /><br />

Cmq si ho già fatto tutta la storia di mettere il firmware (tramite questa guida trovata tramite google)

Quote:

Scanner EPSON perfection 1670

CONFIGURAZIONE DELLO SCANNER EPSON PERFECTION 1670 IN DEBIAN

DOPO AVER INSTALLATO XSANE :

COPIARE IL FILE ESFW30.BIN IN /USR/SHARE/SANE/SNAPSCAN

MODIFICARE IL FILE /ETC/SANE.D/SNAPSCAN.CONF IN DICANDO IL “PATH” DEL FIRMAWARE PUNTANDO QUINDI SUL FILE ESFW30.BIN CHE SARA’ : /USR/SHARE/SANE/SNAPSCAN

SI DEVE INOLTRE DARE IL PERMESSO ALL’UTENTE PER LACCESSO ALLO SCANNER

esempio file snapscan.conf:

# Change to the fully qualified filename of your firmware file, if
# firmware upload is needed by the scanner
firmware /usr/share/sane/SNAPSCAN/ESFW30.BIN

# If not automatically found you may manually specify a device name.

# For USB scanners also specify bus=usb, e.g.
/dev/usb/scanner0 bus=usb
# Epson Perfection 1670
usb 0×04b8 0×011f

e il driver che mi dava Yast (che mi avvertiva della necessità di procurarmi il firmware).

Mi manca solo sta stramaledetta faccenda dei permessi, altrimenti funzionerebbe tutto alla grande... :hammer:

Ritratto di Il_Cjargnel
Il_Cjargnel
(Guru)
Offline
Guru
Iscritto: 04/08/2005
Messaggi: 1886

ok x i driver !!!

riavviato la macchia e provato???

OpenSuse 11.0+ OpenSuse 11.2

Ritratto di D_RuLeZ
D_RuLeZ
(Junior)
Offline
Junior
Iscritto: 23/12/2005
Messaggi: 39

Su google si trovano 100'000 guide, ma o sono per scanner dotati di porta parallela (il mio è usb) o per il kernel 2.4 in cui c'era ancora il gruppo scanner...

Però il mio è sotto lp, magari devo aggiungere il mio utente a quel gruppo, ma non conosco il comando...