xgl si o xgl no?

21 risposte [Ultimo messaggio]
Ritratto di sub078
sub078
(Geek)
Offline
Geek
Iscritto: 07/03/2008
Messaggi: 62

Dunque cercherò di essere sintetico.
Ho settato e fatto funzionare compiz usando emerald come gestore delle decorazioni delle finestre. Tutto ok! Funziona tutto! Poi il dramma! Ho fatto un piccolo collegamento sul desktop che dasse il comando:
gnome-xgl-switch --disable-xgl per poter disabilitare compix.
poi ho creato un'altro collegamento con il seguente comando:
gnome-xgl-switch --enable-xgl e a fianco reboot per far riavviare X, ma in realtà X non si riavvia... ma vabbeh, allora riavvio il PC a mano e... DRAMMA DEI DRAMMI....
X non parte e mi da un errore tipo:
unrecognized option: reboot

Come metto a posto X?

PS se da consolle disabilito xgl è tutto ok.... ma vorrei poter disabilitare e abilitare compix senza fare sempre tutto questo caos! Grazie!

Ritratto di Il_Cjargnel
Il_Cjargnel
(Guru)
Offline
Guru
Iscritto: 04/08/2005
Messaggi: 1886

non so che scheda video hai (non ce scrittto!!!) ma io userei AIGLX che va nettamente meglio di GLX!!
poi vedi tu!

MAndi mandi

OpenSuse 11.0+ OpenSuse 11.2

Ritratto di sub078
sub078
(Geek)
Offline
Geek
Iscritto: 07/03/2008
Messaggi: 62

Quote:

Il_Cjargnel ha scritto:
non so che scheda video hai (non ce scrittto!!!) ma io userei AIGLX che va nettamente meglio di GLX!!
poi vedi tu!

MAndi mandi

è una intel 950; grazie della dritta ma come faccio ad usare AIGLX al posto di GLX?

Ritratto di Il_Cjargnel
Il_Cjargnel
(Guru)
Offline
Guru
Iscritto: 04/08/2005
Messaggi: 1886

bella domanda da 1 miliardo di euro... hai me queste schede non le conosco, e non so nemmeno se idrivers supportano AIGLX, ma credo di si, il punto però è che non conoscendole, non so come abilitare!!!
sorry!! Sad

magari altri utenti che hanno queste schede ti potranno aiutare meglio di me!

OpenSuse 11.0+ OpenSuse 11.2

Ritratto di sub078
sub078
(Geek)
Offline
Geek
Iscritto: 07/03/2008
Messaggi: 62

mmmm ok... grazie lo stesso ma come mai se abilito xgl e riavvio X mi dice unrecognized option: reboot?????
come risolvo? XGL andava benissimo.... fino a che non ho fatto quegli scriptini......

Ritratto di AL9000
AL9000
(Guru)
Offline
Guru
Iscritto: 29/10/2005
Messaggi: 1277

Quote:

sub078 ha scritto:
Dunque cercherò di essere sintetico.
Ho settato e fatto funzionare compiz usando emerald come gestore delle decorazioni delle finestre. Tutto ok! Funziona tutto! Poi il dramma! Ho fatto un piccolo collegamento sul desktop che dasse il comando:
gnome-xgl-switch --disable-xgl per poter disabilitare compix.
poi ho creato un'altro collegamento con il seguente comando:
gnome-xgl-switch --enable-xgl e a fianco reboot per far riavviare X, ma in realtà X non si riavvia... ma vabbeh, allora riavvio il PC a mano e... DRAMMA DEI DRAMMI....
X non parte e mi da un errore tipo:
unrecognized option: reboot

Come metto a posto X?

PS se da consolle disabilito xgl è tutto ok.... ma vorrei poter disabilitare e abilitare compix senza fare sempre tutto questo caos! Grazie!

penso che tu abbia fatto un pò di confusione: perchè non usi il mio metodo, indicato nella guida che ho scritto?
basta che adatti gli script indicati nella sezione OPZIONALE: ATTIVARE/DISATTIVARE AIGLX+COMPIZ CON UN CLICK alle tue esigenze: quelli scritti da me sono per chi ha seguito la mia guida, ma è semplice modificarli per ottenere il risultato che stai cercando

Quote:

Il_Cjargnel ha scritto:
non so che scheda video hai (non ce scrittto!!!) ma io userei AIGLX che va nettamente meglio di GLX!!
poi vedi tu!

A parte il fatto di avere a disposizione effetti e 3D in contemporanea, non sono assolutamente d'accordo: non sò quali siano i risultati di aiglx su schede nvidia nè su schede intel, ma su schede ATI la fluidità e la stabilità di XGL è ancora superiore a quanto si può ottenere da AIGLX

Ciao

Chi è investito di un'autorità si trasformerà inevitabilmente, secondo una legge sociale immutabile, in un oppressore ed in uno sfruttatore della società. (M.A. Bakunin)

Ritratto di Il_Cjargnel
Il_Cjargnel
(Guru)
Offline
Guru
Iscritto: 04/08/2005
Messaggi: 1886

ma su Nvidia io personalmente mit rovo meglio con aigx funziona tutto molto fluidamente senza il minimo problema in più anche googlearth funge senza problemi!

Però è vero, su ATi e men che meno INTEL non so come funziona, ma io avevo consigliato l'usao di aiglx, quando non sapevo che tipo di scheda era presente (stupidamente pensavo a nvidia)

OpenSuse 11.0+ OpenSuse 11.2

Ritratto di AL9000
AL9000
(Guru)
Offline
Guru
Iscritto: 29/10/2005
Messaggi: 1277

@ sub078

visto che stai usando XGL, meglio che segui quello che ho scritto in un mio post in questa discussione, alla sesta pagina

1) prima di tutto cancella i collegamenti che hai creato: sono questi che sballano X

2) cerca il paragrafo dove ho scritto ATTIVAZIONE XGL+COMPIZ-FUSION (su KDE) e segui le mie istruzioni.

Ciao

Chi è investito di un'autorità si trasformerà inevitabilmente, secondo una legge sociale immutabile, in un oppressore ed in uno sfruttatore della società. (M.A. Bakunin)

Ritratto di sub078
sub078
(Geek)
Offline
Geek
Iscritto: 07/03/2008
Messaggi: 62

uhm..... ok ma.... non ho ancora risolto il problema! Uff..... come faccio? dite che se disinstallo tutto compiz ed emerald e poi lo rimetto risolvo qualcosa? Grazie.....,

Ritratto di AL9000
AL9000
(Guru)
Offline
Guru
Iscritto: 29/10/2005
Messaggi: 1277

no no, non disinstallare niente: calma, va tutto bene!

devi solo cancellare i collegamenti che hai creato.

oppure modifica quello dove hai inserito il comando reboot, togliendo questo comando: è proprio reboot che sballa tutto, lo hai inserito male, come se fosse un'opzione del comando gnome-xgl-switch (invece non lo è)

Fatto questo, segui quello che ho scritto nella discussione che ti ho segnalato (non la guida, che è per AIGLX, ma la discussione dove parlo di XGL)

Ciao

Chi è investito di un'autorità si trasformerà inevitabilmente, secondo una legge sociale immutabile, in un oppressore ed in uno sfruttatore della società. (M.A. Bakunin)

Ritratto di sub078
sub078
(Geek)
Offline
Geek
Iscritto: 07/03/2008
Messaggi: 62

Quote:

AL9000 ha scritto:
no no, non disinstallare niente: calma, va tutto bene!

devi solo cancellare i collegamenti che hai creato.

oppure modifica quello dove hai inserito il comando reboot, togliendo questo comando: è proprio reboot che sballa tutto, lo hai inserito male, come se fosse un'opzione del comando gnome-xgl-switch (invece non lo è)

Fatto questo, segui quello che ho scritto nella discussione che ti ho segnalato (non la guida, che è per AIGLX, ma la discussione dove parlo di XGL)

Ciao

ok... ma il problema è proprio questo... il comando che ho creato sul desktop l'ho cancellato quindi sto cavolo di reboot si deve essere insediato da qualche altra parte ma non so assolutamente dove possa essere!!!! Ho controllato xorg.conf ma li non c'è e non saprei dove altro guardare!