xgl si o xgl no?

Ritratto di AL9000
AL9000
(Guru)
Offline
Guru
Iscritto: 29/10/2005
Messaggi: 1277

disabilita XGL con
gnome-xgl-switch --disable-xgl
poi dai reboot

poi procedi come ti ho indicato

Ciao

Chi è investito di un'autorità si trasformerà inevitabilmente, secondo una legge sociale immutabile, in un oppressore ed in uno sfruttatore della società. (M.A. Bakunin)

Ritratto di sub078
sub078
(Geek)
Offline
Geek
Iscritto: 07/03/2008
Messaggi: 62

Quote:

AL9000 ha scritto:
disabilita XGL con
gnome-xgl-switch --disable-xgl
poi dai reboot

poi procedi come ti ho indicato

Ciao

Ho disabilitato xgl con il comando gnome.... etc etc... riavvio e tutto ok... ma se rimetto xgl e riavvio mi da questo errore:

Fatal error
Unrecognized option: reboot
Giving up
xinit: no such file or directory (err no:2)....
xinit: no such process (err no:3) unable to connect to server X

Che faccio??? Sono troppo fighi gli effetti desktop!!!!!!

Ritratto di AL9000
AL9000
(Guru)
Offline
Guru
Iscritto: 29/10/2005
Messaggi: 1277

no, forse non ci siamo capiti:

per riabilitare XGL non devi scrivere
gnome-xgl-switch --enable-xgl reboot
perchè è errato: reboot, in questo modo, lo passi come opzione del comando gnome-xgl-switch e non è corretto.

devi scrivere
gnome-xgl-switch --enable-xgl
e premere invio

e poi riavvii con reboot (e di nuovo invio)

Comunque, se seguissi il mio post su XGL che ti ho consigliato prima faresti tutto con un click.

Ciao

Chi è investito di un'autorità si trasformerà inevitabilmente, secondo una legge sociale immutabile, in un oppressore ed in uno sfruttatore della società. (M.A. Bakunin)

Ritratto di sub078
sub078
(Geek)
Offline
Geek
Iscritto: 07/03/2008
Messaggi: 62

esattamente il comando che do è quello:
gnome-xgl-switch --enable-xgl

poi IO RIAVVIO ma mi da gli errori di cui sopra!!!! Sto reboot dove cavolo si è andato ad infilare?????

Ritratto di AL9000
AL9000
(Guru)
Offline
Guru
Iscritto: 29/10/2005
Messaggi: 1277

postami il contenuto del file /etc/sysconfig/displaymanager

Chi è investito di un'autorità si trasformerà inevitabilmente, secondo una legge sociale immutabile, in un oppressore ed in uno sfruttatore della società. (M.A. Bakunin)

Ritratto di sub078
sub078
(Geek)
Offline
Geek
Iscritto: 07/03/2008
Messaggi: 62

Quote:

AL9000 ha scritto:
postami il contenuto del file /etc/sysconfig/displaymanager

Eccolo:
## Path: Desktop/Display manager
## Type: string(Xorg,Xgl)
## Default: "Xorg"
#
# Xgl is an experimental Xserver using OpenGL for rendering.
# Right now only the glx backend is supported, which runs on top of a
# standard Xorg server providing OpenGL.
# Set this to 'Xgl' and run SuSEconfig only if you want to run your
# displaymanager (kdm/gdm/xdm) on Xgl on top of Xorg.
# This setting is case sensitive.
# Warning! This is highly experimental.
#
DISPLAYMANAGER_XSERVER="Xorg"
## Path: Desktop/Display manager
## Type: string
## Default: "-accel glx:pbuffer -accel xv:pbuffer"
#
# Xglx is an experimental Xserver using OpenGL for rendering.
# Additional options for startup when using a display manager.
# You can try
# "-accel glx"
# or
# "-accel glx:pbuffer"
# in order to get accelerated indirect OpenGL rendering for 3D applications.
# You can also try
# "-accel xv"
# to accelerate XVideo color space conversion and/or scaling.
#
# See also /usr/share/doc/packages/xgl/README.SUSE
#

## Path: Desktop/Display manager
## Description: settings to generate a proper displaymanager config
## Config: xdm,kdm,gdm
## Type: string(kdm,xdm,gdm,wdm,console)
## Default: ""
#
# Here you can set the default Display manager (kdm/xdm/gdm/wdm/console).
# all changes in this file require a restart of the displaymanager
#
DISPLAYMANAGER="kdm"

## Type: yesno
## Default: no
#
# Allow remote access (XDMCP) to your display manager (xdm/kdm/gdm). Please note
# that a modified kdm or xdm configuration, e.g. by KDE control center
# will not be changed. For gdm, values will be updated after change.
# XDMCP service should run only on trusted networks and you have to disable
# firewall for interfaces, where you want to provide this service.
#
DISPLAYMANAGER_REMOTE_ACCESS="no"

## Type: yesno
## Default: no
#
# Allow remote access of the user root to your display manager. Note
# that root can never login if DISPLAYMANAGER_SHUTDOWN is "auto" and
# System/Security/Permissions/PERMISSION_SECURITY is "paranoid"
#
DISPLAYMANAGER_ROOT_LOGIN_REMOTE="no"

## Type: yesno
## Default: yes
#
# Let the displaymanager start a local Xserver.
# Set to "no" for remote-access only.
# Set to "no" on architectures without any Xserver (e.g. s390/s390x).
#
DISPLAYMANAGER_STARTS_XSERVER="yes"

## Type: yesno
## Default: no
#
# TCP port 6000 of Xserver. When set to "no" (default) Xserver is
# started with "-nolisten tcp". Only set this to "yes" if you really
# need to. Remote X service should run only on trusted networks and
# you have to disable firewall for interfaces, where you want to
# provide this service. Use ssh X11 port forwarding whenever possible.
#
DISPLAYMANAGER_XSERVER_TCP_PORT_6000_OPEN="no"

## Type: string
## Default:
#
# Define the user whom should get logged in without request. If string
# is empty, display standard login dialog.
#
DISPLAYMANAGER_AUTOLOGIN="giuseppe"

## Type: yesno
## Default: no
#
# Allow all users to login without password, but ask for the user, if
# DISPLAYMANAGER_AUTOLOGIN is empty.
#
DISPLAYMANAGER_PASSWORD_LESS_LOGIN="no"

## Type: yesno
## Default: no
#
# Display a combobox for Active Directory domains.
#
DISPLAYMANAGER_AD_INTEGRATION="no"

## Type: list(root,all,none,auto)
## Default: auto
#
# Determine who will be able to shutdown or reboot the system in kdm
# and gdm. Valid values are: "root" (only root can shutdown), "all"
# (everybody can shutdown), "none" (nobody can shutdown from
# displaymanager), "auto" (follow
# System/Security/Permissions/PERMISSION_SECURITY to decide: "easy
# local" is equal to "all", everything else is equal to "root"). Note
# that remote user can never shutdown in GDM.
#
DISPLAYMANAGER_SHUTDOWN="auto"

## Type: string
## Default: "auto"
#
# Mode to configure on output devices by default
# (RANDR 1.2 compatible drivers only).
#
# If set to "auto", DISPLAYMANAGER_RANDR_MODE_auto is used on laptops, and
# the empty string on workstations.
#
# The output is not explicitly enabled (read: disabled) if set to an empty
# string.
# If the variable contains a fully configured modeline (see default of
# DISPLAYMANAGER_RANDR_MODE_auto), the mode is defined and set.
# If the variable contains a mode name only, the mode has to be defined
# already.
#
# If a monitor is attached during Xstartup, or when invoking "xrandr --auto"
# during runtime, the output is correctly configured and a mode is
# automatically selected if none has been used so far.
#
# Variables are checked according to their extension for
# VGA DVI_I DVI_D DVI_A Composite S_Video Component LFP Proprietary
#
DISPLAYMANAGER_RANDR_MODE_VGA="auto"

## Type: string
## Default: "1024x768_60 64.11 1024 1080 1184 1344 768 769 772 795 -HSync +Vsync"
#
# Mode to use for laptops for DISPLAYMANAGER_RANDR_MODE_* on laptops only,
# when the according variable is set to "auto".
# (RANDR 1.2 compatible drivers only).
#
DISPLAYMANAGER_RANDR_MODE_auto="1024x768_60 64.11 1024 1080 1184 1344 768 769 772 795 -HSync +Vsync"
## Path: Desktop/Display manager
## Description: settings to generate a proper displaymanager config
## Type: string
## Default:
## Config: kdm3
#
# space separated list of users for which icons should be shown in KDM
# if empty, then take system defaults
#
KDM_USERS=""

## Type: string
## Default:
#
# Special greeting words in kdm
#
KDM_GREETSTRING=""

## Type: string
## Default: SUSE
#
# Define the theme to be used by kdm. If empty, the traditional login
# window is used (which lacks some features)
#
DISPLAYMANAGER_KDM_THEME="SUSE"

Ritratto di AL9000
AL9000
(Guru)
Offline
Guru
Iscritto: 29/10/2005
Messaggi: 1277

ok, in questo momento stai usando xorg.

ti spiego un paio di cose:
prima che introducessero il comando gnome-xgl-switch (che, dopo il tuo intervento con i collegamenti sul desktop, ti dà quel problema) XGL si abilitava modificando questo file.

Allora: fatti una copia di questo file nella tua home, così se il tentativo che stai per fare va male basterà copiare il displaymanager attuale (quello che avrai messo nella tua home) nella cartella /etc/sysconfig (confermando la sovrascrittura) per riportare tutto a com'è ora.

ora dai questo comando (e inserisci la password di amministratore quando ti verrà chiesto)
kdesu kwrite /etc/sysconfig/displaymanager
seleziona tutto e cancella, senza chiudere kwrite

ora seleziona tutto il listato qui sotto e inseriscilo in kwrite:
## Path:        Desktop/Display manager<br />## Type:        string(Xorg,Xgl)<br />## Default:     &quot;Xorg&quot;<br />#<br /># Xgl is an experimental Xserver using OpenGL for rendering.<br /># Right now only the glx backend is supported, which runs on top of a<br /># standard Xorg server providing OpenGL.<br /># Set this to &#039;Xgl&#039; and run SuSEconfig only if you want to run your<br /># displaymanager (kdm/gdm/xdm) on Xgl on top of Xorg.<br /># This setting is case sensitive.<br /># Warning! This is highly experimental.<br />#<br />DISPLAYMANAGER_XSERVER=&quot;Xgl&quot;<br />## Path:        Desktop/Display manager<br />## Type:        string<br />## Default:     &quot;-accel glx:pbuffer -accel xv:pbuffer&quot;<br />#<br /># Xglx is an experimental Xserver using OpenGL for rendering.<br /># Additional options for startup when using a display manager.<br /># You can try<br />#   &quot;-accel glx&quot;<br /># or<br />#   &quot;-accel glx:pbuffer&quot;<br /># in order to get accelerated indirect OpenGL rendering for 3D applications.<br /># You can also try<br />#   &quot;-accel xv&quot;<br /># to accelerate XVideo color space conversion and/or scaling.<br />#<br /># See also /usr/share/doc/packages/xgl/README.SUSE<br />#<br />DISPLAYMANAGER_XGL_OPTS=&quot;-accel glx:pbuffer -accel xv:pbuffer&quot;<br />## Path:      Desktop/Display manager<br />## Description:    settings to generate a proper displaymanager config<br />## Config:      xdm,kdm,gdm<br /><br />## Type:        string(kdm,xdm,gdm,wdm,console)<br />## Default:        &quot;&quot;<br />#<br /># Here you can set the default Display manager (kdm/xdm/gdm/wdm/console).<br /># all changes in this file require a restart of the displaymanager<br />#<br />DISPLAYMANAGER=&quot;kdm&quot;<br /><br />## Type:       yesno<br />## Default:  no<br />#<br /># Allow remote access (XDMCP) to your display manager (xdm/kdm/gdm). Please note<br /># that a modified kdm or xdm configuration, e.g. by KDE control center<br /># will not be changed. For gdm, values will be updated after change.<br /># XDMCP service should run only on trusted networks and you have to disable<br /># firewall for interfaces, where you want to provide this service.<br />#<br />DISPLAYMANAGER_REMOTE_ACCESS=&quot;no&quot;<br /><br />## Type:      yesno<br />## Default:  no<br />#<br /># Allow remote access of the user root to your display manager. Note<br /># that root can never login if DISPLAYMANAGER_SHUTDOWN is &quot;auto&quot; and<br /># System/Security/Permissions/PERMISSION_SECURITY is &quot;paranoid&quot;<br />#<br />DISPLAYMANAGER_ROOT_LOGIN_REMOTE=&quot;no&quot;<br /><br />## Type:  yesno<br />## Default:  yes<br />#<br /># Let the displaymanager start a local Xserver.<br /># Set to &quot;no&quot; for remote-access only.<br /># Set to &quot;no&quot; on architectures without any Xserver (e.g. s390/s390x).<br />#<br />DISPLAYMANAGER_STARTS_XSERVER=&quot;yes&quot;<br /><br />## Type:        yesno<br />## Default:     no<br />#<br /># TCP port 6000 of Xserver. When set to &quot;no&quot; (default) Xserver is<br /># started with &quot;-nolisten tcp&quot;. Only set this to &quot;yes&quot; if you really<br /># need to. Remote X service should run only on trusted networks and<br /># you have to disable firewall for interfaces, where you want to<br /># provide this service. Use ssh X11 port forwarding whenever possible.<br />#<br />DISPLAYMANAGER_XSERVER_TCP_PORT_6000_OPEN=&quot;no&quot;<br /><br />## Type:    string<br />## Default:<br />#<br /># Define the user whom should get logged in without request. If string<br /># is empty, display standard login dialog.<br />#<br />DISPLAYMANAGER_AUTOLOGIN=&quot;giuseppe&quot;<br /><br />## Type:        yesno<br />## Default:     no<br />#<br /># Allow all users to login without password, but ask for the user, if<br /># DISPLAYMANAGER_AUTOLOGIN is empty.<br />#<br />DISPLAYMANAGER_PASSWORD_LESS_LOGIN=&quot;no&quot;<br /><br />## Type:        yesno<br />## Default:     no<br />#<br /># Display a combobox for Active Directory domains.<br />#<br />DISPLAYMANAGER_AD_INTEGRATION=&quot;no&quot;<br /><br />## Type:    list(root,all,none,auto)<br />## Default: auto<br />#<br /># Determine who will be able to shutdown or reboot the system in kdm<br /># and gdm. Valid values are: &quot;root&quot; (only root can shutdown), &quot;all&quot;<br /># (everybody can shutdown), &quot;none&quot; (nobody can shutdown from<br /># displaymanager), &quot;auto&quot; (follow<br /># System/Security/Permissions/PERMISSION_SECURITY to decide: &quot;easy<br /># local&quot; is equal to &quot;all&quot;, everything else is equal to &quot;root&quot;). Note<br /># that remote user can never shutdown in GDM.<br />#<br />DISPLAYMANAGER_SHUTDOWN=&quot;auto&quot;<br /><br />## Type:        string<br />## Default:     &quot;auto&quot;<br />#<br /># Mode to configure on output devices by default<br /># (RANDR 1.2 compatible drivers only).<br />#<br /># If set to &quot;auto&quot;, DISPLAYMANAGER_RANDR_MODE_auto is used on laptops, and<br /># the empty string on workstations.<br />#<br /># The output is not explicitly enabled (read: disabled) if set to an empty<br /># string.<br /># If the variable contains a fully configured modeline (see default of<br /># DISPLAYMANAGER_RANDR_MODE_auto), the mode is defined and set.<br /># If the variable contains a mode name only, the mode has to be defined<br /># already.<br />#<br /># If a monitor is attached during Xstartup, or when invoking &quot;xrandr --auto&quot;<br /># during runtime, the output is correctly configured and a mode is<br /># automatically selected if none has been used so far.<br />#<br /># Variables are checked according to their extension for<br />#    VGA DVI_I DVI_D DVI_A Composite S_Video Component LFP Proprietary<br />#<br />DISPLAYMANAGER_RANDR_MODE_VGA=&quot;auto&quot;<br />#DISPLAYMANAGER_RANDR_MODE_DVI_I=&quot;&quot;<br />#DISPLAYMANAGER_RANDR_MODE_DVI_D=&quot;&quot;<br />#DISPLAYMANAGER_RANDR_MODE_DVI_A=&quot;&quot;<br />#DISPLAYMANAGER_RANDR_MODE_Compsite=&quot;&quot;<br />#DISPLAYMANAGER_RANDR_MODE_S_Video=&quot;&quot;<br />#DISPLAYMANAGER_RANDR_MODE_Component=&quot;&quot;<br />#DISPLAYMANAGER_RANDR_MODE_LFP=&quot;&quot;<br />#DISPLAYMANAGER_RANDR_MODE_Proprietary=&quot;&quot;<br /><br />## Type:        string<br />## Default:     &quot;1024x768_60 64.11 1024 1080 1184 1344 768 769 772 795 -HSync +Vsync&quot;<br />#<br /># Mode to use for laptops for DISPLAYMANAGER_RANDR_MODE_* on laptops only,<br /># when the according variable is set to &quot;auto&quot;.<br /># (RANDR 1.2 compatible drivers only).<br />#<br />DISPLAYMANAGER_RANDR_MODE_auto=&quot;1024x768_60 64.11 1024 1080 1184 1344 768 769 772 795 -HSync +Vsync&quot;<br />## Path:   Desktop/Display manager<br />## Description: settings to generate a proper displaymanager config<br />## Config:      kdm3<br /><br />## Type:    string<br />## Default: <br />#<br /># space separated list of users for which icons should be shown in KDM<br /># if empty, then take system defaults<br />#<br />KDM_USERS=&quot;&quot;<br /><br />## Type:    string<br />## Default: <br />#<br /># Special greeting words in kdm<br />#<br />KDM_GREETSTRING=&quot;&quot;<br /><br />## Type:        string<br />## Default:     SUSE<br />#<br /># Define the theme to be used by kdm. If empty, the traditional login<br /># window is used (which lacks some features)<br /># <br />DISPLAYMANAGER_KDM_THEME=&quot;SUSE&quot;<br />
ora salva e chiudi kwrite.

Riavvia, dovrebbe abilitarti XGL

Se non funzia dai, da root, il comando qui sotto per riportare tutto a com'era prima:
mv /home/tuonome/displaymanager /etc/sysconfig/
e poi riavvia.

Fammi sapere, ciao

Chi è investito di un'autorità si trasformerà inevitabilmente, secondo una legge sociale immutabile, in un oppressore ed in uno sfruttatore della società. (M.A. Bakunin)

Ritratto di sub078
sub078
(Geek)
Offline
Geek
Iscritto: 07/03/2008
Messaggi: 62

Niente da fare... Il problema rimane... Non riesco proprio a capire... Mi sa che dovrò rinunciare alla figata degli effetti 3D UFFFFFFF

Ritratto di sub078
sub078
(Geek)
Offline
Geek
Iscritto: 07/03/2008
Messaggi: 62

Altro piccolo pezzetto, non so di preciso cosa è successo ma nel file displaymanager ho tolto l'opzione pbuffer da accel xgl e accel xv e ho riavviato, questo è stato il risultato quando do startx:
INTEL: No matching Device section for istance (BusID:0:2:1) found
Intel(O):[dri] I830driAvaible failed: DRI not found

Che ci sia un problema al dri? solo che non ho la piu' pallida idea di cosa esso sia!
Big Grin

Qualche altro consiglio?
Grazie....

Ritratto di AL9000
AL9000
(Guru)
Offline
Guru
Iscritto: 29/10/2005
Messaggi: 1277

dri=direct rendering

ma ce l'hai il 3D dei driver? voglio dire: se avvii un'applicazione che sfrutta il 3D (qualche gioco, google earth ecc.), parte o ti da errore?

perchè se non hai il 3D non puoi usare XGL, semmai aiglx...ma con schede intel non so come si fa

ciao

Chi è investito di un'autorità si trasformerà inevitabilmente, secondo una legge sociale immutabile, in un oppressore ed in uno sfruttatore della società. (M.A. Bakunin)