coll. internet suse 10.1 modem 56k su laptop

Nessuna risposta
Ritratto di 3121n
3121n
(Newbie)
Offline
Newbie
Iscritto: 25/09/2006
Messaggi: 1

ciao a tutti sono nuovo per quanto riguarda linux, spero di riuscire al più presto di abbandonare WXP, ma il problema è che, necessitando della rete non riesco a collegarmi con un portatile e la versione 10.1.
ore ne kinternet ne yast riescono a collegarsi con modem che viene riconosciuto da yast come elitegroup AC 97 modem controller.
ho caricato kernel source, ho installato slmodem avendo i seguenti passaggi da file read me:
1. Unpack tar.gz package file:

$ gzip -dc slmodem-2.9.X.tar.gz | tar xf -

2. 'cd' to package directory:

$ cd slmodem-2.9.X

3. Review and edit 'Makefile' (if need):

In many cases you will need to correct path to your local kernel
source tree:

KERNEL_DIR=/path/to/linux

Default KERNEL_DIR is '/lib/modules/<kerne-version>/build'. Many Linux
Distributions use directory '/usr/src/linux-<version>' also.

Note: If you are using Linux kernel 2.4, only header files should be
available for build in $(KERNEL_DIR)/include

Another way to pass right value KERNEL_DIR is to use command line
parameter while running 'make':

$ make KERNEL_DIR=/path/to/linux ...

4. Run 'make' command to compile package:

$ make

5. Install. As 'root' user run:

# make install

It will install:

- application 'slmodemd' under '/usr/sbin' directory

- hardware specific drivers (kernel modules) 'slamr' and 'slusb'
under conventional kernel modules directory

- character device nodes '/dev/slamr0-3' with major number 212
(for pci modems) and '/dev/slusb0-3' with major number 213
(for usb modems).

- config modules for autoloading (by editing file '/etc/modules.conf')
(only with 2.4 kernels)

Getting Started
===============

After successful installation and configuration:

1. Load modem driver.

Load your modem hardware specific kernel module:

# modprobe slamr

if you are using AMR/CNR/PCI modem, or

# modprobe slusb

if you are using SmartUSB56 Modem.

Note: this will be done automatically when modules were
configured for 'loading on demand'

Note: this is safe to load both 'alamr' and 'slusb' modules.

2. Run soft modem application.

# /usr/sbin/slmodemd <device_name>

Where device name is appropriate device node for your modem
(look at output of 'dmesg' command).
Run '/usr/sbin/slmodemd --help' for details.

Examples:

# /usr/sbin/slmodemd --country=USA /dev/slamr0

, or for SmartUSB56 Modems:

# /usr/sbin/slmodemd --country=ITALY /dev/slusb0

3. Using the modem.

When 'slmodemd' is running this creates PTY (pseudo-terminal) to
emulate modem port device, also this creates symbolic link
like '/dev/ttySL0' (shown at startup).

Config your application to use this link '/dev/ttySL0' (or PTY node
itself) as modem port.

Note: Some application want 'to know' that they are working with
pseudo-terminal and may require additional configurations.

Known application notes:

- 'wvdial' requires option 'Carrier Check = no' in config file

- some versions of 'kppp' may not work properly with devices named
like '/dev/ttySL0'. To workaround this you may create symbolic link
'/dev/modem' ( # ln -s /dev/ttySL0 /dev/modem ) and use this link
as modem device with 'kppp'

- some pci modem devices are declared as COMMUNICATION_MODEM class and
might be caught by other standard drivers - you will see "grabbed
by another driver" warning in dmesg buffer. There is no good way to
"release" it, but as silly workaround you may use 'ungrab-winmodem'
pseudo-driver from http://linmodems.technion.ac.il/packages/smartlink.
Note that you should load it before 'slamr' module.

4. Startup automation.

There are examples of startup scripts in 'scripts' directory.

tutto da root:
1-ho scompattato il tutto

2-da dentro la cartella slmodem ho aperto la konsole e digitato "make"

3- come sopra "make install"

e sembra installato

4-poi da konsole ho digit. # modprobe slamr
ma non succede nulla, allora ho provato da riga di comando ma nulla

5- entro in # /usr/sbin/ e trovo un file <slmodemd> apro console e digit. # /usr/sbin/slmodemd modem0, ma non succede nulla

impostati i parametri n° tel, log e psw mi da sempre "modem occupato"

vi ringrazio in anticipo per l'eventuale aiuto

welcome to the dawn