Connessione wifi

5 risposte [Ultimo messaggio]
Ritratto di misamisa
misamisa
(Newbie)
Offline
Newbie
Iscritto: 30/04/2014
Messaggi: 4

Buongiorno, sono nuovo del forum e del mondo Linux in generale, sono riuscito ad installare
con qualche difficoltà opensuse 12.2 e le guide mi son state utilissime. Purtroppo non riesco a connettere il pc alla rete wifi, qualcuno può venire in mio soccorso e guidarmi passo passo? Ho un Amd athlon(tm) 64 x2 dual core processor 4400+, RAM 2,2 gb, nvidia GeForce 6150 LE

Ritratto di Sargon6
Sargon6
(Guru)
Offline
Guru
Iscritto: 13/11/2008
Messaggi: 723

Anche io ho avuto qualche difficoltà ad avviare il network manager.
Riporto il procedimento da me usato. Vedi se può esserti utile.

Per poter navigare in Internet, ho proceduto come segue.
STRANAMENTE Network Manager è installato ma non abilitato -cosa che causa l'impossibilità di selezionare "Senza fili", "Abilita banda larga mobile", e "DSL"-, quindi il problema si può risolvere senza installare nulla. Per farlo, occorre:
1) Aprire YaST
2) Cliccare su "Impostazioni di rete" (è un'applicazione raggruppata sotto la voce "Dispositivi di rete")
3) Attendere che Yast trovi le informazioni che gli servono per proseguire (la cosa non è immediata...)
4) Nel pannello che si apre, selezionare la voce "Opzioni Globali"
5) Spuntare correttamente il "Metodo di configurazione di rete"; deve essere impostato su "Controllato dall'utente con NetworkManager", non su "Metodo tradizionale con ifup"
6) Cliccare su OK
7) Spegnere e riaccendere il computer.
8 ) Configurare opportunamente Network Manager.

Nel mio blog, ho scritto delle cose che forse ti interessano.
http://www.suseitalia.org/blog/9923

Ritratto di misamisa
misamisa
(Newbie)
Offline
Newbie
Iscritto: 30/04/2014
Messaggi: 4

Grazie sargon6 per la tua attenzione, in effetti sono proprio un inesperto ed ho bisogno molto di essere aiutato, la prima parte delle operazioni che mi hai descritto mi si presenta in inglese ma penso di esserci riuscito ugualmente, quando do l'ok per il metodo di configurazione di rete mi esce una finestra che dice "Applet richiesta. NetworkManager è controllato da un'applet desktop(knetworkmanager per KDE e nm-applet per GNOME). Assicurarsi che sia in esecuzione, altrimenti avviarla manualmente. "
Io a questo punto dico ok, ma durante il salvataggio della
Configurazione di rete all'ultimo passo( esecuzione di suseconfig) mi dice "Errore, nessuna rete in funzione"
Cosa posso fare??

Ritratto di Sargon6
Sargon6
(Guru)
Offline
Guru
Iscritto: 13/11/2008
Messaggi: 723

misamisa, abbi pazienza, ma devi essere più preciso.
Io ti ho elencato 8 cose da fare, e scrivere "la prima parte delle operazioni che mi hai descritto mi si presenta in inglese ma penso di esserci riuscito ugualmente" senza scrivere quali delle 8 sei riuscito a mettere in pratica, non mi aiuta a capire a che punto sei.

Nel mio blog, ho scritto delle cose che forse ti interessano.
http://www.suseitalia.org/blog/9923

Ritratto di misamisa
misamisa
(Newbie)
Offline
Newbie
Iscritto: 30/04/2014
Messaggi: 4

Chiedo perdono. Mi riferivo al punto 6). Dopo aver dato ok mi ha presentato l'errore che ho descritto. Dopodiché ho provato a spegnere e riaccendere ed a quanto pare al momento il metodo di configurazione di rete è impostato su " controllato dall'utente con network manager".
Io però network manager non lo trovo da nessuna parte...
Help

Ritratto di SilverHawk
SilverHawk
(Geek)
Offline
Geek
Iscritto: 31/05/2014
Messaggi: 180

NetworkManager è un servizio, e non ha un pannello di controllo vero e proprio (a mo' di YaST per intenderci). Di fatto si configura solo tramite l'icona che di solito si trova in basso a destra a fianco dell'orologio.
Come indicato da Saragon6, durante l'installazione NetworkManager potrebbe essere stato rimpiazzato dal metodo tradizionale IfUp (e da qui l'inizio dei tuoi problemi). Prova a ripercorrere i passi indicati da Saragon6 e rispondi punto per punto se ti trovi o noti qualcosa di differente:
1) Aprire YaST
2) Cliccare su "Impostazioni di rete" (è un'applicazione raggruppata sotto la voce "Dispositivi di rete")
3) Attendere che Yast trovi le informazioni che gli servono per proseguire (la cosa non è immediata...)
4) Nel pannello che si apre, selezionare la voce "Opzioni Globali" (SH: è la prima scheda a sinistra)
5) Spuntare correttamente il "Metodo di configurazione di rete"; deve essere impostato su "Controllato dall'utente con NetworkManager", non su "Metodo tradizionale con ifup" (SH: deve essere selezionato il primo pallino fra i due)
6) Cliccare su OK
7) Spegnere e riaccendere il computer.
8 ) Configurare opportunamente Network Manager.
A presto
Ciao

EDIT: Credo di aver capito! Ti funziona tutto, e probabilmente benone: semplicemente non è stata creata in automatico la connessione via wireless perché NM non può farlo in autonomia (non ha i dati). Da qui il messaggio "Nessuna rete in funzione".
Una volta acceso il PC, fai click sull'icona della rete, seleziona "Gestione connessioni" (o relativo in inglese) e crea una "Nuova connessione wireless": segui i passaggi e dicci cosa ottieni.
In alternativa, a fianco di "Gestione connessioni" c'è la voce "Mostra altro" con un + in verde: ti mostra le connessioni wireless a portata di raggio, basta che fai click su quella che ti interessa, metti la password e dai OK. Voilà.