Firefox extension

10 risposte [Ultimo messaggio]
Ritratto di stefanet
stefanet
(Junior)
Offline
Junior
Iscritto: 28/12/2011
Messaggi: 17

Buongiorno,

ieri ho installato opensuse 12.1 64 bit sul nuovo pc, ma ho dei problemi nell'installazione delle estensioni di firefox.

Ovvero ogni addons che vado ad installare mi viene mostrato il messaggio dell'incompatibilità dell'addons con firefox 9.
Ho provato a mettere una versione precedente di firefox (la 8), ma mi da lo stesso errore.

Sul portatile di lavoro ho lo stesso sistema, ma riesco ad installare le stesse estensioni che non riesco ad installare sul nuovo sistema.

Quale potrebbe essere il problema?

Grazie
Stefano

Ritratto di Suse99
Suse99
(Monster)
Offline
Monster
Iscritto: 15/07/2011
Messaggi: 280

1 Cosa benvenuto!!!
2 non so se questo ti puo' servire io ho capito che firefox non si avvia vero? http://support.mozilla.com/it/kb/Firefox%20non%20si%20avvia

Suse99, Opensuse 13.1 gnome 64bit,Processore: Intel Core i5, Scheda grafica: NVIDIA gtx 760

Ritratto di stefanet
stefanet
(Junior)
Offline
Junior
Iscritto: 28/12/2011
Messaggi: 17

Scusatemi per la mia "ignoranza" Kiss , è che scrivo di rado nei forum e ogni volta non so bene cosa fare Raised Eyebrow

Firefox si avvia correttamente, ma ogni volta che provo ad installare un componente aggiuntivo mi viene detto che quel componente non è supportato da firefox 9 e quindi non viene installato e/o è disabilitato.
Questo lo fa con tutti i componenti aggiuntivi, quelli che ho provato e che generalmente uso sono "Web Developer", "DOM Inspector", "Download Helper", "Down Them All" per dire i più utilizzati e che tra l'altro sto utilizzando sul portatile con cui sto scrivendo che è in toto o quasi identico al PC fisso che mi sta dando i problemi.

Può essere un problema di profilo? Anche se sinceramente ci credo poco.

Ho provato anche a lanciare Firefox anche da command line per vedere se mostrava messaggi particolari, ma nulla.
C'è la possibilità di eseguire firefox in debug mode?

Grazie

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2754

http://support.mozilla.com/it/kb/Impossibile%20installare%20componenti%20aggiuntivi

SUSE Tumbleweed- kernel-5.19.7-1 kde-plasma-5.25.5.1.2 Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.143-SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di stefanet
stefanet
(Junior)
Offline
Junior
Iscritto: 28/12/2011
Messaggi: 17

Proverò a fare quello che dice sul link che mi hai postato, anche se non mi sembra di ricadere in nessuna delle problematiche descritte...

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2754

http://support.mozilla.com/it/kb/Risoluzione%20dei%20problemi%20relativi%20a%20estensioni%20e%20temi
questo è inerente al tuo problema,cmq è strana la cosa,mai successso una cosa cosi.

SUSE Tumbleweed- kernel-5.19.7-1 kde-plasma-5.25.5.1.2 Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.143-SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di wal7er
wal7er
(Guru)
Offline
Guru
Iscritto: 21/09/2007
Messaggi: 572

Magari se mettessi l'elenco delle estensioni con la versione potremmo esseri più d'aiuto.
Quelle da te citate e funzionanti (le ho installate) su firefox 9.0.1:

Down Them All 2.0.8
Download Helper 4.9.8

Per quanto riguarda "Web Developer", "DOM Inspector" se ti va, e no lo hai già provato, puoi provare firebug 1.8.4 che integra le funzionalità dei due precedenti (e forse c'ha qualcosa in più).

In qualche caso può succedere che la versione vecchia non si autoaggiorni all'ultima: in questi casi prova a disinstallare prima e ad effettuare una installazione con l'ultima versione disponibile online.

HP Pavilion dv5-1110el powered by OpenSUSE 13.2 64bit

http://linuxcounter.net/cert/432576.png

Ritratto di stefanet
stefanet
(Junior)
Offline
Junior
Iscritto: 28/12/2011
Messaggi: 17

Le versioni che sto tentando di installare sono le ultime, ovvero:

DOM Inspector 2.0.10
Web Developer 1.1.9
Download Helper 4.9.8
DownThemAll 2.0.8

Purtroppo ora non posso fare prove in quanto sono a lavoro...

Comunque stasera farò dei tentativi...

Ritratto di Sarkiapone
Sarkiapone
(Webmaster)
Offline
Webmaster
Iscritto: 04/09/2004
Messaggi: 743

wal7er ha scritto:

Per quanto riguarda "Web Developer", "DOM Inspector" se ti va, e no lo hai già provato, puoi provare firebug 1.8.4 che integra le funzionalità dei due precedenti (e forse c'ha qualcosa in più).

Ti consiglio anche io Firebug, molto più comodo di Web Developer e Dom Inspector Smile

Ritratto di furlan
furlan
(Geek)
Offline
Geek
Iscritto: 14/10/2004
Messaggi: 147

Solo un appunto, molto spesso le estensioni "perdono" la compatibilità perché hanno impostato il numero di versione con cui sono compatibili. La perdono quindi in modo fittizio.
Più che altro con la bella idea di aumentare di versione ogni volta che si corregge un bug (+ o -) le estensioni divengono obosolete spesso e volentieri.
Un esempio su tutti è l'estensione per kwallet che mi obbliga (non essendo ancora stata aggiornata) a mantenere Firefox 8 sulla mia Suse.
Il mio consiglio è quindi di mantenere Firefox 8 (ed in genere ogni versione) per un paio di settimane dal rilascio prima di fare l'upgrade.

Gianluca

Gianluca - furlan
www.morolandia.wordpress.com

Ritratto di stefanet
stefanet
(Junior)
Offline
Junior
Iscritto: 28/12/2011
Messaggi: 17

Ho risolto il problema, che sinceramente ancora non ho ben capito quale fosse, ma credo un problema di profilo.

Ho tolto tutte le installazioni "sporche", riavviato firefox e reinstallato i pluging ed al primo tentativo ha funzionato.

Ciao e Grazie a tutti