Mi manca ifup.

20 risposte [Ultimo messaggio]
Ritratto di GiulioGG
GiulioGG
(Monster)
Offline
Monster
Iscritto: 26/05/2009
Messaggi: 281

Ho constatato che ormai ifup è introvabile dal motore di ricerca .rpm , come se fosse una cosa vergognosa da nascondere, mentre invece è usato con successo al posto del punitivo networkmanager sulle "releases" precedenti le infelici 13.x . Esiste un surrogato altrettanto efficace per le attuali "releases"?

Ritratto di gi-gi
gi-gi
(Moderatore)
Offline
Moderatore
Iscritto: 09/12/2014
Messaggi: 418

Ciao.

Non specifichi a quale release ti riferisci. Dal testo sembra di intuire che usi la versione 42.1. Che io sappia dalla versione 13.2 al posto di ifup viene installato di default il pacchetto funzionalmente equivalente wicked. Puoi averne conferma da YaST --> Sistema --> Impostazioni di rete --> Opzioni globali (scheda) --> Metodo di configurazione di rete.

gigi

Ritratto di GiulioGG
GiulioGG
(Monster)
Offline
Monster
Iscritto: 26/05/2009
Messaggi: 281

gi-gi ha scritto:

dalla versione 13.2 al posto di ifup viene installato di default il pacchetto funzionalmente equivalente wicked.

Ho provato wicked ma non è affatto funzionalmente equivalente a ifup, infatti...non funziona, con lo stesso hardware e Kppp con cui mi collego alla rete da 12.3 con ifup senza problemi. E' possibile modificare il pacchetto di ifup di 12.3 per farlo funzionare su 13.2 ?

Ritratto di gi-gi
gi-gi
(Moderatore)
Offline
Moderatore
Iscritto: 09/12/2014
Messaggi: 418

Ciao.

Beh, non conosco esattamente le dipendenze dell'uno e dell'altro per darti una risposta certa. Però kppp vedo che è presente tra i pacchetti del DVD del release sia in openSuse 13.2 che in openSuse 42.1. Trovo per principio molto stano che kppp venga incluso in ben due release consecutive se non risultasse compatibile con wicked. Se vai su questa pagina: http://pkgs.org/opensuse-factory/opensuse-oss/kppp-15.08.3-1.1.x86_64.rpm.html puoi notare che kppp non dipende né da ifup, né da wicked, per cui sembrerebbe poter funzionare con entrambi i programmi. Forse il problema che hai (e non specifichi nel dettaglio) non dipende da wicked.

Potrebbero risultarti utili anche le informazioni che trovi a questi link:

https://docs.kde.org/stable4/en/kdenetwork/kppp/kppp.pdf
http://www.tldp.org/HOWTO/PPP-HOWTO/tools.html

gigi

Ritratto di GiulioGG
GiulioGG
(Monster)
Offline
Monster
Iscritto: 26/05/2009
Messaggi: 281

gi-gi ha scritto:

Forse il problema che hai (e non specifichi nel dettaglio) non dipende da wicked.

Kppp mi segnala che il collegamento al server del provider è attivo, quindi il problema dovrebbe essere nella tratta tra Kppp e il browser (qualsiasi) di oS 13.2 .

Ritratto di gi-gi
gi-gi
(Moderatore)
Offline
Moderatore
Iscritto: 09/12/2014
Messaggi: 418

Ciao.

Dovresti postare i parametri con cui hai configurato kppp, nonché l'errore segnalato dal browser. Anche altre informazioni, come hardware utilizzato, provider ISP, ecc. potrebbero tornare utili.

gigi

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2739

sorry

SUSE Tumbleweed- kernel-5.6.14.1.1- kde-plasma-5.18.5.1- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.132.14- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2739

trinity-kwifimanager
Direttore wireless LAN per Trinity

Kwifimanager Suite è un insieme di strumenti che permette di gestire la connessione LAN senza fili sotto il K Desktop Environment. Esso fornisce informazioni sulla connessione corrente. Kwifimanager supporta ogni scheda Wavelan che utilizza l'interfaccia wireless extensions.
https://software.opensuse.org/package/trinity-kwifimanager
Non lo uso ma provalo,neanche so se ti puo essere utile
ciao

SUSE Tumbleweed- kernel-5.6.14.1.1- kde-plasma-5.18.5.1- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.132.14- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2739

Non esiste sto ifup,da nessuna parte.

SUSE Tumbleweed- kernel-5.6.14.1.1- kde-plasma-5.18.5.1- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.132.14- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di gi-gi
gi-gi
(Moderatore)
Offline
Moderatore
Iscritto: 09/12/2014
Messaggi: 418

Ciao.

Ho fatto un po' di ricerche e sono arrivato alla seguente conclusione:

Fino alla release 13.1 in YaST era presente la voce DSL (vedi immagini allegate), soppressa assieme alle voci Modem e ISDN a partire dalla versione 13.2 (quando è stato riscritto YaST). Purtroppo non sono riuscito a risalire ai file interessati dalla configurazione.

Ho poi individuato i seguenti link che potrebbero tornarti utili:

Configurazione manuale:
https://forums.opensuse.org/showthread.php/502199-UPGRADING-REMOVES-PPPOE-%2813-1-gt-13-2%29?p=2673411#post2673411

Configurazione di Network Manager (è per l'ambiente Englightenment, ma credo non ci siano difficoltà ad interpretarlo sotto KDE)

http://unsolicitedbutoffered.blogspot.co.nz/2014/11/opensuse-132-englightenment-pppoe-wi-fi.html

NB: il fatto che la rete sottostante sia configurata tramite ifup o wicked è del tutto ininfluente.

Immagini allegate:

gigi

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1758

ifup è stato sostituito dal più potente wicked su Suse.
Basta configurarlo bene grazie al yast!!!

L'unico problema di wicked è che può far crollare proxi o server-sicurezza di windows che sono in rete, mettendoli sotto pressione!
Rolling On The Floor
Insomma una lumaca di macchina con suse batte una ferrari con windows.

SO: Linux desktop Sistema: OpenSUSE Leap 15.1 (64bit) KDEE 5.12
SO: Linux desktop Sistema: OpenSUSE Tumbleweed (64bit) KDE 5
Miao