Mi manca ifup.

20 risposte [Ultimo messaggio]
Ritratto di GiulioGG
GiulioGG
(Monster)
Offline
Monster
Iscritto: 26/05/2009
Messaggi: 274

gi-gi ha scritto:

Dovresti postare i parametri con cui hai configurato kppp, nonché l'errore segnalato dal browser. Anche altre informazioni, come hardware utilizzato, provider ISP, ecc. potrebbero tornare utili.

Configurazione di Kppp, hardware e provider sono gli stessi con i quali mi collego senza problemi a internet con openSUSE 12.3; la segnalazione del browser è la solita generica: controlla l'indirizzo digitato, le impostazioni. Che intoppo nuovo dunque ha interposto oS 13.2 tra Kppp, che si collega alla rete, e il browser?

Ritratto di gi-gi
gi-gi
(Moderatore)
Offline
Moderatore
Iscritto: 09/12/2014
Messaggi: 418

Ciao.

E' trascorso un po' di tempo dalla mia ultima risposta, per cui vedo di ricapitolare, cercando di intuire anche quanto non dici...

Hai una connessione ADSL a tempo, pertanto per connetterti devi attivare la connessione usando nome utente e password che inserisci nel programma Kppp precedentemente configurato.

Questa operazione funziona con openSuse 13.1 ma non con openSuse 13.2

Se è così, quello che è cambiato tra la 13.1 e la 13.2 è che nella 13.1 in YaST --> Impostazioni di rete --> DSL potevi configurare questo tipo di connessioni (ADSL a tempo), mentre nella 13.2 il modulo DSL non c'è più (non è l'unico modulo di yaST "sparito" tra la 13.1 e la 13.2). Pertanto quei dati che si inserivano dal modulo DSL adesso vanno inseriti a mano in uno o più file di configurazione.

Dato che io non ho una ADSL a tempo non sono in grado di fare delle prove, posso solo fare ricerche con Google e "filtrare" quello che mi sembra ti possa servire.

Nel mio post precedente a questo ci sono appunto dei link a pagine che potrebbero fare al caso tuo. E' necessario che parti da lì e se qualcosa non ti è chiaro posti un altro quesito.

Un'alternativa a questo modo di procedere potrebbe essere quella di tentare di installare sulla 13.2 il modulo DNS di YaST, con esiti però non prevedibili...

gigi

Ritratto di GiulioGG
GiulioGG
(Monster)
Offline
Monster
Iscritto: 26/05/2009
Messaggi: 274

gi-gi ha scritto:


Hai una connessione ADSL a tempo, pertanto per connetterti devi attivare la connessione usando nome utente e password che inserisci nel programma Kppp precedentemente configurato.

Non ho una connessione ADSL ma via rete telefonica wireless. Rimane l'interrogativo: perchè Kppp e browser, funzionanti ambedue, non riescano a funzionare assieme in oS 13.2 come invece mi funzionano in oS 12.3? Se tu volessi collegarti a internet via modem USB e rete telefonica wireless (es.: Tim, Wind, ecc.), quali delle impostazioni di default modificheresti in openSUSE 13.2 ?

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1697

provo con kppp (ci feci una guida qui) con Suse 13.2 e mi funziona benissimo, quindi deve essere una impostazione di kppp che non è giusta!

Quale impostazioni fai in kppp???

SO: Linux desktop Sistema: OpenSUSE Leap 15.1 (64bit) KDEE 5.12
SO: Linux desktop Sistema: OpenSUSE Tumbleweed (64bit) KDE 5
Miao

Ritratto di GiulioGG
GiulioGG
(Monster)
Offline
Monster
Iscritto: 26/05/2009
Messaggi: 274

mauriziod ha scritto:

provo con kppp (ci feci una guida qui) con Suse 13.2 e mi funziona benissimo, quindi deve essere una impostazione di kppp che non è giusta!

Quale impostazioni fai in kppp???

Le stesse con le quali mi funziona perfettamente con openSUSE 12.3, quasi identiche a quelle che ho visto nella tua guida, quindi il problema è in qualche cosa della mia oS 13.2 . Potrebbe essere qualche difetto di installazione o di permessi? Ripeto che Kppp di oS 13.2 si connette regolarmente al server del provider e ne riceve i messaggi, ma è il browser che rimane isolato dalla rete.

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1697

Ok, Capisco, MA QUALI SONO???
van bene anche screenshot.

SO: Linux desktop Sistema: OpenSUSE Leap 15.1 (64bit) KDEE 5.12
SO: Linux desktop Sistema: OpenSUSE Tumbleweed (64bit) KDE 5
Miao

Ritratto di GiulioGG
GiulioGG
(Monster)
Offline
Monster
Iscritto: 26/05/2009
Messaggi: 274

mauriziod ha scritto:

Ok, Capisco, MA QUALI SONO???
van bene anche screenshot.

Provando a “fotografarne” le finestre Kppp mi si blocca! Mi sembra proprio che la oS 13.2 che ho scaricato sia una raccolta di bugs. A proposito, terminata la prima installazione che sembrava ok, oS 13.2 si è improvvisamente auto-disinstallata a velocità vertiginosa! Forse mi è capitato di scaricare un .iso “ritoccato” per convincere a tornare a Windows...

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1697

GiulioGG ha scritto:

mauriziod ha scritto:

Ok, Capisco, MA QUALI SONO???
van bene anche screenshot.

Provando a “fotografarne” le finestre Kppp mi si blocca! Mi sembra proprio che la oS 13.2 che ho scaricato sia una raccolta di bugs. A proposito, terminata la prima installazione che sembrava ok, oS 13.2 si è improvvisamente auto-disinstallata a velocità vertiginosa! Forse mi è capitato di scaricare un .iso “ritoccato” per convincere a tornare a Windows...

Infatti mi sembra stranissimo il tuo problema!!

qui è quella ufficiale
https://software.opensuse.org/132/it

Controlla prima il MD5

SO: Linux desktop Sistema: OpenSUSE Leap 15.1 (64bit) KDEE 5.12
SO: Linux desktop Sistema: OpenSUSE Tumbleweed (64bit) KDE 5
Miao

Ritratto di gi-gi
gi-gi
(Moderatore)
Offline
Moderatore
Iscritto: 09/12/2014
Messaggi: 418

Ciao.

Prova a verificare se seguendo questa guida riesci a configurare una connessione PPPoE su openSuse

Nota:
A partire da openSuse 13.1 le wizard precedentemente utilizzate per configurare una connessione PPPoE sono state rimosse, pertanto occorre intervenire manualmente per configurare una connessione di questo tipo.

1) Lanciare Dolphin in modalità superutente.

2) Creare il file /etc/ppp/peers/ADSL vuoto ed al suo interno copiare quanto segue:

    # load plugin for PPPoE
    plugin rp-pppoe.so
    #
    # Ethernet interface to use
    enp0s20u3
    #
    # set user
    user username@provider.com
    #
    # set lower mtu/mru for PPPoE
    mtu 1492
    mru 1492
    #
    # set default route
    defaultroute
    replacedefaultroute
    #
    # obtain DNS entries
    usepeerdns
    #
    # never die
    idle 0
    maxfail 0
    persist
    passive

NB: nel file qui sopra devi inserire al posto di enp0s20u3 il nome della tua connessione Ethernet, ed al posto di username@provider.com il tuo nome utente con cui ti connetti al tuo provider.

3) Inserire i dati di login al servizio ADSL nei file /etc/ppp/chap-secrets e /etc/ppp/pap-secrets. In questi file impostare il "client name" con lo stesso valore inserito nel file /etc/ppp/peers/ADSL:

"username@provider.com"  *  "password"

NB: nel file qui sopra devi inserire al posto di username@provider.com il tuo nome utente con cui ti connetti al tuo provider ed al posto di password la tua password corrispondente. I doppi apici vanno lasciati.

4) Creare il file /etc/ppp/ip-up vuoto e renderlo eseguibile poi al suo interno copiare quanto segue:

    #!/bin/bash
    # Automatic nameserver config with netconfig
    {
        echo "INTERFACE='$IFNAME'"
        echo "IPADDR='$IPLOCAL'"
        echo "PTPADDR='$IPREMOTE'"
        echo "DNSSERVERS='$DNS1 $DNS2'"
    } | /sbin/netconfig modify -s pppd -i "$IFNAME"
 
    # Restart firewall if already enabled and active
    /etc/sysconfig/network/scripts/firewall try-restart

5) Creare il file /etc/ppp/ip-down vuoto e renderlo eseguibile poi al suo interno copiare quanto segue:

    #!/bin/bash
    # Automatic nameserver config with netconfig
    /sbin/netconfig remove -s pppd -i "$IFNAME"
 
    # Restart firewall if already enabled and active
    /etc/sysconfig/network/scripts/firewall try-restart

6) Creare il file /etc/systemd/system/ppp@.service vuoto ed al suo interno copiare quanto segue:

    [Unit]
    Description=PPP link to %I
    Documentation=man:pppd(8)
    After=network-pre.target network.service SuSEfirewall2_init.service
    Before=network.target multi-user.target shutdown.target SuSEfirewall2.service
 
    [Service]
    Type=forking
    PIDFile=/var/run/ppp-%I.pid
    ExecStart=/usr/sbin/pppd call %I linkname %I updetach nolog
    ExecReload=/usr/bin/kill -s HUP $MAINPID
    Restart=always
    RestartSec=10
    SuccessExitStatus=1
    RestartPreventExitStatus=3 4 5
 
    [Install]
    WantedBy=network-online.target multi-user.target

7) Lanciare Konsole e connettersi come superuser (su -) poi immettere nell'ordine i comandi:

    systemctl enable ppp@ADSL.service
 
    systemctl start ppp@ADSL.service

Così facendo viene creato un servizio che crea una connessione ADSL permanente (non a tempo).

Nel caso volessi interrompere il collegamento da Konsole, connesso come superuser (su -) devi dare il comando

    systemctl stop ppp@ADSL.service

Non so dirti se quanto sopra sia compatibile con KPPP, però dovresti ottenere una funzionalità analoga anche se un po' meno evoluta.

gigi

Ritratto di GiulioGG
GiulioGG
(Monster)
Offline
Monster
Iscritto: 26/05/2009
Messaggi: 274

Problema risolto nel più semplice dei modi passando a openSUSE 15.0 .