MyPhpAdmin cose che devo ancora sapere..............

10 risposte [Ultimo messaggio]
Ritratto di franco_da_vc
franco_da_vc
(Monster)
Offline
Monster
Iscritto: 22/05/2008
Messaggi: 277

Saluti a tutti,

ho appena scaricato la 13.1 Applause ed appena mi avanzo un attimo di tempo la installo Smile .

Ora però mi trovo davanti ad un problema che vorrei risolvere prima delle grandi manovre, non che le due cose centrino più di tanto, ma per mie organizzazioni, penso sia meglio così.

Mi trovo a dover scaricare un archivio basato su MySql in remoto, sull'Hoster da cui devo operare il servizio dovrebbe essere già di serie, mentre sul mio sistema come posso fare?

Mi è stato consigliato MyPhpAdmin che ho trovato tra i programmi dei repository ed ho prontamente sacaricato, a questo punto ho letto su Wiki che l'utiliy è disponibile su localhost/MyPhpAdmin, ma ho provato a dare il comando sul mio browser e non ho fatto altro che ottenere il solito messaggio di errore, c'è evidentemente un passaggio che mi manca, ma quale?

Chi mi può aiutare?

Ciao, e vi ringrazio già fin d'ora!!

Bye by AFo

Ritratto di pinquadr
pinquadr
(Guru)
Offline
Guru
Iscritto: 20/11/2004
Messaggi: 921

Per poter funzionare phpMyAdmin ha bisogno di Apache2, PHP5 e MySql quindi questi programmi devono essere installati sulla tua macchina. Se in Yast>Gestione pacchetti cerchi 'lamp' (senza virgolette) trovi quello che ti serve. La configurazione potrebbe richiedere qualche livello di conoscenza più elevato del normale.

OpenSuse Leap42 con KDE5 su Intel I7 4930K scheda madre Asus Sabertooth X79 - RAM 32 Gb - scheda video NVIDIA GTX660 1GB - scheda TV Hauppauge WinTV Nova T stick

Ritratto di franco_da_vc
franco_da_vc
(Monster)
Offline
Monster
Iscritto: 22/05/2008
Messaggi: 277

Grazie Pinquadr,

Concordo con te, Il fatto è che..... è vero non ti ho anticipato che io Apache, Php e MySql li ho già sul mio sistema, il database di cui parlo serve a far funzionare il cms Joomla, quindi lamp non penso di doverlo scaricare, tra parentesi non so perchè, ma non lo trovavo, è quel livello di conoscenza di cui mi hai scritto che mi manca, dove posso trovare istruzioni per poterlo caricare?

In ogni caso ti ringrazio ancora!

Bye by AFo

Ritratto di franco_da_vc
franco_da_vc
(Monster)
Offline
Monster
Iscritto: 22/05/2008
Messaggi: 277

Alura,

sono riuscito ad installarlo, seguendo un tutorial di HTML.it ho copiato la cartella phpMyAdmin nella directory public_html settando il tutto con lo user wwwrun ed il gruppo www e per ultimo ho inserito vi ho inserito anche config.inc.php sempre con lo stesso gruppo e user.

Il problema e che ottengo l'errore: #1045 Impossibile eseguire il login nel server MySQL, ho anche provato sbirciando in giro per il web a variare alcune tarature, niente da fare l'utility sembra insensibile e mi da sempre lo stesso errore.

Nessuno sa cosa sto sbagliando?

Bye by AFo

Ritratto di pinquadr
pinquadr
(Guru)
Offline
Guru
Iscritto: 20/11/2004
Messaggi: 921

Nel file config.inc.php devi indicare lo user mysql e relativa password. Immagino che tu ti riferisca alla configurazione locale. Ti ricordi come è stato impostato mysql?

OpenSuse Leap42 con KDE5 su Intel I7 4930K scheda madre Asus Sabertooth X79 - RAM 32 Gb - scheda video NVIDIA GTX660 1GB - scheda TV Hauppauge WinTV Nova T stick

Ritratto di franco_da_vc
franco_da_vc
(Monster)
Offline
Monster
Iscritto: 22/05/2008
Messaggi: 277

Grazie pinquadr

pinquadr ha scritto:

Nel file config.inc.php devi indicare lo user mysql e relativa password. Immagino che tu ti riferisca alla configurazione locale. Ti ricordi come è stato impostato mysql?

Ok! La mia configurazione del server mysqli (e non mysql) è la seguente:

Tipo database = Mysqli
Host = localhost
Nome utente database = root
Nome database = jz61d
Prefisso tabelle database = jz61d_

Ho però dei dubbi su alcune righe di config.inc.php che riporto sotto:

$cfg['Servers'][$i]['extension'] = 'mysqli';
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['nopassword'] = true;
$cfg['Servers'][$i]['AllowNoPassword'] = true;

Sono state riportate nell'ordine che che le ho ritrovate nel file di configurazione e con la configurazione inserita così al tentativo di aprire phpMyAdmin ottengo il messaggio "Login senza password è vietato dalla configurazione (vedi AllowNoPassword)", c'è qualche errore?

Ti ringrazio ancora!

Bye by AFo

Ritratto di pinquadr
pinquadr
(Guru)
Offline
Guru
Iscritto: 20/11/2004
Messaggi: 921

Per capirci in invio copia del mio file /dati/htdocs/phpMyAdmin/config.inc.php:

// The $cfg['Servers'] array starts with $cfg['Servers'][1].  Do not use $cfg['Servers'][0].
// You can disable a server config entry by setting host to ''.
$i++;
$cfg['Servers'][$i]['host']          = 'XXX.XXX.X.X'; // MySQL hostname or IP address
$cfg['Servers'][$i]['port']          = '';          // MySQL port - leave blank for default port
$cfg['Servers'][$i]['socket']        = '';          // Path to the socket - leave blank for default socket
$cfg['Servers'][$i]['connect_type']  = 'tcp';       // How to connect to MySQL server ('tcp' or 'socket')
$cfg['Servers'][$i]['compress']      = FALSE;       // Use compressed protocol for the MySQL connection
                                                    // (requires PHP >= 4.3.0)
$cfg['Servers'][$i]['controluser']   = 'pma';          // MySQL control user settings
                                                    // (this user must have read-only
$cfg['Servers'][$i]['controlpass']   = '';          // access to the "mysql/user"
                                                    // and "mysql/db" tables).
                                                    // The controluser is also
                                                    // used for all relational
                                                    // features (pmadb)
$cfg['Servers'][$i]['auth_type']     = 'config';    // Authentication method (config, http or cookie based)?
$cfg['Servers'][$i]['user']          = 'XXXXX;      // MySQL user
$cfg['Servers'][$i]['password']      = 'XXXXXX';          // MySQL password (only needed

sei sicuro che il tuo file di cui hai inviato ida ti non sia invece relativo alla configurazione di Joomla?

OpenSuse Leap42 con KDE5 su Intel I7 4930K scheda madre Asus Sabertooth X79 - RAM 32 Gb - scheda video NVIDIA GTX660 1GB - scheda TV Hauppauge WinTV Nova T stick

Ritratto di franco_da_vc
franco_da_vc
(Monster)
Offline
Monster
Iscritto: 22/05/2008
Messaggi: 277

Ciao Pinquadr.

Si si, il file che sto analizzando è il config.inc.php

Mmmmh! sto notando una cosa, il tuo file, se quello è tutto, è molto più piccolo del mio, io ho preso di fatto il file di esempio e ci ho fatto le varie modifiche sopra, cio non va bene?

Poi, il mio archivio su cui devo lavorare non è remoto, ma locale quindi nella registrazione $cfg['Servers'][$i]['host'] io ho inserito localhost, mentre la seconda e la terza scrittura anche per me sono stringa vuota mentre per la direttiva $cfg['Servers'][$i]['connect_type'] ove ho anch'io tcp presumo che lo debba sostituire con socket.
Nel record $cfg['Servers'][$i]['controluser'] io ho stringa vuota, mentre vedo che tu hai inserito pma, devo inserirlo anch'io? Per quanto riguarda $cfg['Servers'][$i]['user'] ho inserito root perché nella configurazione di joomla ho messo quello a proposito dell'utente mysql e nel record $cfg['Servers'][$i]['password'] ho lasciato stringa vuota perché non ho dato password nella configurazione di joomla, mi sono accorto però che quest'ultima direttiva va abilitata solo nel caso che auth_type sia uguale a config, proverò a modificare quello e casomai ti dirò.

Per ora ti ringrazio e ti saluto.

Bye by AFo

Ritratto di franco_da_vc
franco_da_vc
(Monster)
Offline
Monster
Iscritto: 22/05/2008
Messaggi: 277

Riprendo ora l'argomento, e mi scuso per il buco:

ora ho modificato anch'io il file di configurazione e l'ho portato a questa scrittura:

$i++;
$cfg['Servers'][$i]['host'] = 'localhost';	// MySQL hostname or IP address
$cfg['Servers'][$i]['port'] = '';		// MySQL port - leave blank for default port
$cfg['Servers'][$i]['socket'] = '';		// Path to the socket - leave blank for default socket
$cfg['Servers'][$i]['connect_type'] = 'socket';	// How to connect to MySQL server ('tcp' or 'socket')
$cfg['Servers'][$i]['extension'] = 'mysqli';	// The PHP MySQL extension to use ('mysql' or 'mysqli')
$cfg['Servers'][$i]['user'] = 'root';		// MySQL user
$cfg['Servers'][$i]['AllowNoPassword'] = true;	// Allow access without password

Malgrado cio ottengo sempre lo stesso genere di errore all'atto del login

Login senza password è vietato dalla configurazione (vedi AllowNoPassword)

Ora, pensavo che il problema stesse nel fatto che avevo sovrascritto il file originale ed ho quindi scritto a mia volta questo file sulla scorta dell'esempio di Pinquadr, ma per ora il risultato è invariato.

Chi sa darmi ancora qualche spunto?

Ringrazio!

Bye by AFo

Ritratto di pinquadr
pinquadr
(Guru)
Offline
Guru
Iscritto: 20/11/2004
Messaggi: 921

Azzardo: per ragioni di sicurezza non è consentito entrare in MySql come utente root senza password. Io infatti uso un utente normale con pieni diritti amministrativi e ne indico la password.

OpenSuse Leap42 con KDE5 su Intel I7 4930K scheda madre Asus Sabertooth X79 - RAM 32 Gb - scheda video NVIDIA GTX660 1GB - scheda TV Hauppauge WinTV Nova T stick

Ritratto di franco_da_vc
franco_da_vc
(Monster)
Offline
Monster
Iscritto: 22/05/2008
Messaggi: 277

Strano, io ho usato Mysql per far funzionare Joomla e in fase di installazione ho dovuto togliere la password perchè non la accettava e il cms funziona quindi è connesso al database (sempre in locale).... però, mentre vi scrivevo, mi è venuto un dubbio ora vado a pranzo poi controllo e vi faccio sapere!

Ciao e grazie.

Bye by AFo