Problema configurazione rete domestica con 2 Windows - openSUSE 11.4

9 risposte [Ultimo messaggio]
Ritratto di Depa Marco
Depa Marco
(Geek)
Offline
Geek
Iscritto: 02/10/2010
Messaggi: 178

ciao a tutti...
Ho 3 PC in casa:
- uno in salotto (Windows XP SP3; appartiene al Gruppo di Lavoro "DEPAHOUSE"; si chiama "Mediastation")
- uno in camera (Windows XP SP3; appartiene allo stesso Gruppo di Lavoro; si chiama "PC_FISSO")
- il mio portatile (OpenSUSE 11.4)
i due PC con WINDOWS si vedono perfettamente e sono in grado di scambiarsi file ecc.
Con SUSE, ho provato a configurare l'appartenenza al dominio usando l'apposita voce in YAST che si chiama "Appartenenza a un dominio Windows".
La procedura va a buon fine e se, con Dolphin, guardo alla voce "Rete" e poi "Condivisioni Samba" vedo la rete "Depahouse". Clicco per entrare, ma mi lascia in attesa per un caricamento lunghissimo e poi dice che il tempo per contattare il server è scaduto.
Nel firewall di SUSE ho configurato l'eccezioni per Samba, ma niente...
:'( :'(

Cosa posso fare??? Grazie 1000

Ritratto di pinquadr
pinquadr
(Guru)
Offline
Guru
Iscritto: 20/11/2004
Messaggi: 921

Questo è il mio file di configurazione, perfettamente funzionante. Aprilo come utente root nel programma di scrittura di file di testo (Kwrite, Gedit, ecc.), adattalo con i tuoi dati e poi salvalo in /etc/samba/smb.conf e riavvia il sistema.

[global]
        workgroup = WORKGROUP
        passdb backend = tdbsam
        printing = cups
        printcap name = cups
        printcap cache time = 750
        cups options = raw
        map to guest = Bad User
#logon path = \\%L\profiles\.msprofile
#logon home = \\%L\%U\.9xprofile
#logon drive = P:
        usershare allow guests = Yes
        guest ok = Yes
        wins support = No
        wins server = 
        local master = yes
        preferred master = yes
        os level = 65
 
## Share disabled by YaST
# [homes]
#       comment = Home Directories
#       valid users = %S, %D%w%S
#       read only = No
#       inherit acls = Yes
#       browseable = No
 
## Share disabled by YaST
# [users]
#       comment = All users
#       path = /home
#       read only = No
#       inherit acls = Yes
#       veto files = /aquota.user/groups/shares/
 
## Share disabled by YaST
# [groups]
#       comment = All groups
#       path = /home/groups
#       read only = No
#       inherit acls = Yes
 
[printers]
        create mask = 0600
        comment = All Printers
        browseable = no
        printable = yes
        path = /var/tmp
 
[print$]
        comment = Printer Drivers
        path = /var/lib/samba/drivers
        write list = @ntadmin, root
        force group = ntadmin
        create mask = 0664
        directory mask = 0775
[d]
        create mask = 0766
        directory mask = 0766
        read only = no
        path = /windows/d
        write list = lavoro,@users
        force user = lavoro
 
 
[media]
        create mask = 0766
        directory mask = 0766
        read only = no
        path = /media
        write list = lavoro,@users
        force user = lavoro

Ovviamente questa configurazione di riferisce alle condivisioni sul tuo sistema Linux.

OpenSuse Leap42 con KDE5 su Intel I7 4930K scheda madre Asus Sabertooth X79 - RAM 32 Gb - scheda video NVIDIA GTX660 1GB - scheda TV Hauppauge WinTV Nova T stick

Ritratto di Depa Marco
Depa Marco
(Geek)
Offline
Geek
Iscritto: 02/10/2010
Messaggi: 178

questo è il mio file:

[global]
	workgroup = DEPAHOUSE
	passdb backend = tdbsam
	printing = cups
	printcap name = cups
	printcap cache time = 750
	cups options = raw
	map to guest = Bad User
	include = /etc/samba/dhcp.conf
	logon path = \\%L\profiles\.msprofile
	logon home = \\%L\%U\.9xprofile
	logon drive = P:
	usershare allow guests = No
	security = domain
	usershare max shares = 100
[homes]
	comment = Home Directories
	valid users = %S, %D%w%S
	browseable = No
	read only = No
	inherit acls = Yes
[profiles]
	comment = Network Profiles Service
	path = %H
	read only = No
	store dos attributes = Yes
	create mask = 0600
	directory mask = 0700
[users]
	comment = All users
	path = /home
	read only = No
	inherit acls = Yes
	veto files = /aquota.user/groups/shares/
[groups]
	comment = All groups
	path = /home/groups
	read only = No
	inherit acls = Yes
[printers]
	comment = All Printers
	path = /var/tmp
	printable = Yes
	create mask = 0600
	browseable = No
[print$]
	comment = Printer Drivers
	path = /var/lib/samba/drivers
	write list = @ntadmin root
	force group = ntadmin
	create mask = 0664
	directory mask = 0775

Mi sembra tutto in regola Sad
O sbaglio???

Grazie 1000

Ritratto di pinquadr
pinquadr
(Guru)
Offline
Guru
Iscritto: 20/11/2004
Messaggi: 921

Ma hai risolto o no?

OpenSuse Leap42 con KDE5 su Intel I7 4930K scheda madre Asus Sabertooth X79 - RAM 32 Gb - scheda video NVIDIA GTX660 1GB - scheda TV Hauppauge WinTV Nova T stick

Ritratto di Depa Marco
Depa Marco
(Geek)
Offline
Geek
Iscritto: 02/10/2010
Messaggi: 178

no, appunto...
Sempre la stessa cosa...
Ho postato il contenuto del mio file perchè credo che sia corretto, ma ho ancora lo stesso problema...
Sad :(

Grazie

Ritratto di pinquadr
pinquadr
(Guru)
Offline
Guru
Iscritto: 20/11/2004
Messaggi: 921

Guarda bene, ci sono molte differenze tra il mio e il tuo file di configurazione. Se non capisci il significato delle diverse righe, è difficile che arrivi ad un sistema funzionante. Tu hai impostato su condivisione degli utenti, ma è questo che ti serve? poi da te non è 'usershare allow guests = Yes'.
Prova a rinominare il tuo /etc/smb.conf in /etc/smb.conf.old e a copiare quello che ti ho inserito nel messaggio come /etc/smb.conf e modifica ESCLUSIVAMENTE workgroup=, e i diversi share ([d], [media]) con i tuoi. Se poi utilizzi come me force user= devi indicare il tuo utente (di solito te stesso).

OpenSuse Leap42 con KDE5 su Intel I7 4930K scheda madre Asus Sabertooth X79 - RAM 32 Gb - scheda video NVIDIA GTX660 1GB - scheda TV Hauppauge WinTV Nova T stick

Ritratto di guero84
guero84
(Junior)
Offline
Junior
Iscritto: 20/05/2012
Messaggi: 30

Ciao, anch'io avevo lo stesso problema nei giorni scorsi, Solo che i due winzoz in questione sono 2 portatitili uno win7 e l'altro win8...
cercando ho trovato questa discussione, ho configurato samba come suggerito da pinquadr ,
ma non andava... poi ho scoperto che il portatile aveva attivo il firewall, dandolo giu, ho iniziato a vedere le risorse condivise... persino la stampante che è attaccata con l'usb al Linux!
Non mi sono ancora addentrato... ma pensavo di ritirar su il firewall impostando meglio i filtri!, ma non penso ci siano grandi problemi.

Grz dell'aiuto!

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1686

Dunque Nel Firewall dovete abilitare Samba. Yast->firewall e seguire la procedura guidata: Quando giungete alla lista dei servizi ammessi esternamente, guardate attentamente la tendina "servizio da consentire" e scegliete Samba e premete il bottone"aggiungi".
Proseguite poi fin alla fine.

Qualche volta si incrocchia e conviene pertanto sempre riavviare.

Immagini allegate:

SO: Linux desktop Sistema: OpenSUSE Leap 15 (32bit) TDE 4 / Mate
SO: Linux desktop Sistema: OpenSUSE Leap 15 (64bit) KDE 5
Miao

Ritratto di guero84
guero84
(Junior)
Offline
Junior
Iscritto: 20/05/2012
Messaggi: 30

Risolto!

Ora mi sposto da un'altra parte del forum,
perchè dopo HTTP, FTP e aver dato l'accesso ai dati e alla stampante al portatile di mia sorella mi sono inoltrato nel VNC ...

Grazie dell'aiuto!

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1686

@Depa Marco

Mi era sfuggito il tuo problema: Prova (se non è ancora risolto) entrando in Yast->Appartenenza al dominio windows.

Nota: Se non c'è, carica il modulo Yast.

Metti il nome del gruppo e poi cecca "usa informazioni SMB per autenticazione linux" e cecca anche "consenti agli utenti di condividere le proprie directory".

Clicca su OK, riavvia e prova.

SO: Linux desktop Sistema: OpenSUSE Leap 15 (32bit) TDE 4 / Mate
SO: Linux desktop Sistema: OpenSUSE Leap 15 (64bit) KDE 5
Miao