Problema all'avvio di Knetworkmanager

24 risposte [Ultimo messaggio]
Ritratto di Lorentz
Lorentz
(Geek)
Offline
Geek
Iscritto: 31/01/2008
Messaggi: 93

Ciao a tutti,
ho appena felicemente installato la 11.2 con KDE, che apprezzo molto per le prestazioni sul mio Acer Aspire One.

Adesso però ho un problemino. Ho configurato KnetworkManager per riconoscere la mia rete wireless domestica, e me la vede e prende sempre bene. Solo che all'avvio si creano dei problemi: nonostante la rete mi venga vista, non viene eseguita la connessione automatica; non solo, ma neanche a indicargli manualmente di connettersi, lo fa... e questo, attenzione, solo con la mia rete domestica! Mi tocca ogni volta riavviare KnetworkManger (non networkManager, ma KnetworkManager) e tutto torna a funzionare correttamente. La cosa ormai si ripete a tutti gli avvii, ed è un tantino fastidiosa...

Ecco qui il log iniziale:

Apr 10 10:08:28 linux-qogp NetworkManager: [1270886908.105395] write_to_netconfig(): Writing to netconfig: DNSSERVERS='192.168.0.1'#012
Apr 10 10:08:28 linux-qogp NetworkManager: Clearing nscd hosts cache.
Apr 10 10:08:28 linux-qogp NetworkManager: Policy set 'NETGEAR' (wlan0) as default for routing and DNS.
Apr 10 10:08:28 linux-qogp NetworkManager: Activation (wlan0) successful, device activated.
Apr 10 10:08:28 linux-qogp NetworkManager: Activation (wlan0) Stage 5 of 5 (IP Configure Commit) complete.
Apr 10 10:08:28 linux-qogp nm-dispatcher.action: Script '/etc/NetworkManager/dispatcher.d/autofs' exited with error status 1.

Forse il mistero sta nell'ultima riga...?

Hardware: http://tinyurl.com/nu57nm
Software: OpenSuse 11.2, KDE.

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2742

Lorentz ha scritto:

Ciao a tutti,
ho appena felicemente installato la 11.2 con KDE, che apprezzo molto per le prestazioni sul mio Acer Aspire One.

Adesso però ho un problemino. Ho configurato KnetworkManager per riconoscere la mia rete wireless domestica, e me la vede e prende sempre bene. Solo che all'avvio si creano dei problemi: nonostante la rete mi venga vista, non viene eseguita la connessione automatica; non solo, ma neanche a indicargli manualmente di connettersi, lo fa... e questo, attenzione, solo con la mia rete domestica! Mi tocca ogni volta riavviare KnetworkManger (non networkManager, ma KnetworkManager) e tutto torna a funzionare correttamente. La cosa ormai si ripete a tutti gli avvii, ed è un tantino fastidiosa...

Ecco qui il log iniziale:

Apr 10 10:08:28 linux-qogp NetworkManager: [1270886908.105395] write_to_netconfig(): Writing to netconfig: DNSSERVERS='192.168.0.1'#012
Apr 10 10:08:28 linux-qogp NetworkManager: Clearing nscd hosts cache.
Apr 10 10:08:28 linux-qogp NetworkManager: Policy set 'NETGEAR' (wlan0) as default for routing and DNS.
Apr 10 10:08:28 linux-qogp NetworkManager: Activation (wlan0) successful, device activated.
Apr 10 10:08:28 linux-qogp NetworkManager: Activation (wlan0) Stage 5 of 5 (IP Configure Commit) complete.
Apr 10 10:08:28 linux-qogp nm-dispatcher.action: Script '/etc/NetworkManager/dispatcher.d/autofs' exited with error status 1.

Forse il mistero sta nell'ultima riga...?


Ciao io sul mio acer aspire 5920 mi installo wicd e non hò di questi problemi te lo consiglio
http://software.opensuse.org/search wicd
installi con 1-click

SUSE Tumbleweed- kernel-5.10.12.1- kde-plasma-5.20.5-1.1 Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.141.14- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di Lorentz
Lorentz
(Geek)
Offline
Geek
Iscritto: 31/01/2008
Messaggi: 93

Grazie, lo proverò!

Hardware: http://tinyurl.com/nu57nm
Software: OpenSuse 11.2, KDE.

Ritratto di Lorentz
Lorentz
(Geek)
Offline
Geek
Iscritto: 31/01/2008
Messaggi: 93

Il programma è bellino, però mancano alcune cose utili come la minimizzazione nella system tray. A me comunque va bene anche Knetworkmanager, basta mi diciate come risolvere il problema di cui sopra...

Hardware: http://tinyurl.com/nu57nm
Software: OpenSuse 11.2, KDE.

Ritratto di enziosavio
enziosavio (non verificato)
()

Metti Kde4.4.2 e minimizzi la System tray
http://www.kde.org/info/4.4.2.php#binary

Ritratto di Mirko
Mirko
(Guru)
Offline
Guru
Iscritto: 19/12/2005
Messaggi: 1602

Ragazzi, per favore. Quando un utente ha un problema con un programma, possiamo evitare di consigliare l'uso di un altro programma?
Questa è la mentalità Windows, questo forum invece è pensato per risolvere i problemi.

Veniamo a noi:
1) la connessione automatica - sembrerà strano - va impostata chiaramente. Io suppongo che tu lo abbia già fatto, ma se così non fosse (controlla comunque): click destro sull'icona di nm, "gestisci le connessioni", scheda "Senza fili", un click sulla tua connessione, "Modifica", spuntare l'opzione "Connetti automaticamente";
2) perché dici "e questo, attenzione, solo con la mia rete domestica"? Hai provato anche a connetterti ad altre reti e il problema non si presenta?
3) hai provato anche tramite ethernet (in questo caso dovrebbe andare sempre o quasi)? Ovvero, attaccando il cavo ethernet la connessione parte da sé?
4) usi il metodo statico o il dhcp? Se usi lo statico, puoi riportare qui i valori che hai impostato? In ogni caso, prova anche il metodo opposto a quello che usi ora;
5) apri un terminale, loggati come root, dai questo comando:

tail -f /var/log/NetworkManager

Fai partire *manualmente* la connessione e riporta qui le righe che ti stampa dopo averla fatta partire;
6) su Google si trovano molti risultati cercando l'ultimo errore che appare nel tuo log, anche se non sono convinto che il problema sia quello. In ogni caso, prova a vedere un po':
http://www.google.it/search?q=%22Script+%2Fetc%2FNetworkManager%2Fdispatcher.d%2Fautofs+exited+with+error+status+1%22&meta=&aq=f&aqi=&aql=&oq=&gs_rfai=

Comunque in tutto questo hai dimenticato di dirci la cosa più importante: che scheda hai? Riporta anche l'output del comando (da root):

lspci

Magari estraendo la sola riga riguardo la tua scheda.

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2742

ciao
@Mirko
Knetworkmanager è una ciofeca quindi non lo adopero mi connetto con il cavo e mi installo wicd,sul mio acer aspire,anche se non hò avuto problemi a far funzionare il wifi da subito anche con la 11,con 11.1, e 11.2 però mi trovo meglio con wicd quindi consiglio di mettere wicd poi ognuno è padrone di fare quel che gli pare....giusto Mirko.
ciao

SUSE Tumbleweed- kernel-5.10.12.1- kde-plasma-5.20.5-1.1 Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.141.14- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di Mirko
Mirko
(Guru)
Offline
Guru
Iscritto: 19/12/2005
Messaggi: 1602

Certo che ognuno è libero di fare quello che gli pare Smile Però se c'è un problema con Nm, tanto vale risolverlo. Sarà anche una ciofeca, ma a me non ha mai dato problemi di sorta, anzi mi ha sempre funzionato egregiamente.

Ritratto di anubis
anubis
(Guru)
Offline
Guru
Iscritto: 07/04/2007
Messaggi: 3656

dipende dai gusti, per me wicd è una ciofeca...

NetworkManager di per se è ottimo, il suo client QT (knetworkmanager) è altrettanto ciofeca quuanto wicd...

io ad esempio uso SEMPRE indipendentemente dal DE (kde,gnome,xfce,lxde,ecc)

nm-applet

ovvero il client GTK, che oltre ad essere SEMPRE funzionante, è quello che viene sviluppato parallalemente a NetworkManager e che quindi supporta di volta in volta tutto ciò che NetworkManager supporta

allo stesso modo,

cnetworkmanager è sempre funzionante ed è un "salvavita" nel caso in cui non sia una interfaccia grafica, per connettersi via wireless, SENZA ESSERE ROOT (come sarebbe necessario se si usasse ifup/wicd) basta digitare:

cnetworkmanager --connect=SSID --wpa-pass=PASSWORD

in caso di rete protetta da wpa/wpa2 ad esempio

dragoncello ha scritto:

ciao
@Mirko
Knetworkmanager è una ciofeca quindi non lo adopero mi connetto con il cavo e mi installo wicd,sul mio acer aspire,anche se non hò avuto problemi a far funzionare il wifi da subito anche con la 11,con 11.1, e 11.2 però mi trovo meglio con wicd quindi consiglio di mettere wicd poi ognuno è padrone di fare quel che gli pare....giusto Mirko.
ciao

OpenSUSE Member,Packman Packager, Education Project Admin, LXDE Project Admin
Powered by http://en.opensuse.org/HP_Pavilion_dv6855el

Ritratto di Lorentz
Lorentz
(Geek)
Offline
Geek
Iscritto: 31/01/2008
Messaggi: 93

Finalmente ho un pò di tempo per ritornare sul discorso.

1) Ovvio.
2) Esatto.
3) L'ethernet funziona.
4) DHCP. Ma come fa ad esser colpa di questo?
5) Ho disattivato e riattivato la wireless. Ecco il risultato.

linux-qogp:/home/lore # tail -f /var/log/NetworkManager
Apr 14 21:32:21 linux-qogp NetworkManager: <info>    gateway 192.168.0.1
Apr 14 21:32:21 linux-qogp NetworkManager: <info>    nameserver '192.168.0.1'
Apr 14 21:32:23 linux-qogp NetworkManager: <info>  (ath0): device state change: 8 -> 2 (reason 0)                                                                                         
Apr 14 21:32:23 linux-qogp NetworkManager: <info>  (ath0): deactivating device (reason: 0).  
Apr 14 21:32:23 linux-qogp NetworkManager: <info>  ath0: canceled DHCP transaction, dhcp client pid 2652                                                                                  
Apr 14 21:32:23 linux-qogp NetworkManager: <debug> [1271273543.582878] run_netconfig(): Spawning '/sbin/netconfig modify --service NetworkManager'                                        
Apr 14 21:32:23 linux-qogp NetworkManager: <info>  Clearing nscd hosts cache.                
Apr 14 21:32:23 linux-qogp NetworkManager: <WARN>  check_one_route(): (ath0) error -34 returned from rtnl_route_del(): Sucess#012                                                         
Apr 14 21:32:23 linux-qogp NetworkManager: <info>  (ath0): taking down device.               
Apr 14 21:32:23 linux-qogp nm-dispatcher.action: Script '/etc/NetworkManager/dispatcher.d/autofs' exited with error status 1.                                                             
Apr 14 21:33:16 linux-qogp NetworkManager: <info>  (ath0): bringing up device.               
Apr 14 21:33:16 linux-qogp NetworkManager: <info>  (ath0): device state change: 2 -> 3 (reason 0)                                                                                         
Apr 14 21:33:16 linux-qogp NetworkManager: <info>  (ath0): supplicant interface state:  starting -> ready                                                                                 
Apr 14 21:33:18 linux-qogp NetworkManager: <info>  Activation (ath0) starting connection 'NETGEAR'                                                                                        
Apr 14 21:33:18 linux-qogp NetworkManager: <info>  (ath0): device state change: 3 -> 4 (reason 0)                                                                                         
Apr 14 21:33:18 linux-qogp NetworkManager: <info>  Activation (ath0) Stage 1 of 5 (Device Prepare) scheduled...                                                                           
Apr 14 21:33:18 linux-qogp NetworkManager: <info>  Activation (ath0) Stage 1 of 5 (Device Prepare) started...                                                                             
Apr 14 21:33:18 linux-qogp NetworkManager: <info>  Activation (ath0) Stage 2 of 5 (Device Configure) scheduled...                                                                         
Apr 14 21:33:18 linux-qogp NetworkManager: <info>  Activation (ath0) Stage 1 of 5 (Device Prepare) complete.                                                                              
Apr 14 21:33:18 linux-qogp NetworkManager: <info>  Activation (ath0) Stage 2 of 5 (Device Configure) starting...                                                                          
Apr 14 21:33:18 linux-qogp NetworkManager: <info>  (ath0): device state change: 4 -> 5 (reason 0)                                                                                         
Apr 14 21:33:18 linux-qogp NetworkManager: <info>  Activation (ath0/wireless): access point 'NETGEAR' has security, but secrets are required.                                             
Apr 14 21:33:18 linux-qogp NetworkManager: <info>  (ath0): device state change: 5 -> 6 (reason 0)                                                                                         
Apr 14 21:33:18 linux-qogp NetworkManager: <info>  Activation (ath0) Stage 2 of 5 (Device Configure) complete.                                                                            
Apr 14 21:33:19 linux-qogp NetworkManager: <WARN>  update_one_setting(): Failed to update connection secrets: 1 802-1x                                                                    
Apr 14 21:33:19 linux-qogp NetworkManager: <WARN>  real_connection_secrets_updated(): Ignoring updated secrets for setting 'ipv4'.                                                        
Apr 14 21:33:19 linux-qogp NetworkManager: <WARN>  real_connection_secrets_updated(): Ignoring updated secrets for setting '802-11-wireless'.                                             
Apr 14 21:33:19 linux-qogp NetworkManager: <info>  Activation (ath0) Stage 1 of 5 (Device Prepare) scheduled...                                                                           
Apr 14 21:33:19 linux-qogp NetworkManager: <info>  Activation (ath0) Stage 1 of 5 (Device Prepare) started...                                                                             
Apr 14 21:33:19 linux-qogp NetworkManager: <info>  (ath0): device state change: 6 -> 4 (reason 0)                                                                                         
Apr 14 21:33:19 linux-qogp NetworkManager: <info>  Activation (ath0) Stage 2 of 5 (Device Configure) scheduled...                                                                         
Apr 14 21:33:19 linux-qogp NetworkManager: <info>  Activation (ath0) Stage 1 of 5 (Device Prepare) complete.                                                                              
Apr 14 21:33:19 linux-qogp NetworkManager: <info>  Activation (ath0) Stage 2 of 5 (Device Configure) starting...                                                                          
Apr 14 21:33:19 linux-qogp NetworkManager: <info>  (ath0): device state change: 4 -> 5 (reason 0)                                                                                         
Apr 14 21:33:19 linux-qogp NetworkManager: <info>  Activation (ath0/wireless): connection 'NETGEAR' has security, and secrets exist.  No new secrets needed.                              
Apr 14 21:33:19 linux-qogp NetworkManager: <info>  Config: added 'ssid' value 'NETGEAR'      
Apr 14 21:33:19 linux-qogp NetworkManager: <info>  Config: added 'scan_ssid' value '1'       
Apr 14 21:33:19 linux-qogp NetworkManager: <info>  Config: added 'key_mgmt' value 'WPA-PSK'  
Apr 14 21:33:19 linux-qogp NetworkManager: <info>  Config: added 'psk' value '<omitted>'     
Apr 14 21:33:19 linux-qogp NetworkManager: <info>  Activation (ath0) Stage 2 of 5 (Device Configure) complete.                                                                            
Apr 14 21:33:19 linux-qogp NetworkManager: <info>  Config: set interface ap_scan to 1        
Apr 14 21:33:19 linux-qogp NetworkManager: <info>  (ath0): supplicant connection state:  scanning -> disconnected                                                                         
Apr 14 21:33:23 linux-qogp NetworkManager: <info>  (ath0): supplicant connection state:  disconnected -> scanning                                                                         
Apr 14 21:33:25 linux-qogp NetworkManager: <info>  (ath0): supplicant connection state:  scanning -> associating                                                                          
Apr 14 21:33:28 linux-qogp NetworkManager: <info>  (ath0): supplicant connection state:  associating -> associated                                                                        
Apr 14 21:33:28 linux-qogp NetworkManager: <info>  (ath0): supplicant connection state:  associated -> 4-way handshake                                                                    
Apr 14 21:33:28 linux-qogp NetworkManager: <info>  (ath0): supplicant connection state:  4-way handshake -> group handshake                                                               
Apr 14 21:33:28 linux-qogp NetworkManager: <info>  (ath0): supplicant connection state:  group handshake -> completed                                                                     
Apr 14 21:33:28 linux-qogp NetworkManager: <info>  Activation (ath0/wireless) Stage 2 of 5 (Device Configure) successful.  Connected to wireless network 'NETGEAR'.                       
Apr 14 21:33:28 linux-qogp NetworkManager: <info>  Activation (ath0) Stage 3 of 5 (IP Configure Start) scheduled.                                                                         
Apr 14 21:33:28 linux-qogp NetworkManager: <info>  Activation (ath0) Stage 3 of 5 (IP Configure Start) started...                                                                         
Apr 14 21:33:28 linux-qogp NetworkManager: <info>  (ath0): device state change: 5 -> 7 (reason 0)                                                                                         
Apr 14 21:33:28 linux-qogp NetworkManager: <info>  Activation (ath0) Beginning DHCP transaction.                                                                                          
Apr 14 21:33:28 linux-qogp NetworkManager: <info>  dhclient started with pid 4078            
Apr 14 21:33:28 linux-qogp NetworkManager: <info>  Activation (ath0) Stage 3 of 5 (IP Configure Start) complete.                                                                          
Apr 14 21:33:28 linux-qogp NetworkManager: <info>  DHCP: device ath0 state changed normal exit -> preinit                                                                                 
Apr 14 21:33:32 linux-qogp NetworkManager: <info>  DHCP: device ath0 state changed preinit -> reboot                                                                                      
Apr 14 21:33:32 linux-qogp NetworkManager: <info>  Activation (ath0) Stage 4 of 5 (IP Configure Get) scheduled...                                                                         
Apr 14 21:33:32 linux-qogp NetworkManager: <info>  Activation (ath0) Stage 4 of 5 (IP Configure Get) started...                                                                           
Apr 14 21:33:32 linux-qogp NetworkManager: <info>    address 192.168.0.3                     
Apr 14 21:33:32 linux-qogp NetworkManager: <info>    prefix 24 (255.255.255.0)               
Apr 14 21:33:32 linux-qogp NetworkManager: <info>    gateway 192.168.0.1
Apr 14 21:33:32 linux-qogp NetworkManager: <info>    nameserver '192.168.0.1'
Apr 14 21:33:32 linux-qogp NetworkManager: <info>  Activation (ath0) Stage 5 of 5 (IP Configure Commit) scheduled...
Apr 14 21:33:32 linux-qogp NetworkManager: <info>  Activation (ath0) Stage 4 of 5 (IP Configure Get) complete.
Apr 14 21:33:32 linux-qogp NetworkManager: <info>  Activation (ath0) Stage 5 of 5 (IP Configure Commit) started...
Apr 14 21:33:33 linux-qogp NetworkManager: <info>  (ath0): device state change: 7 -> 8 (reason 0)
Apr 14 21:33:33 linux-qogp NetworkManager: <debug> [1271273613.063046] run_netconfig(): Spawning '/sbin/netconfig modify --service NetworkManager'
Apr 14 21:33:33 linux-qogp NetworkManager: <debug> [1271273613.160064] write_to_netconfig(): Writing to netconfig: DNSSERVERS='192.168.0.1'#012
Apr 14 21:33:33 linux-qogp NetworkManager: <info>  Clearing nscd hosts cache.
Apr 14 21:33:33 linux-qogp NetworkManager: <info>  Policy set 'NETGEAR' (ath0) as default for routing and DNS.
Apr 14 21:33:33 linux-qogp NetworkManager: <info>  Activation (ath0) successful, device activated.
Apr 14 21:33:33 linux-qogp NetworkManager: <info>  Activation (ath0) Stage 5 of 5 (IP Configure Commit) complete.
Apr 14 21:33:33 linux-qogp nm-dispatcher.action: Script '/etc/NetworkManager/dispatcher.d/autofs' exited with error status 1.

E' quell'errore alla fine che non mi torna...

6) ... ecco, appunto! Darò un'occhiata.

Atheros Communications Inc. AR5001 Wireless Network Adapter (rev 01)

P.S.: pure io preferisco Network Manager.

Hardware: http://tinyurl.com/nu57nm
Software: OpenSuse 11.2, KDE.

Ritratto di Lorentz
Lorentz
(Geek)
Offline
Geek
Iscritto: 31/01/2008
Messaggi: 93

ERRATA CORRIGE: ecco l'errore "vero"

Apr 14 23:32:01 linux-qogp NetworkManager: <WARN>  list_connections_cb(): Couldn't retrieve connections: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken..                                                        
Apr 14 23:32:03 linux-qogp NetworkManager: <WARN>  connection_get_settings_cb(): Couldn't retrieve connection settings: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken..                                         
Apr 14 23:32:03 linux-qogp NetworkManager: <WARN>  connection_get_settings_cb(): Couldn't retrieve connection settings: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken..                                         
Apr 14 23:32:03 linux-qogp NetworkManager: <WARN>  connection_get_settings_cb(): Couldn't retrieve connection settings: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken..                                         
Apr 14 23:32:04 linux-qogp NetworkManager: <WARN>  connection_get_settings_cb(): Couldn't retrieve connection settings: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken..                                         
Apr 14 23:32:04 linux-qogp NetworkManager: <WARN>  connection_get_settings_cb(): Couldn't retrieve connection settings: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken..                                         
Apr 14 23:33:12 linux-qogp NetworkManager: <WARN>  wait_for_connection_expired(): Connection (2) /org/freedesktop/NetworkManagerSettings/0 failed to activate (timeout): (0) Connection was not provided by any settings service

Hardware: http://tinyurl.com/nu57nm
Software: OpenSuse 11.2, KDE.