Samba e condivisione file.....

16 risposte [Ultimo messaggio]
Ritratto di Wave2184
Wave2184
(Junior)
Offline
Junior
Iscritto: 04/10/2004
Messaggi: 11

Ho dei problemini con Samba e la condivisione dei file...

Premetto che utilizzo fastweb....ho 2 computer tutti connessi direttamente all'hug di fastweb....

uno monta waindowsXP e il portatile invece SuSE9.1 ( Laughing )...

riesco a pingare in tutti e due i sensi (win -> linux | linux -> win)

ho abilitato il server samba sul portatile tramite yast dicendo che voglio condividere le home....e ho impostato il dominio di lavoro (CASA)

in risorse di rete del comp con win appare il portatile entro....mi appaiono 4 cartelle:
groups
profiles
users
Stampanti e fax

clicco su users...mi chiede nome utente e pass scrivo quelle del mio utente ma non mi accede....continua a chiedermi utente e pass.....

se invece provo ad accedere da linux al winXP con smb:\\[IP_winXP] o [hostname_WinXP] kde mi chiede username e password.....gli scrivo Administrator e [Pass_Administrator] ma kde mi risponde che il processo è morto inaspettatamente...

non so che fare....qualcuno mi potrebbe spiegare un po come funziona la cosa????

ciao e grazie...

Powered by:
SuSE 9.1
Gentoo 2004.2

Ritratto di Nakom
Nakom
(Junior)
Offline
Junior
Iscritto: 10/09/2004
Messaggi: 38

Probabilmente sul file /etc/samba/smb.conf hai settato:
security = user o security = server
prova con:
security = share
Ciao.

Ritratto di auris
auris
(Guru)
Offline
Guru
Iscritto: 10/09/2004
Messaggi: 4923

http://www.tu-chemnitz.de/docs/lindocs/RH73/RH-DOCS/rhl-cg-it-7.3/s1-samba-configuring.html

Se sei stanco di virus e schermate blu passa a Linux

Ritratto di Wave2184
Wave2184
(Junior)
Offline
Junior
Iscritto: 04/10/2004
Messaggi: 11

ho seguito la guida....e il consiglio di Nakom....

ora se provo da win ad accedere a linux mi chiede una password di un utente guest che non conosco...

sono proprio imbranato....ci credete che in tanto tempo che utilizzo linux non mi sono mai messo a configurare samba???però mi sono stufato adesso voglio configurarlo per benino.....

allora da quello che ho capito usare yast per configurare samba non mi sembra la cosa migliore....tocca modificare il file a mano....

però la cosa che non capisco è perchè non permette la navigazione da linux a win dicendome che il processo è morto inaspettatamente....possibile che bisogna configurare qualcos altro anche su winXP????

Powered by:
SuSE 9.1
Gentoo 2004.2

Ritratto di Wave2184
Wave2184
(Junior)
Offline
Junior
Iscritto: 04/10/2004
Messaggi: 11

Allora ho dato un okkiata al mio smb.conf e lìho modificato in questo modo....

# smb.conf is the main Samba configuration file. You find a full commented<br /># version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE<br /># Date: 2004-09-12<br />[global]<br />workgroup = CASA<br />printcap cache time = 750<br />cups options = raw<br />printer admin = @ntadmin, root, administrator<br />username map = /etc/samba/smbusers<br />map to guest = Bad User<br />logon path = \\%L\profiles\.msprofile<br />logon home = \\%L\%U\.9xprofile<br />logon drive = P:<br />security = share<br />null password = yes<br />encrypt password = yes<br />guest account = utentesmb<br />server string = <br />domain master = no<br />local master = no<br />load printers = no<br />ldap suffix = dc=example,dc=com<br />restrict anonymous = no<br />preferred master = no<br />max protocol = NT<br />ldap ssl = No<br />server signing = Auto<br />;; [homes]<br />;;   comment = Home Directories<br />;;   valid users = %S<br />;;   browseable = no<br />;;   read only = No<br />;;   inherit permissions = Yes<br />;;   guest ok = no<br />;;   printable = no<br />;; [profiles]<br />;;   comment = Network Profiles Service<br />;;   path = %H<br />;;   read only = No<br />;;   store dos attributes = Yes<br />;;   create mask = 0600<br />;;   directory mask = 0700<br />;;   browseable = yes<br />;;   guest ok = no<br />;;   printable = no<br />;; [users]<br />;;  comment = All users<br />;;  path = /home<br />;;  read only = No<br />;;  inherit permissions = Yes<br />;;  veto files = /aquota.user/groups/shares/<br /><br />[share]<br /> comment = Share<br /> browseable = yes<br /> guest ok = yes<br /> guest only = yes<br /> path = /windows/Share/share<br /> writable = yes<br /><br />;; [groups]<br />;;   comment = All groups<br />;;   path = /home/groups<br />;;   read only = No<br />;;   inherit permissions = Yes<br />;;   browseable = yes<br />;;   guest ok = no<br />;;   printable = no<br /><br />;; [pdf]<br />;;   comment = PDF creator<br />;;   path = /var/tmp<br />;;   printable = yes<br />;;   print command = /usr/bin/smbprngenpdf -J '%J' -c %c -s %s -u '%u' -z %z<br />;;   create mask = 0600<br />;;   browseable = yes<br />;;   guest ok = no<br /><br />;; [printers]<br />;;   comment = All Printers<br />;;   path = /var/tmp<br />;;   printable = yes<br />;;   create mask = 0600<br />;;   browseable = no<br />;;   guest ok = no<br /><br />;; [print$]<br />;;   comment = Printer Drivers<br />;;   path = /var/lib/samba/drivers<br />write list = @ntadmin root

ho voluto permettere l accesso a /windows/Share/share a chiunque....in effetti adesso da windows riesco a navigare quella cartella...ma quello che non capisco è perchè non riesco a scriverci file dentro...mi dice Impossibile copiare file. Accesso Negato. Controllare che il disco non sia pieno o protetto da scrittura e che il file non sia attualmente in uso....

naturalmente il file non è in uso e il disco non è pieno....eppure dalle impostazioni su smb.conf dovrei avere permessi di scrittura.....

non capisco....

e poi se cerco di accedere alla rete dal comp con linux ottengo questa in risposta da konqueror:

Errore durante la connessione al server responsabile di smb:/

Sad Sad non so più che fare....

Powered by:
SuSE 9.1
Gentoo 2004.2

Ritratto di JeanCarrel
JeanCarrel
(Geek)
Offline
Geek
Iscritto: 09/09/2004
Messaggi: 142

Visto il mio post (un minuto dopo il tuo) ti consiglio di togliere security=share x usare security=user.

Poi, la domanda sorge spontanea, ma anche il gruppo di lavoro in winzozz è "CASA"?

C.
Fede

Linux Registered User #353428
Powered by [d]SuSE 9.1 Pro[/d] »» ora Ubuntu dipendente 8-)

Ritratto di Wave2184
Wave2184
(Junior)
Offline
Junior
Iscritto: 04/10/2004
Messaggi: 11

si il gruppo di lavoro è CASA... Thinking

adesso dopo vari smanettamenti riesco a raggiungere una cartella condivisa in win e d ali riesco a fare i vari trasferimenti di file....ma la scrittura da win a linux è sempre impedita mentre da linux a win posso tutto....ora mi ci metto e vedo di risolvere la cosa....

cmq sia di che si tratta webmin????me lo consogli????

Powered by:
SuSE 9.1
Gentoo 2004.2

Ritratto di JeanCarrel
JeanCarrel
(Geek)
Offline
Geek
Iscritto: 09/09/2004
Messaggi: 142

Quote:

Wave2184 ha scritto:
[cut]...ma la scrittura da win a linux è sempre impedita mentre da linux a win posso tutto....ora mi ci metto e vedo di risolvere la cosa....

cmq sia di che si tratta webmin????me lo consogli????

Certo che ti consiglio Webmin!!

Tornando al tuo problema, ma la direstory condivisa è mica in una partizione winzozz? E magari anche NTFS :-\

Prova a dare come share /home/$tuoutente/Temp.
Se non esite creala e dagli "chmod ugo+rw"

Puoi aggiungere a smb.conf:

[...]

[Condivisa]
path=/home/$tuoutente/Temp
public=yes
writable=yes

C.
Fede

Linux Registered User #353428
Powered by [d]SuSE 9.1 Pro[/d] »» ora Ubuntu dipendente 8-)

Ritratto di ap1978
ap1978
(Guru)
Offline
Guru
Iscritto: 01/10/2004
Messaggi: 2972

Samba ha un proprio tool di gestione via web, SWAT. Se hai installato samba, automaticamente hai swat.

Per attivarlo apri da root il file /etc/xinetd.d/swat e cambia l'opzione disable in "no":

disable = no

Attiva il servizio xinetd nell'editor di runlevel di Yast! e riavvia.

Per accedere a swat apri un browser e vai all'indirizzo http//localhost:901

Trovi maggiori informazioni sul manuale online di samba disponibile sul sito www.samba.org

Ciao

ap Smile

ap Big Grin

Ritratto di Wave2184
Wave2184
(Junior)
Offline
Junior
Iscritto: 04/10/2004
Messaggi: 11

ho installato webmin ma se provo ad accedrci non mi entra....con http://localhost:10000

mi dice che cè un errore nel caricamento della pagina..

Powered by:
SuSE 9.1
Gentoo 2004.2

Ritratto di JeanCarrel
JeanCarrel
(Geek)
Offline
Geek
Iscritto: 09/09/2004
Messaggi: 142

Quote:

Wave2184 ha scritto:
ho installato webmin ma se provo ad accedrci non mi entra....con http://localhost:10000

mi dice che cè un errore nel caricamento della pagina..

Vai in /etc/webmin
da shell come root dai ./start

L'utility SWAT la trovi anche in Webmin.

C.
Fede

Linux Registered User #353428
Powered by [d]SuSE 9.1 Pro[/d] »» ora Ubuntu dipendente 8-)