imperium: sticks - non si avvia

17 risposte [Ultimo messaggio]
Ritratto di Speppa
Speppa
(Junior)
Offline
Junior
Iscritto: 04/08/2010
Messaggi: 7

salve
ho opensuse 11.3, con cpu 800mhz e ram 700mb
ho installato imperium: sticks dai repo
nel menu dei giochi compare la voce senza icona e cliccandoci non si apre
dal terminale lo stesso ma non capisco che problema sia
speppa@linux:~> cd /usr/bin
speppa@linux:/usr/bin> rtciv32
Game configuration file missing, reverting to defaults.

System video information detected:

Hardware acceleration is *not* available.
Software surfaces are enabled
Hardware surfaces are enabled
Video memory detected: 0
Video depth: 32 bits per pixel
Setting screen to 840 480
Selecting english description files...
Segmentation fault

se qualcuno ha qualche consiglio è il benvenuto

Ritratto di pinquadr
pinquadr
(Guru)
Offline
Guru
Iscritto: 20/11/2004
Messaggi: 921

Sembrerebbe un problema legato alla mancanza di accelerazione video. Che scheda hai?

OpenSuse Leap42 con KDE5 su Intel I7 4930K scheda madre Asus Sabertooth X79 - RAM 32 Gb - scheda video NVIDIA GTX660 1GB - scheda TV Hauppauge WinTV Nova T stick

Ritratto di Speppa
Speppa
(Junior)
Offline
Junior
Iscritto: 04/08/2010
Messaggi: 7

ciao
ho una nvidia ge force2 mx/mx 400
dovrei installare i driver? secondo la guida http://it.opensuse.org/NVIDIA#Installazione_attraverso_repository dovrei installare x11-video-nvidia solo che io ho da scegliere tra x11-video-nvidiaG01 e x11-video-nvidiaG02 e stando alle descrizioni dei pacchetti, il primo è per le "GeForceFX GPUs" l'altro per "GeForce 6xxx and newer GPUs" e la mia non rientra in questi casi.

Ritratto di pinquadr
pinquadr
(Guru)
Offline
Guru
Iscritto: 20/11/2004
Messaggi: 921

Non uso Nvidia. Però una breve ricerca con Google su "nvidia geforce2 mx+opensuse" mi ha fornito diversi risultati, tra cui:

http://www.williweb.it/joomla/utilita-opensuse/opensuse-11.2-11.1-11.0-installare-driver-nvidia-one-click-install.html

non conosco la situazione per OpenSuse 11.3, però ho letto di diversi problemi con le schede video Nvidia.

OpenSuse Leap42 con KDE5 su Intel I7 4930K scheda madre Asus Sabertooth X79 - RAM 32 Gb - scheda video NVIDIA GTX660 1GB - scheda TV Hauppauge WinTV Nova T stick

Ritratto di fusoo
fusoo
(Monster)
Offline
Monster
Iscritto: 04/08/2010
Messaggi: 230

prova ad installare manualmente i driver scaricandoli dal sito nvidia. io sono riuscito al primo colpo seguendo questa guida http://www.crismonblog.org/opensuse-11.3/installare-il-driver-nvidia-binary-version-in-opensuse-11.3.html
i driver sono questi http://www.nvidia.it/object/linux-display-ia32-96.43.18-driver-it.html i giochi a me funzionano bene
ciao fusoo

desktop,laptop,netbook con opensuse 12.3 , cell android -tv32led,ricevitore sat,videotelefono telecom,router wifi:linux inside -per il frigorifero mi sto attrezzando

Ritratto di bagarozzo85
bagarozzo85
(Guru)
Offline
Guru
Iscritto: 16/06/2006
Messaggi: 1050

Speppa,

la tua scheda video non è più supportata dai driver proprietari, perciò la loro installazione renderebbe il tuo sistema inutilizzabile.
Al massimo, verifica col seguente comando che i driver nouveau siano installati:
zypper se -s nouveau|grep ^i

Se in uscita hai qualcosa del tipo:
i | xorg-x11-driver-video-nouveau | package | 0.0.15_20100401_bfb95cc-1.10 | i586 | openSUSE-11.3-Oss

allora i driver sono installati.

Non ho mai usato questi driver, quindi non so dirti come impostare l'accelerazione 3D, ma per verificare se sia attiva o meno puoi usare questo comando:
glxinfo|grep direct

Ovviamente, Yes significa che è attiva.

Ritratto di fusoo
fusoo
(Monster)
Offline
Monster
Iscritto: 04/08/2010
Messaggi: 230

beh io ho installato i driver proprietari e il sistema funziona benissimo i driver del 4 agosto sono compatibili con xorg 1.8 quindi sono perfettamente installabili
e utilizzabili
con i driver noveau supertuxkart faceva 5 fps con i proprietari circa 25 su nvidia geforce 2 mx400
ciao fusoo

desktop,laptop,netbook con opensuse 12.3 , cell android -tv32led,ricevitore sat,videotelefono telecom,router wifi:linux inside -per il frigorifero mi sto attrezzando

Ritratto di bagarozzo85
bagarozzo85
(Guru)
Offline
Guru
Iscritto: 16/06/2006
Messaggi: 1050

Se ho sbagliato chiedo scusa, ma andando sul sito per il download del driver si può notare come, selezionando il tipo di periferica, il supporto parta dalla serie GeForce 4, che è di qualche anno più recente dalla GeForce 2 che, se ho capito bene, equipaggia la macchina di Speppa.

Ritratto di Speppa
Speppa
(Junior)
Offline
Junior
Iscritto: 04/08/2010
Messaggi: 7

@bagarozzo85: no non sbagli, ho visto anche io. ma se ho capito bene fusoo ha la mia stessa scheda video ed ha usato questi driver
infatti stavo seguendo la guida linkata da fusoo ma ho dei piccoli problemi che sto cercando di risolvere...

comunque dando:
speppa@linux:~> zypper se -s nouveau|grep ^i
i | xorg-x11-driver-video-nouveau | pacchetto | 0.0.15_20100401_bfb95cc-1.10 | i586 | openSUSE-11.3-Oss
i | xorg-x11-driver-video-nouveau | pacchetto | 0.0.15_20100401_bfb95cc-1.10 | i586 | openSUSE-11.3 11.3-1.82

si sono installati infatti quelli non proprietari e l'accelerazione grafica non è attivata:
speppa@linux:~> glxinfo|grep direct
direct rendering: No

dovrei cercare di disabilitare i nouveau perchè quando arrivo all'installazione mi dice che ci sono già driver attivi, eppure ho seguito passo passo tutta la guida.
se li disinstallo non li dovrebbe vedere o poi non riesco ad usare nemmeno le console (tty1)?

**edit
sono riuscita a installare i driver proprietari, l'accelerazione grafica è attivata:
speppa@linux:/usr/bin> glxinfo|grep direct
direct rendering: Yes

ma il gioco fa sempre lo stesso scherzo:
speppa@linux:/usr/bin> rtciv32
Game configuration file missing, reverting to defaults.

System video information detected:

Hardware acceleration is *not* available.
Software surfaces are enabled
Hardware surfaces are enabled
Video memory detected: 0
Video depth: 32 bits per pixel
Setting screen to 840 480
Selecting english description files...
Segmentation fault

sembra che non veda l'accelerazione grafica. ho dato anche un riavvio per sicurezza ma la situazione non cambia
intanto grazie a tutti per l'aiuto

Ritratto di anubis
anubis
(Guru)
Offline
Guru
Iscritto: 07/04/2007
Messaggi: 3656

il programma va in crash!!!

Speppa ha scritto:


Segmentation fault

OpenSUSE Member,Packman Packager, Education Project Admin, LXDE Project Admin
Powered by http://en.opensuse.org/HP_Pavilion_dv6855el

Ritratto di bagarozzo85
bagarozzo85
(Guru)
Offline
Guru
Iscritto: 16/06/2006
Messaggi: 1050

Speppa ha scritto:
@bagarozzo85: no non sbagli, ho visto anche io. ma se ho capito bene fusoo ha la mia stessa scheda video ed ha usato questi driver

Allora, sembra che la questione della compatibilità sia scaturita da un errore nel sito della Nvidia, perché nelle release notes del driver da te linkato è scritto chiaramente:
[...]
The 96.43.xx driver supports the following set of GPUs:

NVIDIA GPU product Device PCI ID
---------------------------------------------
GeForce2 MX/MX 400 0x0110
[...]

Quindi quel driver è compatibile con la tua VGA.

Ora, 2 cose:
- visto che la mia Nvidia è bruciata non posso più provare, però il metodo migliore, più veloce, più sicuro, più semplice ecc. per installare i driver proprietari in openSUSE consiste da sempre nell'aggiungere il repository Nvidia (se hai mai aggiornato il sistema dovresti trovare tale repository nella lista dei repository della comunità) e aggiornare il sistema.
Il metodo di crismonblog che ti ha linkato fusoo funzionerà certamente, ma richiede l'installazione dei pacchetti della toolchain che non ti servono, è più complicato e, soprattutto, va ripetuto a ogni aggiornamento del kernel;

- da quale repository hai installato il gioco? Non riesco a trovarlo da webpin.