problema installazione open raider

5 risposte [Ultimo messaggio]
Ritratto di anubis
anubis
(Guru)
Offline
Guru
Iscritto: 07/04/2007
Messaggi: 3656

trovato solo tramite sorgenti.. ho questo errore al make:

Anubis-pc:/home/anubis/Desktop/OpenRaider-0.1.0 # make<br />make targets BUILDDIR=bin/debug \<br />        CFLAGS=&quot;-Wall -Isrc -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT -DSDL_INTERFACE -DUSING_OPENGL -DZLIB_SUPPORT -DUSING_EMITTER -DUSING_OPENAL -DUSING_MTK_TGA -DUSING_PTHREADS -DUSING_HEL -DVERSION=\&quot;\\\&quot;OpenRaider-0.1.0.sdl-20030512\\\&quot;\&quot; -DBUILD_HOST=\&quot;\\\&quot;`uname -s -n -r -m`\\\&quot;\&quot; -g -O0 -DDEBUG -DEXPERIMENTAL&quot; \<br />        LD_FLAGS=&quot;-L/usr/X11R6/lib -lXmu -lXt -lSM -lICE -lXext -lX11 -lXi -lGL -lGLU -lm -L/usr/lib -lSDL -lpthread -lz -lstdc++ -lopenal -lpthread&quot;<br />make[1]: Entering directory `/home/anubis/Desktop/OpenRaider-0.1.0&#039;<br />gcc -Wall -Isrc -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT -DSDL_INTERFACE -DUSING_OPENGL -DZLIB_SUPPORT -DUSING_EMITTER -DUSING_OPENAL -DUSING_MTK_TGA -DUSING_PTHREADS -DUSING_HEL -DVERSION=&quot;\&quot;OpenRaider-0.1.0.sdl-20030512\&quot;&quot; -DBUILD_HOST=&quot;\&quot;Linux Anubis-pc 2.6.18.2-34-default i686\&quot;&quot; -g -O0 -DDEBUG -DEXPERIMENTAL -o bin/debug/Vector3d.o -c src/hel/Vector3d.cpp<br />gcc -Wall -Isrc -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT -DSDL_INTERFACE -DUSING_OPENGL -DZLIB_SUPPORT -DUSING_EMITTER -DUSING_OPENAL -DUSING_MTK_TGA -DUSING_PTHREADS -DUSING_HEL -DVERSION=&quot;\&quot;OpenRaider-0.1.0.sdl-20030512\&quot;&quot; -DBUILD_HOST=&quot;\&quot;Linux Anubis-pc 2.6.18.2-34-default i686\&quot;&quot; -g -O0 -DDEBUG -DEXPERIMENTAL -o bin/debug/Matrix.o -c src/hel/Matrix.cpp<br />gcc -Wall -Isrc -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT -DSDL_INTERFACE -DUSING_OPENGL -DZLIB_SUPPORT -DUSING_EMITTER -DUSING_OPENAL -DUSING_MTK_TGA -DUSING_PTHREADS -DUSING_HEL -DVERSION=&quot;\&quot;OpenRaider-0.1.0.sdl-20030512\&quot;&quot; -DBUILD_HOST=&quot;\&quot;Linux Anubis-pc 2.6.18.2-34-default i686\&quot;&quot; -g -O0 -DDEBUG -DEXPERIMENTAL -o bin/debug/ViewVolume.o -c src/hel/ViewVolume.cpp<br />gcc -Wall -Isrc -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT -DSDL_INTERFACE -DUSING_OPENGL -DZLIB_SUPPORT -DUSING_EMITTER -DUSING_OPENAL -DUSING_MTK_TGA -DUSING_PTHREADS -DUSING_HEL -DVERSION=&quot;\&quot;OpenRaider-0.1.0.sdl-20030512\&quot;&quot; -DBUILD_HOST=&quot;\&quot;Linux Anubis-pc 2.6.18.2-34-default i686\&quot;&quot; -g -O0 -DDEBUG -DEXPERIMENTAL -o bin/debug/BoundingVolume.o -c src/hel/BoundingVolume.cpp<br />gcc -Wall -Isrc -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT -DSDL_INTERFACE -DUSING_OPENGL -DZLIB_SUPPORT -DUSING_EMITTER -DUSING_OPENAL -DUSING_MTK_TGA -DUSING_PTHREADS -DUSING_HEL -DVERSION=&quot;\&quot;OpenRaider-0.1.0.sdl-20030512\&quot;&quot; -DBUILD_HOST=&quot;\&quot;Linux Anubis-pc 2.6.18.2-34-default i686\&quot;&quot; -g -O0 -DDEBUG -DEXPERIMENTAL -o bin/debug/Quaternion.o -c src/hel/Quaternion.cpp<br />gcc -Wall -Isrc -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT -DSDL_INTERFACE -DUSING_OPENGL -DZLIB_SUPPORT -DUSING_EMITTER -DUSING_OPENAL -DUSING_MTK_TGA -DUSING_PTHREADS -DUSING_HEL -DVERSION=&quot;\&quot;OpenRaider-0.1.0.sdl-20030512\&quot;&quot; -DBUILD_HOST=&quot;\&quot;Linux Anubis-pc 2.6.18.2-34-default i686\&quot;&quot; -g -O0 -DDEBUG -DEXPERIMENTAL -o bin/debug/math.o -c src/hel/math.cpp<br />/usr/include/bits/waitstatus.h:80: error: declaration of ‘unsigned int wait::&lt;anonymous struct&gt;::__w_retcode’<br />/usr/include/bits/waitstatus.h:75: error: conflicts with previous declaration ‘unsigned int wait::&lt;anonymous struct&gt;::__w_retcode’<br />/usr/include/bits/waitstatus.h:81: error: declaration of ‘unsigned int wait::&lt;anonymous struct&gt;::__w_coredump’<br />/usr/include/bits/waitstatus.h:74: error: conflicts with previous declaration ‘unsigned int wait::&lt;anonymous struct&gt;::__w_coredump’<br />/usr/include/bits/waitstatus.h:82: error: declaration of ‘unsigned int wait::&lt;anonymous struct&gt;::__w_termsig’<br />/usr/include/bits/waitstatus.h:73: error: conflicts with previous declaration ‘unsigned int wait::&lt;anonymous struct&gt;::__w_termsig’<br />/usr/include/bits/waitstatus.h:94: error: declaration of ‘unsigned int wait::&lt;anonymous struct&gt;::__w_stopsig’<br />/usr/include/bits/waitstatus.h:89: error: conflicts with previous declaration ‘unsigned int wait::&lt;anonymous struct&gt;::__w_stopsig’<br />/usr/include/bits/waitstatus.h:95: error: declaration of ‘unsigned int wait::&lt;anonymous struct&gt;::__w_stopval’<br />/usr/include/bits/waitstatus.h:88: error: conflicts with previous declaration ‘unsigned int wait::&lt;anonymous struct&gt;::__w_stopval’<br />make[1]: *** [bin/debug/math.o] Error 1<br />make[1]: Leaving directory `/home/anubis/Desktop/OpenRaider-0.1.0&#039;<br />make: *** [debug] Error 2<br />

quale può essere il problema?

p.s. esiste qualche versione magari più decente, di tomb raider per linux?? Laughing

OpenSUSE Member,Packman Packager, Education Project Admin, LXDE Project Admin
Powered by http://en.opensuse.org/HP_Pavilion_dv6855el

Ritratto di anubis
anubis
(Guru)
Offline
Guru
Iscritto: 07/04/2007
Messaggi: 3656

gcc sembra funzionare.. da cosa può dipendere?

OpenSUSE Member,Packman Packager, Education Project Admin, LXDE Project Admin
Powered by http://en.opensuse.org/HP_Pavilion_dv6855el

Ritratto di pinguinopaesano
pinguinopaesano
(Monster)
Offline
Monster
Iscritto: 30/06/2006
Messaggi: 418

Salve, vorrei sapere se poi qualcuno è riuscito a compilare un pacchetto per openraider...

Ritratto di Crismon
Crismon
(Guru)
Offline
Guru
Iscritto: 28/11/2006
Messaggi: 1715

Ricevo lo stesso errore anche io... ora mi chiedevo (forse stupidata dell'anno) se convertissimo il .deb in rpm? Andiamo incontro a problemi strutturali o potrebbe essere un'idea?

www.crismonblog.org | Un blog targato openSUSE

Ritratto di Crismon
Crismon
(Guru)
Offline
Guru
Iscritto: 28/11/2006
Messaggi: 1715

Ok Ok non ho avuto pazienza... mi sono creato l'rpm l'ho installato ma credo che abbia dei problemi nel riconoscimento dei driver video.... non so....

crismon@linux-v7jl:/usr&gt; OpenRaider<br />UID 2256624793<br /><br />[Starting OpenRaider-0.1.0.sdl-20030512]<br /><br />Resource system<br />Command&gt; [Network.Server] &#039;Dedicated=false&#039; not implemented<br /><br />[Starting video subsystem...]<br />@Created OpenGL Context...<br /><br /><br />        ## GL Driver Info ##<br />        Vendor     : (null)<br />        Renderer   : (null)<br />        Version    : (null)<br />        Extensions : (null)<br /><br /><br />Segmentation fault

www.crismonblog.org | Un blog targato openSUSE

Ritratto di Crismon
Crismon
(Guru)
Offline
Guru
Iscritto: 28/11/2006
Messaggi: 1715

Volevo aggiungere che leggendo sui vari file di configurazione trovo OpenRaider.init e al suo interno nella sezione video c''e

[Video.OpenGL]<br />Driver=/usr/lib/libGL.so.1<br />Width=640<br />Height=480<br />FastCard=true<br />FullScreen=false

Mi chiedo... è corretta questa riga a vostro avviso?

Driver=/usr/lib/libGL.so.1

www.crismonblog.org | Un blog targato openSUSE