Connessione nokia 6630 Opensuse 11.1

Ritratto di stephen71
stephen71
(Geek)
Offline
Geek
Iscritto: 30/12/2006
Messaggi: 52

Grazie alle guide e ai Vostri post sono riuscito ad installare il modem del 6630 sulla suse 11.1. Ero rimasto alla suse 10.2.......
Ora uso kinternet e ho però questo problema che su internet ho riscontrato essere frequente ma senza soluzione.
In pratica ogni tanto si disconnette, riprovo a connettermi ed è come se il cellulare sia impallato. Devo quindi spegnere il cell e poi riaccenderlo per riconnettermi. Questo succedeva anche con la suse 10.2 ma non così di frequente.
Purtroppo non ho alcun file di log da postare ma se qualcuno mi sa dire cosa fare per reperirlo lo posto.
Grazie

Ritratto di stephen71
stephen71
(Geek)
Offline
Geek
Iscritto: 30/12/2006
Messaggi: 52

Ecco il file di log di kinternet:

trying to connect to smpppd
connect to smpppd
Status is: disconnected
Status is: connecting
pppd[0]: Plugin passwordfd.so loaded.
pppd[0]: --> WvDial: Internet dialer version 1.60
pppd[0]: --> Initializing modem.
pppd[0]: --> Sending: ATZ
pppd[0]: ATZ
pppd[0]: OK
pppd[0]: --> Sending: AT Q0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
pppd[0]: AT Q0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
pppd[0]: OK
pppd[0]: --> Sending: ATM1
pppd[0]: ATM1
pppd[0]: OK
pppd[0]: --> Modem initialized.
pppd[0]: --> Sending: ATDP*99***1#
pppd[0]: --> Waiting for carrier.
pppd[0]: ATDP*99***1#
pppd[0]: CONNECT
pppd[0]: ~[7f]}#@!}!} } }2}#}$@#}!}$}%\}"}&} }*} } g}%~
pppd[0]: --> Carrier detected. Waiting for prompt.
pppd[0]: ~[7f]}#@!}!} } }2}#}$@#}!}$}%\}"}&} }*} } g}%~
pppd[0]: --> PPP negotiation detected.
pppd[0]: Script /usr/bin/wvdial --chat --no-syslog --config /var/run/smpppd/chat-modem1.conf smpppd finished (pid 4475), status = 0x0
pppd[0]: Serial connection established.
pppd[0]: Renamed interface ppp0 to modem1
pppd[0]: Using interface modem1
Status is: connecting
pppd[0]: Connect: modem1 <--> /dev/ttyACM0
pppd[0]: PAP authentication succeeded
pppd[0]: local IP address 151.81.25.179
pppd[0]: remote IP address 10.6.6.6
pppd[0]: primary DNS address 193.70.152.25
pppd[0]: secondary DNS address 193.70.192.25
pppd[0]: Script /etc/ppp/ip-up finished (pid 4497), status = 0x0
Status is: connected
pppd[0]: Hangup (SIGHUP)
pppd[0]: Modem hangup
pppd[0]: Connect time 10.2 minutes.
pppd[0]: Sent 82931 bytes, received 221855 bytes.
pppd[0]: Connection terminated.
pppd[0]: Script /etc/ppp/ip-down finished (pid 5430), status = 0x0
Status is: disconnected
pppd[0] died: A modem hung up the phone (exit code 16)

Perchè si disconnette? In 30 minuti la connessione cade 3 o 4 volte senza motivo :-o :-o e non so più che fare.

Ritratto di stephen71
stephen71
(Geek)
Offline
Geek
Iscritto: 30/12/2006
Messaggi: 52

Ragazzi sono disperato :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry:
Il nokia 6630 si disconnette di continuo.
Tutte le volte lo devo riavviare per poi connettermi altrimenti si pianta.
Una dritta..............

Ritratto di stephen71
stephen71
(Geek)
Offline
Geek
Iscritto: 30/12/2006
Messaggi: 52

Dopo varie peripezie ho scoperto che yast non mi salva la configurazione del modem. Imposto la velocità e gli init come avevo precedentemente sul kppprc ma ogni volta che visualizzo la configurazione mi rimane sempre la stessa di default.
Qualcuno mi sa dire il file da modificare a mano?
Grazie.

Ritratto di sunrots
sunrots
(Guru)
Offline
Guru
Iscritto: 04/01/2005
Messaggi: 510

Quote:

stephen71 ha scritto:
Dopo varie peripezie ho scoperto che yast non mi salva la configurazione del modem

Il problema è strano. Prova ad utilizzare kppp per connetterti, oppure gnomeppp e controlla se così eviti le interruzioni continue.
Saluti,

sunrots

Non più attivo qui. Mi troverete su http://it-opensuse.org Wink

Ritratto di stephen71
stephen71
(Geek)
Offline
Geek
Iscritto: 30/12/2006
Messaggi: 52

Quote:

sunrots ha scritto:
Il problema è strano. Prova ad utilizzare kppp per connetterti, oppure gnomeppp e controlla se così eviti le interruzioni continue.
Saluti,

sunrots

Ho fatto proprio così e per ora non ho avuto nessuna interruzione ma è troppo poco per cantare vittoria.
Su windog non mi si disconnette.
Comunque sono sempre alla ricerca del file da configurare per capire effettivamente cosa poteva causare la disconnessione.
Dovè che yast scrive la configurazione di kinternet?
nel file /etc/wvdial.conf NO visto che ho già provato e non funzia.
IN CHE FILE SCRIVE STA BENEDETTA CONFIGURAZIONE???????? :-o :-o :-o

Ritratto di sunrots
sunrots
(Guru)
Offline
Guru
Iscritto: 04/01/2005
Messaggi: 510

Quote:

stephen71 ha scritto:
Dovè che yast scrive la configurazione di kinternet?
nel file /etc/wvdial.conf NO visto che ho già provato e non funzia.
IN CHE FILE SCRIVE STA BENEDETTA CONFIGURAZIONE???????? :-o :-o :-o

http://forums.opensuse.org/archives/sls-archives/archives-suse-linux/archives-network-security/384798-where-modem-configuration-files-stored.html

Nemmeno io sapevo esattamente dove lo scrivesse... così anche oggi ho imparato qualcosa... Smile
Saluti,

sunrots

Non più attivo qui. Mi troverete su http://it-opensuse.org Wink

Ritratto di stephen71
stephen71
(Geek)
Offline
Geek
Iscritto: 30/12/2006
Messaggi: 52

Quote:

sunrots ha scritto:

http://forums.opensuse.org/archives/sls-archives/archives-suse-linux/archives-network-security/384798-where-modem-configuration-files-stored.html

Nemmeno io sapevo esattamente dove lo scrivesse... così anche oggi ho imparato qualcosa... Smile
Saluti,

sunrots

Grazie è proprio quello che cercavo. Ho modificato a mano il file e finalmente ha preso la nuova configurazione. Ora sto testando e spero vada meglio anche perche il kppp ha gli stessi problemi Sad

Ritratto di stephen71
stephen71
(Geek)
Offline
Geek
Iscritto: 30/12/2006
Messaggi: 52

Ragazzi sono nella ca..a!!!!!!!
Provo continuamente a modificare la configurazione del collegamento al modem ma senza successo.
Non riesco a capire se il modem si disconnette a causa di qualche sito internet o se invece il problema sia nella configurazione.
Qualcuno mi può aiutare?

Ritratto di sunrots
sunrots
(Guru)
Offline
Guru
Iscritto: 04/01/2005
Messaggi: 510

Quote:

Qualcuno mi può aiutare?

Si, forse qualcuno potrebbe aiutare, ma nel messaggio di richiesta aiuto perché l'80% degli utenti non aggiunge mai il minimo di informazioni che sarebbero utili a capirci qualcosa? Incollare per cortesia l'attuale configurazione che dà problemi e forse sarà possibile andare oltre.
Saluti,

sunrots

Non più attivo qui. Mi troverete su http://it-opensuse.org Wink