Aggiornamento Flash su Opensuse 12.3

23 risposte [Ultimo messaggio]
Ritratto di xenarulz
xenarulz
(Geek)
Offline
Geek
Iscritto: 01/05/2006
Messaggi: 54

Salve a tutti.
Come da oggetto, ho una vecchia versione di Opensuse (per l'uso che ne faccio è ok e non sento necessità di cambiarla) ma adesso mi trovo di fronte a un problema notevole, non riesco ad aggiornare Flash.
Yast mi dice che ho su la 11.2.202.440-2.115.1 che per i repo che ho è l'ultima disponibile.
In realtà dal sito Adobe ne vedo una ben più recente, ma non riesco a installarla.
Scarico il pacchetto, mi chiede se voglio installarlo con Yast, dico di sì, Yast si apre, controlla i repo, poi va per installare e dopo un pò si chiude. Buon senso vuole che abbia fatto quel che doveva. Invece no, se controllo c'è sempre la vecchia versione.
Aiuto! Mi dite tutti i passaggi che devo seguire per installare a manina dal sito Adobe lo stramaledetto flash?
Grazie...

Ritratto di boffo
boffo
(Guru)
Offline
Guru
Iscritto: 17/10/2005
Messaggi: 687

Flash viene aggiornato in automatico, non hai bisogno di aggiornarlo a mano.
Tra l'altro Flash è una tecnologia vecchia, ormai viene usato quasi esclusivamente per le pubblicità.
Se non hai ancora l'ultima versione non ti preoccupare che arrivera.
Se usi chrome allora flash è già incluso con chrome.

Ritratto di xenarulz
xenarulz
(Geek)
Offline
Geek
Iscritto: 01/05/2006
Messaggi: 54

No, guarda, io NON ho l'ultima versione e tutti i siti chelo usano (oltre a Yast) mi confermano che non ce l'ho.
La stessa Mozilla nella pagina di controllo plugin mi dice che ho una versione non aggiornata e mi reindirizza al sito Adobe per scaricarla.
Il problema è che nei repisitories sono mesi e mesi che l'ultima versione non viene mostrata, temo che per la mia versione di Suse non lo sarà mai e per questo volevo scaricarmela a mano.

Quanto all'uso, un'infinità di siti usa flash (ok specie per ragioni di gaming ma non solo, anche video e effetti speciali). Per dire se uno ha anche windows non può scaricare adobe reader se non ha flash perchè la pagina di adobe lo

Ritratto di rocking_horse
rocking_horse
(Geek)
Offline
Geek
Iscritto: 21/07/2006
Messaggi: 187

Prova a installare il pacchetto rpm con Apper anziché Yast

openSuse Leap 15.1 - Packard Bell Imedia S Core i3 4 GB RAM - AMD Radeon HD 7350 1GB

Ritratto di gi-gi
gi-gi
(Moderatore)
Offline
Moderatore
Iscritto: 09/12/2014
Messaggi: 418

Ciao.

Su un PC con installata la versione a 32 bit di openSuse 12.3 ho scaricato l'ultima versione di flash-player (11.2.202.491-2.64.1)
) e di flash-player-kde4 dal repository della 13.2 ed ho provato ad installare i due pacchetti da YaST dopo aver creato un repository locale.
YaST segnala il mancato soddisfacimento di una dipendenza (flash-player-kde4-11.2.202.491-2.64.1 richiede la versione 4.14 o superiore di kde). Se però disinstalli flash-player-kde4 (o ne forzi l'aggiornamento) flash-player-11.2.202.491-2.64.1 viene installato senza problemi.
Non sono in grado di dirti quanto flash-player-kde4 sia indispensabile, forse ti conviene fare una prova.

gigi

Ritratto di xenarulz
xenarulz
(Geek)
Offline
Geek
Iscritto: 01/05/2006
Messaggi: 54

Interrogazione non riuscita
could not resolve: file:///home/elena/Downloads/adobe-release-x86_64-1.0-1.noarch.rpm

Ritratto di xenarulz
xenarulz
(Geek)
Offline
Geek
Iscritto: 01/05/2006
Messaggi: 54

Grazie ho provato a disinstallare ma non cambia nulla

Ritratto di gi-gi
gi-gi
(Moderatore)
Offline
Moderatore
Iscritto: 09/12/2014
Messaggi: 418

Ciao.

Se vuoi un aiuto per provare a risolvere il problema dovresti fornire un minimo di informazioni:

- indicare precisamente il rilascio (12.3) e la piattaforma (32 o 64 bit?)

- quale strumento usi per l'installazione (YaST?)

- dove hai reperito il file da installare (repository ufficiale o altro?)

- quali errori ricevi durante l'installazione

- altro che tu possa ritenere utile ...

gigi

Ritratto di xenarulz
xenarulz
(Geek)
Offline
Geek
Iscritto: 01/05/2006
Messaggi: 54

Ciao. Ho la 12.3 64 bit
Sui repositories della mia versione non c'è l'ultima versione di flash, tutto il casino viene da lì perchè ho dovuto cercare il pacchetto altrove.
Sono andata dal sito Adobe e l'ho preso lì (anche Mozilla per Firefox mi manda là), ma una volta scaricato non riesco a installarlo.
Il pacchetto rpm in particolare è minuscolo (tipo 4 kb) e suppongo che una volta 'lanciato' con Yast debba andare aprendere il resto del pacchetto da qualche parte, ma evidentemente non lo trova.
Il .tar.gz non so come gestirlo...

Ritratto di gi-gi
gi-gi
(Moderatore)
Offline
Moderatore
Iscritto: 09/12/2014
Messaggi: 418

Ciao.

Comincia a scaricare l'rpm dal link qui sotto:

https://get.adobe.com/it/flashplayer/download/?installer=Flash_Player_11.2_for_other_Linux_%28.rpm%29_64-bit&standalone=1

Ho visto che non c'è alcun riferimento né alla distribuzione, né tanto meno al rilascio, quindi dovresti poterlo installare.

La versione è la stessa che ho io sulla 13.2.

Poi fammi sapere.

gigi

Ritratto di xenarulz
xenarulz
(Geek)
Offline
Geek
Iscritto: 01/05/2006
Messaggi: 54

E' precisamente il posto da cui l'avevo scaricato, e non funziona