Aiuto gestione software

4 risposte [Ultimo messaggio]
Ritratto di LaRue
LaRue
(Junior)
Offline
Junior
Iscritto: 12/05/2010
Messaggi: 25

Salve a tutti, mi sono appena decisa a passare alla 11.4 ma ho un problema col gestore software.
Se provo ad aprire il gestore software si blocca il caricamento perchè un certo "package kit" è in esecuzione. Che diavolo significa? Cosa faccio? E perchè mi ritrovo sempre con problemi di questo tipo? ç__ç
Grazie per l'attezione.

Ritratto di Gollum
Gollum
(Collaboratore)
Offline
Collaboratore
Iscritto: 03/03/2005
Messaggi: 802

PackageKit è il gestore del software di openSUSE e che si occupa quindi anche di cercare gli aggiornamenti disponibili per la distribuzione. L'allarme che te ricevi è inerente proprio a questo, ovvero il software è in esecuzione e non ti permette di avviare altre applicazioni che hanno a che fare con il software. Che tipo di desktop stai usando, KDE oppure GNOME?

Desktop DELL XPS8100 => openSUSE_12.2 => KDE 4.10 => Core i7 => 3.4.28-2.20 => Nvidia GT220
Notebook Sony Vaio VPPCA =>openSUSE_12.2 => KDE 4.10 => Core i5 => 3.4.28-2.20 => AMD HD 6470M

Ritratto di LaRue
LaRue
(Junior)
Offline
Junior
Iscritto: 12/05/2010
Messaggi: 25

gnome.
Il punto è che mi è successo appena installato, non è che ci abbia messo le mani incasinando roba.

Ritratto di LaRue
LaRue
(Junior)
Offline
Junior
Iscritto: 12/05/2010
Messaggi: 25

No, adesso ho riavviato, riprovato e funziona °__° Anche se non ho capito perchè. Avevo già ravviato una volta ma non era cambiato nulla.
Boh?

Ritratto di Gollum
Gollum
(Collaboratore)
Offline
Collaboratore
Iscritto: 03/03/2005
Messaggi: 802

Semplicemente perchè il gestore ha appurato che sul sistema non ci sono pacchetti da aggiornare. Fai attenzione: il gestore packagekit si attiva in automatico ogni volta che la sessione viene avviata quindi sicuramente ti capiterà di nuovo (ma è normale, il sistema ti avvisa che non puoi gestire a mano i pacchetti perchè al momento ci sta pensando lui) almeno che tu non aspetti che abbia finito il suo lavoro oppure che non lo disattivi all'avvio, nel qual caso gli aggiornamenti li dovrai controllare a mano tramite Yast oppure del terminale con zypper. Spero di essre stato un po più chiaro Ciao.

Desktop DELL XPS8100 => openSUSE_12.2 => KDE 4.10 => Core i7 => 3.4.28-2.20 => Nvidia GT220
Notebook Sony Vaio VPPCA =>openSUSE_12.2 => KDE 4.10 => Core i5 => 3.4.28-2.20 => AMD HD 6470M