Beryl svn

29 risposte [Ultimo messaggio]
Ritratto di BrianM
BrianM
(Junior)
Offline
Junior
Iscritto: 28/01/2007
Messaggi: 20

Ciao, ho seguito la guida di JJ_Kame_R per installare beryl svn...che nn so che differenza abbia con beryl... Insomma, mi da questo errore:
Quote:

No package 'glib-2.0' found Consider adjusting the PKG_CONFIG_PATH environment variable if you installed software in a non-standard prefix. Alternatively, you may set the environment variables GLIB_CFLAGS and GLIB_LIBS to avoid the need to call pkg-config. See the pkg-config man page for more details.

Altre volte, invece mi diceva che non riusciva a compilare i plugin di beryl...cosa può essere?
Qualcuno può darmi un link per scaricare beryl svn che nn sia quello nella guida?
Ciao Wink

Ritratto di BrianM
BrianM
(Junior)
Offline
Junior
Iscritto: 28/01/2007
Messaggi: 20

Ok....l'errore è risolto...L'errore dei plugin invece è sempre quello:
Quote:

make[2]: *** [libcrashhandler.la] Error 1
make[2]: Leaving directory `/home/marke89/Desktop/Beryl/beryl-plugins/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/marke89/Desktop/Beryl/beryl-plugins'
make: *** [all] Error 2
BUILD FAILED for beryl-plugins

Ciao

Ritratto di Rents
Rents
(Geek)
Offline
Geek
Iscritto: 01/12/2006
Messaggi: 100

ma ke hanno sti svn in +?
io ho gli rpm e vanno una favola, senza contare il fatto ke si aggiornano facilmente...
niubbo sempre rpm, secondo me. e cmq qnd si compila a mano sarebbe meglio creare l'rpm(tipo con checkinstall), per così poi ritrovarselo nel package manager in caso di disinstallazione

:idea:
OS 11.1
hp pavillion dv5000
centrino duo 1.6
nvidia 7400 Go

Ritratto di BrianM
BrianM
(Junior)
Offline
Junior
Iscritto: 28/01/2007
Messaggi: 20

Beh, se è così... puoi darmi il nome dei pacchetti...e soprattutto la locazione...
O li installi con un repository?
Ciao

Ritratto di BrianM
BrianM
(Junior)
Offline
Junior
Iscritto: 28/01/2007
Messaggi: 20

Ok....ora ho inserito il repository e i pacchetti li ho installati tutti...
Beryl si avvia e sembra tutto ok...le finestre ci sono.
Ma gli effetti non si vedono...a parte quando si manda in tray le finestre...diciamo che l'effetto è simile a quello di compiz...
Ad esempio su beryl manager l'effetto del cubo è abilitato ma non funziona nulla...E le decorazioni finestra nn cambiano...Ah...xmoto mi va a scatti...ma io nn ho attivato xgl...nn dovrebbe dare questi problemi...Qualcuno mi può dare una mano?
Vi posto il mio xorg.conf, ma dovrebbe essere tutto ok...
Ciao

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder26) Fri Dec 15 10:40:27 PST 2006

# /.../
# SaX generated X11 config file
# Created on: 2007-01-30T23:51:09+0100.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "ServerLayout"
Identifier "Layout[all]"
Screen "Screen[0]" 0 0
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Option "AIGLX" "true"
EndSection

Section "Files"
InputDevices "/dev/gpmdata"
InputDevices "/dev/input/mice"
FontPath "/usr/share/fonts/misc:unscaled"
FontPath "/usr/share/fonts/local"
FontPath "/usr/share/fonts/75dpi:unscaled"
FontPath "/usr/share/fonts/100dpi:unscaled"
FontPath "/usr/share/fonts/Type1"
FontPath "/usr/share/fonts/URW"
FontPath "/usr/share/fonts/Speedo"
FontPath "/usr/share/fonts/PEX"
FontPath "/usr/share/fonts/cyrillic"
FontPath "/usr/share/fonts/latin2/misc:unscaled"
FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
FontPath "/usr/share/fonts/latin2/Type1"
FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
FontPath "/usr/share/fonts/baekmuk:unscaled"
FontPath "/usr/share/fonts/japanese:unscaled"
FontPath "/usr/share/fonts/kwintv"
FontPath "/usr/share/fonts/truetype"
FontPath "/usr/share/fonts/uni:unscaled"
FontPath "/usr/share/fonts/CID"
FontPath "/usr/share/fonts/ucs/misc:unscaled"
FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/misc:unscaled"
FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/Type1"
FontPath "/usr/share/fonts/misc/sgi:unscaled"
FontPath "/usr/share/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "type1"
Load "freetype"
Load "extmod"
Load "glx"
Load "v4l"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "on"
EndSection

Section "InputDevice"
Identifier "Keyboard[0]"
Driver "kbd"
Option "Protocol" "Standard"
Option "XkbLayout" "it"
Option "XkbModel" "pc102"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Identifier "Mouse[1]"
Driver "mouse"
Option "Buttons" "5"
Option "Device" "/dev/input/mice"
Option "Name" "Logitech N48/M-BB48 [FirstMouse Plus]"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "Modes"
Identifier "Modes[0]"
EndSection

Section "Monitor"
Identifier "Monitor[0]"
VendorName "ACR"
ModelName "ACER AL1716"
UseModes "Modes[0]"
DisplaySize 338 270
HorizSync 30.0 - 81.0
VertRefresh 50.0 - 75.0
Option "CalcAlgorithm" "XServerPool"
Option "DPMS"
EndSection

Section "Device"
Identifier "Device[0]"
Driver "nvidia"
VendorName "NVidia"
BoardName "GeForce 6200SE TurboCache(TM)"
Option "XAANoOffscreenPixmaps" "true"
Option "DRI" "true"
Option "RenderAccel" "true"
Option "AllowGLXWithComposite" "true"
Option "XAANoOffscreenPixmaps" "true"
Option "AddARGBGLXVisuals" "true"
EndSection

Section "Screen"
Identifier "Screen[0]"
Device "Device[0]"
Monitor "Monitor[0]"
DefaultDepth 24
Option "usevnc" "no"
Option "AllowGLXWithComposite" "True"
Option "RenderAccel" "True"
Option "AddARGBGLXVisuals" "True"
SubSection "Display"
Depth 15
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

Ritratto di Rents
Rents
(Geek)
Offline
Geek
Iscritto: 01/12/2006
Messaggi: 100

ma hai dato da console il comando:
beryl-manager

credo di si da quello ke dici, cmq hai attivato beryl? (click destro sul rubino, o berillio?!?) e un window manager diverso da kwin? (io uso emerald ke va da paura, aquamarine mi si impalla)

ah, un'altra cosa.. tu avevi iniziato a compilare, anzi beryl era finito, no? credo ke dovresti rimuoverlo, potrebbe essere andato in conflitto se hai fatto tutto il resto.

:idea:
OS 11.1
hp pavillion dv5000
centrino duo 1.6
nvidia 7400 Go

Ritratto di BrianM
BrianM
(Junior)
Offline
Junior
Iscritto: 28/01/2007
Messaggi: 20

Allora....io ho cancellato da root la cartella dove c'era beryl svn....anche se la compilazione nn è andata a buon fine qualcosa penso rimanga...Come lo rimuovo...
Cmq il comando beryl-manager l'ho dato e beryl si avvi, cambiano finestre (come quelle su gnome).....ma devo avviare emerald in qualche modo? E poi, come cambio winndows manager?
Ciao...
PS:per xmoto? cambio qualcosa in xorg? Anche se nn avvio beryl mi va a scatti....Quindi sarà colpa di qualche modifica al file...
Grazie Wink

Ritratto di BrianM
BrianM
(Junior)
Offline
Junior
Iscritto: 28/01/2007
Messaggi: 20

Allora...il gestore finestre di beryl va in crash....e mia vvia quello di gnome o di kde...Quindi è il problema è anche li...Non mi avvia i gestori delle finestre di beryl e anche gli effetti vari come il cubo....Dato che nn ho intenzione di usarlo con xgl come posso fare?
Ciao grazie Wink

Ritratto di Rents
Rents
(Geek)
Offline
Geek
Iscritto: 01/12/2006
Messaggi: 100

su opzioni di render (mi sembra fosse così) spunta

forza AIXGL

e usa il gnome-window-manager come prova (a me erastabile) o meglio installati emerald e usa quello.
in caso di crash usa kwin (se sei in kde...).
se nn riesci kiedi e proverò ad essere + specifico (nn ho il pc sottomano)

:idea:
OS 11.1
hp pavillion dv5000
centrino duo 1.6
nvidia 7400 Go

Ritratto di BrianM
BrianM
(Junior)
Offline
Junior
Iscritto: 28/01/2007
Messaggi: 20

Ora provo....ma emerald è installato....l'ho installato da repository come tutti gli altri pacchetti necessari secondo la guida su opensuse.org...
Il problema è che nn so come usare emerald....Ciao

Ritratto di BrianM
BrianM
(Junior)
Offline
Junior
Iscritto: 28/01/2007
Messaggi: 20

L'ho forzato ad usare AIGLX ma niente....non riesco ad abilitare nessuna sorta d'effetto...Ciao