Come modificare la risoluzione del GRUB x cambiare la bootsplash

4 risposte [Ultimo messaggio]
Ritratto di tucano
tucano
(Junior)
Offline
Junior
Iscritto: 22/03/2007
Messaggi: 17

Scusate i molti messaggi che scrivo, ma sono relativamente nuovo di linux e molte cose ancora non le conosco..ho cercato già ma non ho trovato nulla di sicuro a riguardo...

Come posso fare ad impostare una risoluzione maggiore per il grub della 10.2 in fase di avvio? (x intendersi quando mi visualizza la bootsplash, xk ora è configurato su 800 x 600 e non mi carica nessuna bootsplash oltre a quella di base...) . Ho uno schermo 1280 x 800 riconosciuto come CPT monitor (è il monitor di un asus 14" widescreen).

Il sistema operativo una volta avviato ha risoluzione 1280 x 800, ma il grub no.. Sad

______________________________________

Ottimista affoga in vasca da bagno mezza piena

Ritratto di spock
spock
(Guru)
Offline
Guru
Iscritto: 03/08/2006
Messaggi: 1225

http://www.suseitalia.org/modules/newbb/viewtopic.php?topic_id=7243&forum=1&post_id=36680#forumpost36680

Ritratto di tucano
tucano
(Junior)
Offline
Junior
Iscritto: 22/03/2007
Messaggi: 17

Nella tabella del link che mi hai postato però non c'èrisoluzione x widescreen, ma si ferma al 1024 x 768..

comunque ho provato con il vga=791

ma quanto faccio il comando mkinitrd -s 1024 x 768 mi da il seguente errore:

mkinitrd -s 1024 x 768
/sbin/mkinitrd: line 3036: x/etc/fstab: No such file or directory
No '/' mountpoint specified in x/etc/fstab
tucanux:/home/tucano # ICE default IO error handler doing an exit(), pid = 5779, errno = 0

______________________________________

Ottimista affoga in vasca da bagno mezza piena

Ritratto di pernix
pernix
(Guru)
Offline
Guru
Iscritto: 07/07/2006
Messaggi: 995

Quote:

tucano ha scritto:
Nella tabella del link che mi hai postato però non c'èrisoluzione x widescreen, ma si ferma al 1024 x 768..

comunque ho provato con il vga=791

ma quanto faccio il comando mkinitrd -s 1024 x 768 mi da il seguente errore:

mkinitrd -s 1024 x 768
/sbin/mkinitrd: line 3036: x/etc/fstab: No such file or directory
No '/' mountpoint specified in x/etc/fstab
tucanux:/home/tucano # ICE default IO error handler doing an exit(), pid = 5779, errno = 0

Il comando deve essere mkinitrd -s 1024x768 e non mkinitrd -s 1024 x 768: senza spazi nella risoluzione.

Bye

In a world without walls and fences, who needs Windows ad Gates?

openSUSE 10.3 - KDE+Compiz
Dell Latitude D820N: Intel T7200 2GHz; 2GB RAM 667MHz; Nvidia Quadro NVS 120M 512MB

Ritratto di tucano
tucano
(Junior)
Offline
Junior
Iscritto: 22/03/2007
Messaggi: 17

Ok ho provato con il comando senza gli spazi nella risoluzione, ed è andato tutto a buon fine, però nel terminale mi dice alla fine che per 1024 x 768 il bootsplash è disattivato, però se vado nel file che si trova in etc/sysconfig/ mi dice che è attivato invece il bootsplash

## Path: System/Boot
## Description: enables/disables bootup graphics
## Type: yesno
## Default: yes
#
# SPLASH can be set to "no" to turn off the splash-screen on console 1
# at boot time (after kernel load).
#
# SPLASH=no to disable the splash screen
#
# SPLASH=yes to show the splash screen
#
SPLASH="yes"
## Path: System/Boot
## Description: selects bootsplash graphics theme
## Type: string
## Default: SuSE
# Choose the bootsplash theme. It should be based in
# /etc/bootsplash/themes/
THEME="Lizard"

Questo è il mio #/etc/sysconfig/bootsplash .

Invece nel menu.lst che si trova in /boot/grub/ ho questo

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 10.2
root (hd0,5)
kernel /boot/vmlinuz-2.6.18.2-34-default root=/dev/hda6 vga=0x314 resume=/dev/hda5 splash=silent showopts
initrd /boot/initrd-2.6.18.2-34-default
vga=791

che devo fare?

______________________________________

Ottimista affoga in vasca da bagno mezza piena