compiz-fusion soluzione a No GLXFBConfig for default depth e GLX_EXT_texture_from_pixmap is missing

Nessuna risposta
Ritratto di anubis
anubis
(Guru)
Offline
Guru
Iscritto: 07/04/2007
Messaggi: 3656

se voi ottenete uno di questi due errori

GLX_EXT_texture_from_pixmap is missing

oppure

No GLXFBConfig for default depth, this isn't going to work

la soluzione è lanciare compiz con questo comando:

LIBGL_ALWAYS_INDIRECT=1 compiz --no-libgl-fallback --replace ccp &

dovrebbe funzionare sia su nvidia che su ati!

se volete lanciare la fusion icon aprite da root, con un editor di testo il file:

/usr/lib/python2.5/site-packages/FusionIcon/data.py

cercate il rigo

compiz_args = ['--replace', '--sm-disable', '--ignore-desktop-hints', 'ccp']

e aggiungeteci --no-libgl-fallback

diventerà quindi così:

compiz_args = ['--replace', '--sm-disable', '--ignore-desktop-hints', 'ccp', '--no-libgl-fallback']

ora lanciate la fusion-icon con questo comando:

LIBGL_ALWAYS_INDIRECT=1 fusion-icon

OpenSUSE Member,Packman Packager, Education Project Admin, LXDE Project Admin
Powered by http://en.opensuse.org/HP_Pavilion_dv6855el