Configuriamo al meglio i repository di openSUSE 11.4

8 risposte [Ultimo messaggio]
Ritratto di ronin
ronin
(Junior)
Offline
Junior
Iscritto: 26/05/2010
Messaggi: 20

Da YaST è possibile abilitare molti repository aggiuntivi che permettono di migliorare notevolmente la qualità della distribuzione.
Che ne dite di postare qui tutti i consigli per chi, come il sottoscritto, non ha molta dimestichezza con queste cose?

Inizio con l'elencare i repo da abilitare assolutamente:

Packman Repository
libdvdcss repository
nVidia Graphics Drivers (solo per chi ha schede video nVidia)
ATI/AMD Graphics Drivers (solo per chi ha schede video ATI/AMD)
Stable LibreOffice Repository
openSUSE BuildService - Mozilla

Altri?

Quali repo abilitare per aggiornare al volo (con sicurezza) KDE o Gnome?

Ci sono accorgimenti particolari da usare in YaST? Ad es:
Quale priorità usare per i vari repo?
Gestione Pacchetti permette di passare le versioni di sistema a quelle presenti in un particolare repository. Per quali è consigliabile farlo?

Grazie per l'aiuto... magari con le informazioni che raccogliamo qui riusciamo anche a farci una guida.

Ritratto di Andrea85
Andrea85
(Collaboratore)
Offline
Collaboratore
Iscritto: 22/12/2008
Messaggi: 801

Per l'elenco dei repository http://www.suseitalia.org/forum/varie/repository-proviamo-fare-chiarezza-una-volta-tutte
La priorità non serve cambiarla
Passare alle versioni di un repository particolare è utile se vuoi aggiornare tutti i programmi installati che sono contenuti in quel repository.

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2741

Andrea85 ha scritto:

Per l'elenco dei repository http://www.suseitalia.org/forum/varie/repository-proviamo-fare-chiarezza-una-volta-tutte
La priorità non serve cambiarla
Passare alle versioni di un repository particolare è utile se vuoi aggiornare tutti i programmi installati che sono contenuti in quel repository.


@Andrea85
Non avevo visto la "guida" dovrebbe stare sempre in risalto,bravo
ciao

SUSE Tumbleweed- kernel-5.8.7.1.2- kde-plasma-5.19.5.1- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.132.14- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di ILSECCO
ILSECCO
(Geek)
Offline
Geek
Iscritto: 22/01/2010
Messaggi: 76

...ops...

Sistema: openSUSE 12.1 (i586) KDE: 4.7.2 (4.7.2) "release 5" nVidia Corporation GeForce 6200 Driver 2D: nvidia Driver 3D: NVIDIA 275.21 Processore (CPU): AMD Sempron(tm) Processor 3000+ Velocità: 1.599,75 MHz Memoria totale (RAM): 983,5 MiB Memoria disponibile: 14,7 MiB (+ cache 274,1 MiB ) Swap disponibile: 2,0 GiB

Ritratto di ILSECCO
ILSECCO
(Geek)
Offline
Geek
Iscritto: 22/01/2010
Messaggi: 76

Yast non mi aggiunge i repo... Sad
Ho letto la guida sopra e provato con:
-packman
-nvidia (problemi non dovuti da suse)
ma niente da fare;
ho i sette repo di base considerata la recentissima installazione...
In attesa di consigli
Ciao

Sistema: openSUSE 12.1 (i586) KDE: 4.7.2 (4.7.2) "release 5" nVidia Corporation GeForce 6200 Driver 2D: nvidia Driver 3D: NVIDIA 275.21 Processore (CPU): AMD Sempron(tm) Processor 3000+ Velocità: 1.599,75 MHz Memoria totale (RAM): 983,5 MiB Memoria disponibile: 14,7 MiB (+ cache 274,1 MiB ) Swap disponibile: 2,0 GiB

Ritratto di Andrea85
Andrea85
(Collaboratore)
Offline
Collaboratore
Iscritto: 22/12/2008
Messaggi: 801

In che senso non li aggiunge? Qual è il problema?

Ritratto di ILSECCO
ILSECCO
(Geek)
Offline
Geek
Iscritto: 22/01/2010
Messaggi: 76

Vado su Repository dei programmi--> repository della comunità --> seleziono i due repo sopra citati (uno per volta) --> Ok
Sulla lista Repository configurati non appare il nuovo repo aggiunto...ricordo che il repo veniva aggiunto subito e non c'era neanche bisogno di riavviare...ma...

Sistema: openSUSE 12.1 (i586) KDE: 4.7.2 (4.7.2) "release 5" nVidia Corporation GeForce 6200 Driver 2D: nvidia Driver 3D: NVIDIA 275.21 Processore (CPU): AMD Sempron(tm) Processor 3000+ Velocità: 1.599,75 MHz Memoria totale (RAM): 983,5 MiB Memoria disponibile: 14,7 MiB (+ cache 274,1 MiB ) Swap disponibile: 2,0 GiB

Ritratto di aksaf
aksaf
(Guru)
Offline
Guru
Iscritto: 08/03/2011
Messaggi: 957

ILSECCO ha scritto:

Vado su Repository dei programmi--> repository della comunità --> seleziono i due repo sopra citati (uno per volta) --> Ok
Sulla lista Repository configurati non appare il nuovo repo aggiunto...ricordo che il repo veniva aggiunto subito e non c'era neanche bisogno di riavviare...ma...

Che sia un problema legato all'aggiornamento?
In ogni caso potresti provare ad aggiungerli manualmente con zypper:
http://it.opensuse.org/SDB:NVIDIA_driver#Installazione_tramite_repository_con_zypper
http://it.opensuse.org/Repository_Aggiuntivi_Per_YaST#Packman

Ciao e scusatemi tutti per l'OT

Ritratto di ILSECCO
ILSECCO
(Geek)
Offline
Geek
Iscritto: 22/01/2010
Messaggi: 76

Ho aggiunto nvidia, packman-essentials e packman-multimedia; adesso nella lista Repository configurati ci sono tutti e tre
Grazie Wink
Ciao

Sistema: openSUSE 12.1 (i586) KDE: 4.7.2 (4.7.2) "release 5" nVidia Corporation GeForce 6200 Driver 2D: nvidia Driver 3D: NVIDIA 275.21 Processore (CPU): AMD Sempron(tm) Processor 3000+ Velocità: 1.599,75 MHz Memoria totale (RAM): 983,5 MiB Memoria disponibile: 14,7 MiB (+ cache 274,1 MiB ) Swap disponibile: 2,0 GiB