Digikam 2.2 errore all'avvio

3 risposte [Ultimo messaggio]
Ritratto di attilafdd
attilafdd
(Geek)
Offline
Geek
Iscritto: 19/11/2007
Messaggi: 110

Ho installato digikam 2.2.0
All'avvio presenta il seguente errore e dopo il logo di digikam termina.

attilafdd@linux-paji:~> digikam
 
QSqlDatabasePrivate::removeDatabase: connection 'ConnectionTest' is still in use, all queries will cease to work.
digikam: symbol lookup error: digikam: undefined symbol: _ZN11KExiv2Iface14AltLangStrEdit15setLinesVisibleEj
 
attilafdd@linux-paji:~> 

ho provato a googlare... pare sia stato riscontrato da diversi utenti (anche con versioni diverse di Suse e anche su Ubuntu)... ma non trovo soluzione.

Qualcuno ha idee?

Suse 11.4 KDE 4.7

OpenSuse Leap 42.3

Ritratto di attilafdd
attilafdd
(Geek)
Offline
Geek
Iscritto: 19/11/2007
Messaggi: 110

Risolto il primo problema installando:

libkexiv2-10-4.7.2-3.1.i586.rpm

dal repo http://download.opensuse.org/repositories/KDE:/Release:/47/openSUSE_11.4

ora ne esce un secondo:

attilafdd@linux-paji:~> digikam
 
QSqlDatabasePrivate::removeDatabase: connection 'ConnectionTest' is still in use, all queries will cease to work.
No location could be retrieved for url KUrl("file://") 
digikam(9723)/digikam (core) Digikam::ThumbnailCreator::load: Thumbnail is null for  "" 
digikam: symbol lookup error: digikam: undefined symbol: _ZN4KIPI21ImageCollectionSharedD2Ev

OpenSuse Leap 42.3

Ritratto di Raff82
Raff82
(Geek)
Offline
Geek
Iscritto: 30/03/2011
Messaggi: 151

L'errore "symbol lookup error" indica librerie incompatibili o mancanti.
Strano, perché l'installazione di Digikam dai repo ufficiali comporta anche l'installazione di tutte le necessarie dipendenze.

Ritratto di aksaf
aksaf
(Guru)
Offline
Guru
Iscritto: 08/03/2011
Messaggi: 957

Raff82 ha scritto:

L'errore "symbol lookup error" indica librerie incompatibili o mancanti.
Strano, perché l'installazione di Digikam dai repo ufficiali comporta anche l'installazione di tutte le necessarie dipendenze.


Verissimo, ma in quel caso penso che digikam dovrebbe essere alla versione 2.1.0 (che funziona bene, eccetto qualche warning). La 2.2.0 dovrebbe arrivare da KDE Updated o Factory, solo che, dato che uso la versione di KDE in firma, non so quale libreria possa dare problemi, nel caso segnalato...