Dolphin-emu ( emulatore wii & GameCube )

7 risposte [Ultimo messaggio]
Ritratto di Suse98
Suse98
(Guru)
Offline
Guru
Iscritto: 03/10/2010
Messaggi: 1711

Salve.
Volendo un emulatore per wii/GameCube , ho visto se girava con wine :
http://appdb.winehq.org/objectManager.php?sClass=application&iId=8021 , poi sono andato sul sito : http://code.google.com/p/dolphin-emu/ e poi ho visto che c'è per linux , ma solo su Ubuntu/Debian , ho visto come installarlo : http://code.google.com/p/dolphin-emu/wiki/Linux_Build , ma poi ho visto :

Citazione:


sudo apt-get install cmake git g++ wx2.8-headers libwxbase2.8-dev libwxgtk2.8-dev libgtk2.0-dev libsdl1.2-dev nvidia-cg-toolkit libxrandr-dev libxext-dev libglew1.5-dev libao-dev libasound2-dev libpulse-dev libbluetooth-dev libreadline5-dev libavcodec-dev libavformat-dev libswscale-dev


E vabbè , io risolvo con zypper , ma a me , Nvidia , non mi serve , ho una Ati :
Citazione:


... nvidia-cg-toolkit ...


Quindi , mi sono chiesto se mi potevate aiutare ad installarlo per linux , altrimenti lo uso con wine.
Ma ( riflettendo ) con wine , le potenzialità sono ridotte , quindi io vorrei installarlo con linux.
Ciao e grazie per il vostro grandissimo aiuto.

SUSE LINUX Rilascio 12.3 (Dartmounth) KDE 4.10 && GNOME 3.8

Ritratto di Gollum
Gollum
(Collaboratore)
Offline
Collaboratore
Iscritto: 03/03/2005
Messaggi: 802

Potresti provare così:

# zypper in -no--recommends nome_pacchetto

Ricontrolla poi le dipendenze, ma se è stato compilato con il supporto per le schede Nvidia credo ci sia ben poco da fare.

Desktop DELL XPS8100 => openSUSE_12.2 => KDE 4.10 => Core i7 => 3.4.28-2.20 => Nvidia GT220
Notebook Sony Vaio VPPCA =>openSUSE_12.2 => KDE 4.10 => Core i5 => 3.4.28-2.20 => AMD HD 6470M

Ritratto di aksaf
aksaf
(Guru)
Offline
Guru
Iscritto: 08/03/2011
Messaggi: 957

Hai provato i pacchetti dall'Open build service https://build.opensuse.org/search/search?search_text=dolphin-emu&commit=Search&project=1&package=1&name=1&attribute=&advanced=on ? Plain Face

Ritratto di Suse99
Suse99
(Monster)
Offline
Monster
Iscritto: 15/07/2011
Messaggi: 280

a me non me lo istalla forse perche è per opensuse 11.3,io ho la 11.4
Ho eseguito tutte le "etichette" che mi indicava,ho anche istallato il paccetto,ma l'isallazione fallisce

Suse99, Opensuse 13.1 gnome 64bit,Processore: Intel Core i5, Scheda grafica: NVIDIA gtx 760

Ritratto di Suse98
Suse98
(Guru)
Offline
Guru
Iscritto: 03/10/2010
Messaggi: 1711

aksaf ha scritto:

Hai provato i pacchetti dall'Open build service https://build.opensuse.org/search/search?search_text=dolphin-emu&commit=Search&project=1&package=1&name=1&attribute=&advanced=on ? Plain Face


Ecco cosa mi dice :
niente fornisce libSOIL.so.1()(64bit) necessario a dolphin-emu-2.0.rev7419-72.1.x86_64 , non sò dove si trova il pacchetto , devo installare il repo ?

Gollum ha scritto:

Potresti provare così:

# zypper in -no--recommends nome_pacchetto

Ricontrolla poi le dipendenze, ma se è stato compilato con il supporto per le schede Nvidia credo ci sia ben poco da fare.


L'avevo immaginato , ma forse faccio prima a prenderlo da qui : http://ftp5.gwdg.de/pub/opensuse/repositories/home:/canislycan:/games/openSUSE_11.4/x86_64/dolphin-emu-2.0.rev7419-72.1.x86_64.rpm
Ciao e grazie

SUSE LINUX Rilascio 12.3 (Dartmounth) KDE 4.10 && GNOME 3.8

Ritratto di Suse98
Suse98
(Guru)
Offline
Guru
Iscritto: 03/10/2010
Messaggi: 1711

Ho aggiunto il repo : http://download.opensuse.org/repositories/home:/canislycan:/games/openSUSE_11.4/ e poi l'ho installato , da terminale mi dava un'errore delle librerie libwx_gtk2u_aui-2.8.so.0 , le ho installate tutte ( a me mancavano solo due , dopo aver cercato libwx_gtk2u_aui ) , ora vedo se mi carica una rom e siamo a posto.
Grazie

SUSE LINUX Rilascio 12.3 (Dartmounth) KDE 4.10 && GNOME 3.8

Ritratto di Suse98
Suse98
(Guru)
Offline
Guru
Iscritto: 03/10/2010
Messaggi: 1711

Carico la iso e si bugga , come pcsx e pcsx2.
Grazie per l'aiuto comunque

--edit--
Ecco :

Nell'allegato è presente il txt che mi restituisce , la segnalazione di bug

AllegatoDimensione
dolphin-emu-segnalazione-bug.txt 10.95 KB

SUSE LINUX Rilascio 12.3 (Dartmounth) KDE 4.10 && GNOME 3.8

Ritratto di Suse99
Suse99
(Monster)
Offline
Monster
Iscritto: 15/07/2011
Messaggi: 280

l'ho istallato ma non e lo apre,come mai?

Suse99, Opensuse 13.1 gnome 64bit,Processore: Intel Core i5, Scheda grafica: NVIDIA gtx 760