Domanda Zypper - openSUSE 11.4

2 risposte [Ultimo messaggio]
Ritratto di Depa Marco
Depa Marco
(Geek)
Offline
Geek
Iscritto: 02/10/2010
Messaggi: 178

ciao a tutti...
Per aggiornare i pacchetti, lancio sempre da terminale il comando:
# zypper up
e funziona alla grande!!
ma mi compare sempre:

[...]
I seguenti pacchetti di aggiornamento NON saranno installati:
  audacity bluedevil crda gstreamer-0_10 gstreamer-0_10-plugin-gnomevfs gstreamer-0_10-plugin-hal gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-base 
  gstreamer-0_10-plugins-good gstreamer-0_10-plugins-good-lang iw k3b kaffeine libbluedevil1 libgstapp-0_10-0 libgstinterfaces-0_10-0 libgstreamer-0_10-0 libgtkglext-x11-1_0-0 
  libsensors4 libtag-extras1 libwavpack1 libxine1 libxine1-gnome-vfs libxine1-pulse linphone make mjpegtools perl-JSON-XS smartmontools taglib wireless-regdb 
[...]

cosa me lo dice a fare??? qualcosa non va??? vorrei capire Smile

Grazie 1000

Ritratto di Suse98
Suse98
(Guru)
Offline
Guru
Iscritto: 03/10/2010
Messaggi: 1657

Depa Marco ha scritto:

ciao a tutti...
Per aggiornare i pacchetti, lancio sempre da terminale il comando:
# zypper up
e funziona alla grande!!
ma mi compare sempre:

[...]
I seguenti pacchetti di aggiornamento NON saranno installati:
  audacity bluedevil crda gstreamer-0_10 gstreamer-0_10-plugin-gnomevfs gstreamer-0_10-plugin-hal gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-base 
  gstreamer-0_10-plugins-good gstreamer-0_10-plugins-good-lang iw k3b kaffeine libbluedevil1 libgstapp-0_10-0 libgstinterfaces-0_10-0 libgstreamer-0_10-0 libgtkglext-x11-1_0-0 
  libsensors4 libtag-extras1 libwavpack1 libxine1 libxine1-gnome-vfs libxine1-pulse linphone make mjpegtools perl-JSON-XS smartmontools taglib wireless-regdb 
[...]

cosa me lo dice a fare??? qualcosa non va??? vorrei capire Smile

Grazie 1000

Te lo dice perchè :

Depa Marco ha scritto:


I seguenti pacchetti di aggiornamento NON saranno installati


NON installa quei pacchetti di aggiornamento.
Ad esempio , hai installato audacity versione 1.0 , è uscita la 1.0.1 , e lui dice che NON te lo installa.

Il perchè non lo so.
Ciao

--edit--

http://distrowatch.com/dwres.php?resource=package-management ha scritto:


Update existing software = zypper update -t package pkg


pgk è il pacchetto , prova quello Wink

Ciao

HP - Gaming OMEN 15-ek0015nl Notebook
Intel Core i7-10750, Nvidia GeForce RTX 2060 6GB, 32GB RAM, 500GB SSD M2 + 2TB Sabrend SSD M2

Ritratto di wal7er
wal7er
(Guru)
Offline
Guru
Iscritto: 21/09/2007
Messaggi: 572

I Pacchetti non vengono aggiornati automaticamente perchè la versione più recente si trova in un altro repository: questo cambio potrebbe "scassare" altre cose e quindi devi vedere tu se cmbiare il repository relativo o lasciarlo così com'è.
Esempio pratico: firefox si trova nei repo ufficiali e in quello di mozilla (se lo hai attivato); in alcuni casi la versione più recente si trova nel repo mozilla ma nel sistema è installato quello del repo "ufficiale"; in questa situazione viene stampato il messaggio che, pur essendoci una versione piu nuova, non viene aggiornato a causa del cambio del repository.
Per sbrogliare la matassa basta andare nel gestore dei pacchetti e selezionare esplicitamente l'ultima versione (con cambio di repo).

HP Pavilion dv5-1110el powered by OpenSUSE 13.2 64bit

http://linuxcounter.net/cert/432576.png