ERRORE SCARICAMENTO REPOSITORY VLC

11 risposte [Ultimo messaggio]
Ritratto di freddyshow
freddyshow
(Junior)
Offline
Junior
Iscritto: 22/10/2012
Messaggi: 20

Quando avvio il gestore dei pacchetti in automatico, ogni volta, tenta di scaricarmi un pacchetto mancante:

"Si è verificato un errore durante l'inizializzazione dei repository.
Errore durante l'aggiornamento del servizio download.videolan.org/ (http://pub/videolan/vlc/SuSE/12.2):

Errore di scaricamento (curl) per 'http://pub/videolan/vlc/SuSE/12.2/repo/repoindex.xml?cookies=0':
Codice di errore: Connection failed
Messaggio di errore: Could not resolve host: pub; Nome o servizio sconosciuto"

Come faccio a levarmi questo errore di torno? Tanto è stronzo che non mi permette di scaricarne altri dal terminale se non levo prima questo dalle scatole... Grazie a tutti in aticipo!

Freddyshow

Ritratto di Templare
Templare
(Collaboratore)
Offline
Collaboratore
Iscritto: 28/10/2011
Messaggi: 747

Apri Yast------>repository e da lì fai tutto

Assemblato 1: Phenom II X4 965 Black Edition + AMD Radeon HD 5770 + Scheda Madre Asus Crosshair IV Formula + Scheda Audio Asus Xonar D2X. Sistema Windows 7 Ultimate 64 Bit
Assemblato 3: Intel Core i3 3220 + nVIDIA Geforce 640 GT. Sistema openSUSE 13.1 64 bit GNOME

Ritratto di freddyshow
freddyshow
(Junior)
Offline
Junior
Iscritto: 22/10/2012
Messaggi: 20

Templare... il punto è proprio che non so cosa fare in Yast per eliminare il problema... ho una lista di repository ma per un ignorante come me non fanno alcuna differenza...
Saresti così gentile da specificarmi quello che devo fare? Passo passo insieme per mano?

Freddyshow

Ritratto di Templare
Templare
(Collaboratore)
Offline
Collaboratore
Iscritto: 28/10/2011
Messaggi: 747

Sono sempre gentile, ma in questo momento sono a lavoro e per questo motivo non posso prenderti per mano, ma posso segnalarti questa guida da me segnalata nelle news che non avrai probabilmente nemmeno letto:

http://opensuse-guide.org/repositories.php

Per quanto riguarda software multimediali e codec:

http://opensuse-guide.org/codecs.php

Assemblato 1: Phenom II X4 965 Black Edition + AMD Radeon HD 5770 + Scheda Madre Asus Crosshair IV Formula + Scheda Audio Asus Xonar D2X. Sistema Windows 7 Ultimate 64 Bit
Assemblato 3: Intel Core i3 3220 + nVIDIA Geforce 640 GT. Sistema openSUSE 13.1 64 bit GNOME

Ritratto di freddyshow
freddyshow
(Junior)
Offline
Junior
Iscritto: 22/10/2012
Messaggi: 20

Rien a fair. Ho letto la guida che mi hai segnalato ma non riesco a capire quale dei repository contenga l'errore segnalato. Nessun Url della lista corrisponde a quello citato nel messaggio di errore quindi non so come rintracciarlo.. Ho eliminato tutta la lista dei repository in yast.. così, per disperazione, ma nulla è cambiato, all'avio di yast mi riporta sempre lo stesso errore sopra citato... Idee?
Danke

Freddyshow

Ritratto di zioandrea
zioandrea
(Geek)
Offline
Geek
Iscritto: 06/04/2013
Messaggi: 91

Ho avuto un problema simile un mesetto fa. Non ricordo esattamente i dettagli.

Sostanzialmente, il repository VLC è "incompatibile" con Pacman. Quidi devi toglierlo di mezzo.
Se ben ricordo ho dovuto togliere anche il programma vlc (preso dal sito VVLC) e reinstallarlo da Pacman.
Adesso tutto funziona alla perfezione.

Maggiori dettagli li puoi trovare su qualche forum in inglese. Quale? Non ricordo.
Se metti in Google il messaggio d'errore che ricevi, lo trovi.

Scusa se non sono molto chiaro, ma la strada da seguire è questa:
Togliere vlc e il suo repository "proprietario" e reinstallare da Pacman

Andrea

Ritratto di fashion
fashion
(Junior)
Offline
Junior
Iscritto: 04/12/2004
Messaggi: 44

A me risulta che il repo ufficiale di vlc sia: http://download.videolan.org/pub/vlc/SuSE/12.2 prova ad inserirlo a mano come url, disattivando l'altro.

Ritratto di zioandrea
zioandrea
(Geek)
Offline
Geek
Iscritto: 06/04/2013
Messaggi: 91

Hai perfettamente ragione. Però anche i repository Packman di SuSE forniscono VLC,

Se i pacchetti sono "confezionati" in modo diverso, si creano i pasticci in cui io e freddyshow siamo incorsi.
Perché Zypper cerca di scaricare aggiornamenti incompatibili tra loro e/o con il pacchetto installato Sad

Se guardi i messaggi di YAST, vedi che ti mette in guardia dall'aggiungere troppi repository.
Se metti il messaggio d'errore in Google trovi dei forum internazionali che ti dicono di fare quello che ti ho appena detto.
Io non me lo sono inventato. Non sono così bravo Wink

Ripeto che, seguendo le istruzioni, io ho tolto il repository VLC e, per precauzione, reinstallato vlc.
Al successivo riavvio ho cominciato a scaricare tutti gli aggiornamenti senza nessun inconveniente e ora il mio vlc è perfettamente aggiornato.

Ovviamente, conviene tenere Packman, che ti garantisce l'aggiornamento di moltissimi pacchetti (VLC compreso) e
non una pletora di repository, uno per ogni pacchetto.

Andrea

Ritratto di Texnero
Texnero
(Newbie)
Offline
Newbie
Iscritto: 06/05/2013
Messaggi: 2

Ciao,
prova in questa maniera : da terminale

sudo zypper ar http://download.videolan.org/pub/vlc/SuSE/ VLC
sudo zypper mr -r VLC
sudo zypper in vlc

ps.nella prima line sostituisci con 11.1, 11.4, 12.1, 12.2 o 12.3

Il mio setup:cpu Amd 2ghz 64bit - Ram 1gb - hd 160gb - OPENSUSE 12.3 xfce 64bit

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1741

zioandrea ha scritto:

Ho avuto un problema simile un mesetto fa. Non ricordo esattamente i dettagli.

Sostanzialmente, il repository VLC è "incompatibile" con Packman. Quindi devi toglierlo di mezzo.

Io uso ambe due e nessun problema! Il repo VLC contiene SEMPRE i più aggiornati codec rispetto Packman!!!

Il mio per VLC è
http://download.videolan.org/pub/vlc/SuSE/12.1/
Per Packman è
http://packman.inode.at/suse/12.1/

Nota: Uso la versione 12.1 e quindi cambia in corrispondenza.

In Yast elimina quello che punta su:
http://www.pub.com/videolan/vlc/SuSE/12.2
In quanto non più attivo da anni, infatti un sistema è controllare con un browser se punta ad una directory.
Se non lo trovi tra gli URL, provali uno alla volta i link di ogni repo che forse è uno di questi punta su un link dinamico ovvero che reindirizza sul www.pub.com

ATTENZIONE: basta un solo repo che non si collega bene che blocca la lettura dei successivi e quindi non li vedi tutti i repo.

SO: Linux desktop Sistema: OpenSUSE Leap 15.1 (64bit) KDEE 5.12
SO: Linux desktop Sistema: OpenSUSE Tumbleweed (64bit) KDE 5
Miao

Ritratto di zioandrea
zioandrea
(Geek)
Offline
Geek
Iscritto: 06/04/2013
Messaggi: 91

Non so cosa dirvi.
Io avevo lo stesso identico problema di Freddyshow.
Ho preso il messaggio di errore (in inglese) e l'ho messo in Google.
Ho trovato un paio di forum in cui si raccomandava di togliere il repository vlc per incompatibilità.
L'ho fatto e tutto è andato a posto.

Probabilmente, visto che voi riuscite a tenere entrambi i repository, l'incompatibilità è nata da qualche
diversità nel modo con cui voi (da una parte), io e Freddyshow (dall'altra) abbiamo installato inizialmente
il pacchetto e i repository di aggiornamento.
Quale? Difficile capirlo dopo che ho azzerato tutto.

Andrea