Firefox lentissimo

7 risposte [Ultimo messaggio]
Ritratto di cicciolinuks
cicciolinuks
(Geek)
Offline
Geek
Iscritto: 12/06/2010
Messaggi: 198

Salve, avete notato anche voi un rallentamento di Firefox? Da me impiega secoli a partire, dopodiché si impalla, schermate bianche... Ho tolto tutto ciò che avevo in più eccetto AdBlock (che ho disattivato), eppure niente.

Ad un certo punto la spia che indica che si sta scrivendo sul disco rigido inizia a lampeggiare, tutto il computer rallenta. Talvolta spengo la wireless, e dopo 1-2 minuti la smette. Capirei se stessi usando un programmone che non entra in RAM facendo partire la paginazione, ma tutto questo casino per un po' di HTML...

Tempo fa mi era successo lo stesso, allora ho risolto disinstallando e reinstallando Firefox. Potrei disinstallarlo/reinstallarlo anche adesso ma ammesso che funzioni sarebbe solo una soluzione temporanea.

Vabbé che mio computer con OpenSuse è abbastanza datato, però si tratta solo di usare internet per controllare le email, ricerche ecc. Al contrario Opera è una scheggia, soprattutto con l'opzione "turbo" che comprime i pacchetti o qualcosa di simile. Sembrano due computer diversi!

Temendo di avere qualche malaware, ho installato un antivirus, Comodo, che però non trova niente.

Io sono un utente abbastanza legato a Firefox che uso su ogni sistema operativo, vorrei sapere se lo posso recuperare; per ora resto con Opera ma aspetto consigli.

Ritratto di gi-gi
gi-gi
(Moderatore)
Offline
Moderatore
Iscritto: 09/12/2014
Messaggi: 418

Ciao.

Ho avuto un problema simile al tuo con la versione precedente di Firefox. Adesso (attualmente ho la 52.1.1 con openSuse 42.2) va decisamente meglio.

Se non l'hai ancora fatto prova ad aggiornare Firefox.

Un'altra cosa che puoi provare è rinominare la directory .mozilla (directory nascosta) presente nella directory del tuo utente. In questo modo perdi eventuali personalizzazioni di Firefox, ma puoi verificare se il rallentamento è dovuto a qualche anomalia non dovuta al programma in sé.

gigi

Ritratto di cicciolinuks
cicciolinuks
(Geek)
Offline
Geek
Iscritto: 12/06/2010
Messaggi: 198

Tengo sempre il sistema aggiornato ma non ricordo se sono alla 42.2 o 42.1.
Provo stasera a cancellare la cartella, poi comunque aggiornerò alla 42.2 (se non ci sono già).

--- Aggiorno ---
Ho la 42.2, l'ultima credo

Ritratto di CarloCC
CarloCC
(Monster)
Offline
Monster
Iscritto: 06/04/2017
Messaggi: 315

Devi andare in Yast - Impostazione di rete - nome host dns e mettere la spunta a assegna nome host...
vedrai che poi partirà veloce. Questo anche in caso si utilizzi network manager. Ciao
Edit. ho dimenticato il link dove si parla proprio di questo e si da la soluzione
https://www.reddit.com/r/openSUSE/comments/4dqbrv/firefox_opensuse/

Acer Aspire E1-522 Amd Quad-Core E2-3800--Amd Radeon 8280
Acer Aspire M5500 Intel Quad-Core - Amd Radeon R5 230
Distribuzione openSUSE Leap 15 Kde Plasma5 - Tumbleweed

Ritratto di cicciolinuks
cicciolinuks
(Geek)
Offline
Geek
Iscritto: 12/06/2010
Messaggi: 198

CarloCC ha scritto:

Devi andare in Yast - Impostazione di rete - nome host dns e mettere la spunta a assegna nome host...

Ciao, grazie ma già è come dici. C'è la spunta a

"Assegna nome di Host all'IP di loopback"

mentre "Set Hostname via DHCP": no

Ritratto di cicciolinuks
cicciolinuks
(Geek)
Offline
Geek
Iscritto: 12/06/2010
Messaggi: 198

Ho riavviato il computer dopo aver disattivato anche adblock (prima lo avevo disattivato ma avevo riavviato solo Firefox), ora va meglio.
Ho anche seguito la procedura di CarloCC ma come ho scritto era già tutto come doveva essere; per sicurezza ho tolto la spunta e l'ho rimessa. Forse avranno aggiustato qualcosa loro o gli aggiornamenti hanno impostato quelle cose, non saprei. Spero continui ad andare bene, grazie a tutti e due.

Comunque ci sono discussioni simili non solo per Linux, per esempio vedere qua: https://forum.mozillaitalia.org/index.php?topic=68375.0

Ritratto di gi-gi
gi-gi
(Moderatore)
Offline
Moderatore
Iscritto: 09/12/2014
Messaggi: 418

Ciao.

Bene così, però per cortesia metti Risolto al thread.

gigi

Ritratto di cicciolinuks
cicciolinuks
(Geek)
Offline
Geek
Iscritto: 12/06/2010
Messaggi: 198

Fatto (anche se non ho capito come si è risolto).