Frontline, Autotrace

4 risposte [Ultimo messaggio]
Ritratto di SilvioTO
SilvioTO
(Junior)
Offline
Junior
Iscritto: 31/10/2004
Messaggi: 34

Ciao a tutti, mi sono registrato ora sul forum, mi chiamo Silvio e abito vicino a Torino.
Ho una suse 9.1 e ne sono soddisfatto, ho quasi sostituito del tutto windows xp, che purtroppo rimane indispensabile per alcune cose. Ho dei problemi con alcuni programmi, e vorrei iniziare con quello in oggetto.

Ho provato a tracciare un immagine utilizzando Frontline (frontend di Autotrace), ecco cosa ne esce.

nella preview del programma (prima di salvare l'immagine in svg) sembra tutto in ordine:

quando salvo in svg la apro in sodipodi, ecco il risultato:

Qualcuno usa questi programmi e sa dirmi cosa non va? ho provato con varie modalità ma al massimo ottengo che sodipodi crasha nell'aprire l'svg oppure quando importo o apro l'immagine svg rimane bianco il foglio di lavoro.
grazie.

Dual boot O.S. Suse professional 9.1 / Winzoz XPsp2
Intel pentium IV Motherboard: ECS P4S5A
Scheda video: nVidia GeForce4 MX 440
Monitor: Samsung SyncMaster 753s - Sound Blaster Live value
Ram 512 MB - HD Maxtor 80 GB

Ritratto di auris
auris
(Guru)
Offline
Guru
Iscritto: 10/09/2004
Messaggi: 4923

Prova a dare un'occhiata qui:
http://autotrace.sourceforge.net/frontline/
Si fa riferimento alla libreria libfrontline.a per l'utilizzo con sodipodi.
3. Sodipodi, a drawing editor add-on module. add-on module uses the libfrontline.a.

Controlla anche la versione di libart_lgpl installata.

Se sei stanco di virus e schermate blu passa a Linux

Ritratto di SilvioTO
SilvioTO
(Junior)
Offline
Junior
Iscritto: 31/10/2004
Messaggi: 34

libart_lgpl: ho installata la versione 2.3.16, quindi ok
frontline: ho installata la versione 0.5.4, quindi ok
autotrace: ho installata la versione 0.31.1, anche qui ok

sembra tutto a posto, ma non va. chissà se sul tuo pc funziona? hai mai provato?

Dual boot O.S. Suse professional 9.1 / Winzoz XPsp2
Intel pentium IV Motherboard: ECS P4S5A
Scheda video: nVidia GeForce4 MX 440
Monitor: Samsung SyncMaster 753s - Sound Blaster Live value
Ram 512 MB - HD Maxtor 80 GB

Ritratto di auris
auris
(Guru)
Offline
Guru
Iscritto: 10/09/2004
Messaggi: 4923

Se hai installato sodipodi prima di autotrace e frontline, manca il supporto in sodipodi per frontline.
Quindi, installa sodipodi dopo avere installato autotrace e frontline, magari compilando i sorgenti, in modo da verificare il corretto riconoscimento dell'add-on frontline.

Se sei stanco di virus e schermate blu passa a Linux

Ritratto di SilvioTO
SilvioTO
(Junior)
Offline
Junior
Iscritto: 31/10/2004
Messaggi: 34

mi mancavano alcune librerie (in special modo GLib-2.4.7); ho quindi disinstallato l'rpm di sodipodi e l'ho compilato dai sorgenti. ./configure ok; make (non metto tutto il listato):

if gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I.. -I../../src -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include -I/usr/include/libart-2.0 -I/usr/include/libxml2 -I/opt/gnome/include/gtk-2.0 -I/opt/gnome/lib/gtk-2.0/include -I/opt/gnome/include/atk-1.0 -I/opt/gnome/include/pango-1.0 -I/usr/X11R6/include -I/usr/include/freetype2 -I/usr/include/freetype2/config -g -O2 -MT sp-canvas.o -MD -MP -MF ".deps/sp-canvas.Tpo" \
-c -o sp-canvas.o `test -f 'sp-canvas.c' || echo './'`sp-canvas.c; \
then mv -f ".deps/sp-canvas.Tpo" ".deps/sp-canvas.Po"; \
else rm -f ".deps/sp-canvas.Tpo"; exit 1; \
fi
sp-canvas.c: In function `sp_canvas_item_class_init':
sp-canvas.c:125: error: `sp_marshal_BOOLEAN__POINTER' undeclared (first use in this function)
sp-canvas.c:125: error: (Each undeclared identifier is reported only once
sp-canvas.c:125: error: for each function it appears in.)
make[4]: *** [sp-canvas.o] Error 1
make[4]: Leaving directory `/home/silvio/sodipodi-0.34/src/helper'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/home/silvio/sodipodi-0.34/src/helper'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/silvio/sodipodi-0.34/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/silvio/sodipodi-0.34'
make: *** [all] Error 2

non riesco a capire l'errore; non sembra che manchi soltanto qualche libreria e, in tal caso, non so dove reperirla; ho fatto qualche ricerca su google ma non sono venuto a capo di nulla.

Dual boot O.S. Suse professional 9.1 / Winzoz XPsp2
Intel pentium IV Motherboard: ECS P4S5A
Scheda video: nVidia GeForce4 MX 440
Monitor: Samsung SyncMaster 753s - Sound Blaster Live value
Ram 512 MB - HD Maxtor 80 GB