Gimp 2.8

29 risposte [Ultimo messaggio]
Ritratto di metallaro1980
metallaro1980
(Junior)
Offline
Junior
Iscritto: 07/04/2012
Messaggi: 21

ho scaricato i sorgenti di gimp 2.8.0 in una cartella...ho poi aperto la konsole e ho fatto i vari configure etc.
ho però installato le lib che gimp richiede ...glib gtk gegl etc... ma è sorto un problema: i programmi tipo google chrome...mozilla..rawtherapee con l'aggiornamento di queste librerie, smettono di funzionare (specialmente le glib).
allora ho dovuto reinstallare suxe linux...e dopo di che...ho compilato le lib (glib gegl etc) usando: --prefix=/new
bene quando arrivo a compilare gimp (mi trova le gegl le glib) ma non riesco a passare il percorso delle gtk+..
io sono un fotografo e sono passato a linux per la sua stabilità/velocità...
faccio anche video-editing e uso cinelerra.
per i raw della 5d2 uso rawtherapee (lo reputo migliore di adobe camera raw) ma l'ultimo gimp è un portento.
con linux, non ho avuto problemi...guardo benissimo i divx i dvd ..ascolto la musica con qmmp o amarok (tutti programmi da me configurati..plugin)
voi avete una soluzione per installare gimp senza che mi arrechi danni agli altri softwares?

Ritratto di Suse98
Suse98
(Guru)
Offline
Guru
Iscritto: 03/10/2010
Messaggi: 1711

Guarda qui quale ti può interessare: http://software.opensuse.org/package/gimp

SUSE LINUX Rilascio 12.3 (Dartmounth) KDE 4.10 && GNOME 3.8

Ritratto di doc_pluto
doc_pluto
(Guru)
Offline
Guru
Iscritto: 08/02/2007
Messaggi: 871

ma con la gestione pacchetti di yast hai provato?

Hardware: MB:P5E3_Deluxe - CPU:Core2Duo E8400 3.0GHz - RAM:Kingstone_2Gb_DDR3 - Video:GeForce9600GT/PCI/SSE2 - HD: 2x WDCaviarBlue 1TB
--------------------------------
Software: SO:openSuSE 12.1 - ARCH:64bit - DE:Gnome3 - DriverVideo:Ufficiali Nvidia

Ritratto di metallaro1980
metallaro1980
(Junior)
Offline
Junior
Iscritto: 07/04/2012
Messaggi: 21

bhe se trovate gimp (e le varie lib) con i repository...incrociate le dita..
se vi aggiorna le glib e le gtk poi però non vi assicuro che programmi come
google chrome
mozilla
funzionino....ho già provato io a compilare e fare l'update..mi era andata male (non riusciva a trovare un variabile o una funzione in una lib ma la lib esisteva) e quindi ho dovuto reinstallare openSUSE
tra l'altro per compilare le gtk+3..servono un casino di robe...(a livello di devel)
l'unico modo per installare gimp 2.8 è nel compilare le lib (che usa il programma) in modo non condiviso.
servono le gegl-0.2.0...le gtk+-3.2.4 (e qua è un macello) e le glib-2.30.3
usando GEGL_CFLAGS e GEGL_LIBS riesco a passare il link giusto alle lib (in pratica: /new/bin e /new/lib64) la stessa cosa riesco per le GLIB ma non riesco a fargli usare le GTK (nuove) quando faccio ./configure dentro la cartella dei sorgenti di gimp

http://forums.opensuse.org/english/get-technical-help-here/applications/469830-gimp-2-7-4-a.html
Don't even try to change glib, or you will get a broken system.

per quello volevo installare da un'altra parte.

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2727

http://download.opensuse.org/repositories/home:/MargueriteSu:/gimp-2.7/openSUSE_12.1/
è il 2.8
per averlo tutto su un unica finestra,clicchi su Finestre e spunti schermata unica
by

SUSE Tumbleweed- kernel-5.2.14-1-1 kde-plasma-5.16.5- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.116.51- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di metallaro1980
metallaro1980
(Junior)
Offline
Junior
Iscritto: 07/04/2012
Messaggi: 21

alla fine, ce l'ho fatta!
proprio un gran bel programma!complimenti per il lavoro che stanno facendo...per quello che devo farci (di fotografia) mi faccio bastare gimp...

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1691

Per altri:

Gimp 2.6.1 funziona benissimo lo stesso ed è compatibilissimo con tutto. Il 2.8 non è che è quel gran avanzamento salvo usi particolarissimi.

SO: Linux desktop Sistema: OpenSUSE Leap 15.1 (64bit) KDEE 5.12
SO: Linux desktop Sistema: OpenSUSE Tumbleweed (64bit) KDE 5
Miao

Ritratto di aksaf
aksaf
(Guru)
Offline
Guru
Iscritto: 08/03/2011
Messaggi: 957

Se qualcuno è interessato, qui le novità: http://www.gimpusers.com/tutorials/gimp-2-8-features-preview-april-2010

Ritratto di metallaro1980
metallaro1980
(Junior)
Offline
Junior
Iscritto: 07/04/2012
Messaggi: 21

ho scaricato i sorgenti della 2.8 e tutto ok..l'ho compilato...
c'e' un piccolo problema..devo aprire la console e digitare queste righe di codice:
export GTK_PATH=$GTK_PATH:/usr/lib64/gtk-2.0
export GTK2_RC_FILES=$GTK2_RC_FILES:/usr/share/themes/oxygen-gtk/gtk-2.0/gtkrc
poi do gimp-2.8 e tutto ok
se non do quelle due righe di export....mi capita questo messaggino di warning:
(gimp-2.8:14102): Gtk-WARNING **: Unable to locate theme engine in module_path: "oxygen-gtk",

bho!

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2727

Scusa,ma c'è il repository per gimp 2.8,non vale la pena compilarlo imho

SUSE Tumbleweed- kernel-5.2.14-1-1 kde-plasma-5.16.5- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.116.51- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di metallaro1980
metallaro1980
(Junior)
Offline
Junior
Iscritto: 07/04/2012
Messaggi: 21

alla fine ce l'ho fatta
anche perchè ho cambiato due righe di codice...
mo il brush_size quello dove c'e' la fraccia su e giu..non aumenta di 20.00 20.01 20.02 ma aumenta di 20.00 21.00 etc e il default brush l'ho messo a 50.
ho ricompilato make make install..preferisco così