Google-Earth e Zypper dup.

8 risposte [Ultimo messaggio]
Ritratto di burnino
burnino
(Junior)
Offline
Junior
Iscritto: 18/01/2013
Messaggi: 38

E' la seconda volta che ci faccio caso: se dopo una nuova installazione del s.o., e relativa installazione dei software , fra i quali appunto Google-Earth,do' il comando dist upgrade, il software della Google, passa dalla versione 7 alla precedente cioe' la 6.2. In pratica retrocede, e a quanto sembra ad una prima occhiata, e' l'unico programma al quale succede. Ma come e' possibile? Grazie.

Ritratto di Templare
Templare
(Collaboratore)
Offline
Collaboratore
Iscritto: 28/10/2011
Messaggi: 747

Cerco di spiegartela in questa maniera: Il comando zypper dup, al contrario dell'up, prende il software stabile dai repository che tu hai caricato. Al contrario, zypper up ti offre la versione più aggiornata dei repository che hai caricato.

In poche parole: quando devi aggiornare, non dare il comando dup, dai il comando up.

Assemblato 1: Phenom II X4 965 Black Edition + AMD Radeon HD 5770 + Scheda Madre Asus Crosshair IV Formula + Scheda Audio Asus Xonar D2X. Sistema Windows 7 Ultimate 64 Bit
Assemblato 3: Intel Core i3 3220 + nVIDIA Geforce 640 GT. Sistema openSUSE 13.1 64 bit GNOME

Ritratto di burnino
burnino
(Junior)
Offline
Junior
Iscritto: 18/01/2013
Messaggi: 38

grazie Templare. in pratica, se dopo zypper up, ho dato il dup, tutte quelle variazioni che ha fatto , alla pari di google-earth, sono stati dei " ritorni" a piu' vecchie versioni?

Ritratto di Templare
Templare
(Collaboratore)
Offline
Collaboratore
Iscritto: 28/10/2011
Messaggi: 747

Esattamente. Ma per una questione tecnica precisa, non perchè gli gira così

Assemblato 1: Phenom II X4 965 Black Edition + AMD Radeon HD 5770 + Scheda Madre Asus Crosshair IV Formula + Scheda Audio Asus Xonar D2X. Sistema Windows 7 Ultimate 64 Bit
Assemblato 3: Intel Core i3 3220 + nVIDIA Geforce 640 GT. Sistema openSUSE 13.1 64 bit GNOME

Ritratto di burnino
burnino
(Junior)
Offline
Junior
Iscritto: 18/01/2013
Messaggi: 38

ok grazie. finalmente ho le idee più chiare.comunque ti incollo cosa mi risponde ora dando il comando up:
linux-b4nk:~ # zypper up
Loading repository data...
Reading installed packages...

The following package updates will NOT be installed:
gstreamer gstreamer-0_10 gstreamer-0_10-plugin-esd
gstreamer-0_10-plugin-gnomevfs gstreamer-0_10-plugins-bad-lang
gstreamer-0_10-plugins-base gstreamer-0_10-plugins-good gstreamer-0_10-utils
gstreamer-0_10-utils-unversioned gstreamer-plugins-bad gstreamer-plugins-base
gstreamer-plugins-good k3b libgstapp-0_10-0 libgstapp-1_0-0 libgstaudio-1_0-0
libgstbasecamerabinsrc-0_10-23 libgstbasecamerabinsrc-1_0-0
libgstbasevideo-0_10-23 libgstcodecparsers-0_10-23 libgstcodecparsers-1_0-0
libgstfft-1_0-0 libgstinterfaces-0_10-0 libgstpbutils-1_0-0
libgstphotography-0_10-23 libgstphotography-1_0-0 libgstreamer-0_10-0
libgstreamer-1_0-0 libgstriff-1_0-0 libgstrtp-1_0-0 libgstrtsp-1_0-0
libgstsdp-1_0-0 libgstsignalprocessor-0_10-23 libgsttag-1_0-0
libgstvdp-0_10-23 libgstvideo-1_0-0 libmjpegutils-2_0-0 libquicktime0
libquvi-scripts libxine2-pulse python-gstreamer-0_10 typelib-1_0-Gst-0_10
typelib-1_0-Gst-1_0 typelib-1_0-GstAudio-1_0 typelib-1_0-GstInterfaces-0_10
typelib-1_0-GstPbutils-1_0 typelib-1_0-GstTag-1_0 typelib-1_0-GstVideo-1_0

Nothing to do.

cosa vuol dire? se dessi il dup, che gli fa a "questi" sopra?
non glielo do perchè giustamente me li arretra, ma perchè tiene a precisare che non verranno installatI? grazie.

Ritratto di Templare
Templare
(Collaboratore)
Offline
Collaboratore
Iscritto: 28/10/2011
Messaggi: 747

Questa è una cosa che non mi sono mai spiegato e per il quale non ho mai indagato a fondo. Quindi purtroppo non so aiutarti, ma posso dirti che capita anche a me di avere schermate del genere

Assemblato 1: Phenom II X4 965 Black Edition + AMD Radeon HD 5770 + Scheda Madre Asus Crosshair IV Formula + Scheda Audio Asus Xonar D2X. Sistema Windows 7 Ultimate 64 Bit
Assemblato 3: Intel Core i3 3220 + nVIDIA Geforce 640 GT. Sistema openSUSE 13.1 64 bit GNOME

Ritratto di aksaf
aksaf
(Guru)
Offline
Guru
Iscritto: 08/03/2011
Messaggi: 957

da "man zypper":

update (up) [options] [packagename] ...
Update installed packages with newer versions, where possible.
This command will not update packages which would require change of package vendor unless the vendor is specified in /etc/zypp/vendors.d, or which would require manual resolution of problems with dependencies. Such non-installable updates will then be listed in separate section of the summary as "The following package updates will NOT be installed:".

dato che i pacchetti in questione presumo vengano da Packman è allora chiaro che non vengono aggiornati da "zypper up" se prima non si fa il cambio di fornitore con zypper/YaST

Ritratto di burnino
burnino
(Junior)
Offline
Junior
Iscritto: 18/01/2013
Messaggi: 38

allora lascio cosi'. comunque packman me lo impone l'indtallazione via 1 click dei codecs, per cui bisogna che me lo tenga.salvo fare una lettura approfondita di quanto riportato sulla pagina che tratta del cambio del fornitore,che mi sembra un ambito un po ostico, per me. una sola domanda il cambio di fornitore, si puo' fare quante volte si vuole?

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1691

Il cambio fornitore si può fare quante volte si vuole, ma poi non lamentarti se fa dei casini! Laughing

Ma perchè non aggiorni da YAST? Yast2-> aggiornamento programmi. Moltooo più sicuro e semplice! Raised Eyebrow
(Consiglio cancellare l'utilità Apper anche per la versione 12.3 ! Facciamo una petizione alla Suse?)

Controllando da "Yast2-> Installa programmi" puoi poi controllare quali sono i pacchetti "indietro di versione" e quelli "avanti di versione" o "abbandonati", basta vedere nella zona "all" dei package quelli contrassegnati in rosso (indietro o abbandonati o esterni) e blu(proposta una versione superiore spesso con cambio fornitore).
Cowboy
In "Yast2->Repository" poi selezionare che "peso" (dal numero in seconda riga) dare ad ogni repo! Numero inferiore è meno propenso all'aggiornamento da quel fornitore/repo!
Smile

SO: Linux desktop Sistema: OpenSUSE Leap 15.1 (64bit) KDEE 5.12
SO: Linux desktop Sistema: OpenSUSE Tumbleweed (64bit) KDE 5
Miao