Guitar Pro 6

16 risposte [Ultimo messaggio]
Ritratto di Lance
Lance
(Junior)
Offline
Junior
Iscritto: 24/11/2011
Messaggi: 14

Ciao a tutti, questa volta ho problemi con Guitar Pro 6: se clicco sull'icona del programma parte il caricamento (icona che saltella vicino alla freccetta) ma poi sparisce senza che il programma parta realmente.
Ho provato anche da terminale e questo è il log: ./GuitarPro: /opt/GuitarPro6/./libz.so.1: version `ZLIB_1.2.3.3' not found (required by /usr/lib/libxml2.so.2).

Per quanto riguarda l'installazione ho dovuto convertire un file .deb in .rpm con alien dato che non se ne trovano e quindi l'ho installato usando yast (clic destro installa/rimuovi che poi ho provveduto a impostare come predefinito per tutti gli rpm), siccome non funzionava ho provato lo stesso procedimento con un .tgz (di rpm per questo programma non se ne trova Sad) ma il risulatato è sempre lo stesso...

Qualcuno conosce una possibile soluzione?

Grazie in anticipo
Lance

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2752

Lance ha scritto:

Ciao a tutti, questa volta ho problemi con Guitar Pro 6: se clicco sull'icona del programma parte il caricamento (icona che saltella vicino alla freccetta) ma poi sparisce senza che il programma parta realmente.
Ho provato anche da terminale e questo è il log: ./GuitarPro: /opt/GuitarPro6/./libz.so.1: version `ZLIB_1.2.3.3' not found (required by /usr/lib/libxml2.so.2).

Per quanto riguarda l'installazione ho dovuto convertire un file .deb in .rpm con alien dato che non se ne trovano e quindi l'ho installato usando yast (clic destro installa/rimuovi che poi ho provveduto a impostare come predefinito per tutti gli rpm), siccome non funzionava ho provato lo stesso procedimento con un .tgz (di rpm per questo programma non se ne trova Sad) ma il risulatato è sempre lo stesso...

Qualcuno conosce una possibile soluzione?

Grazie in anticipo
Lance


Provato a cercare e installare la libz.so.1: versione 'ZLIB_1.2.3.3.

SUSE Tumbleweed- kernel-5.14.6.1-4- kde-plasma-5.22.5.2 Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.143-SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di Lance
Lance
(Junior)
Offline
Junior
Iscritto: 24/11/2011
Messaggi: 14

Ho la versione 1.2.5 e quindi mi di che ho già la versione più nuova installata...

Ritratto di FabioFender
FabioFender
(Geek)
Offline
Geek
Iscritto: 31/10/2006
Messaggi: 109

Prova a vedere se funziona la versione di windows con wine oppure passa a tuxguitar

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2752

http://rpm.pbone.net/
forse qua la trovi

SUSE Tumbleweed- kernel-5.14.6.1-4- kde-plasma-5.22.5.2 Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.143-SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di Lance
Lance
(Junior)
Offline
Junior
Iscritto: 24/11/2011
Messaggi: 14

FabioFender ha scritto:

Prova a vedere se funziona la versione di windows con wine oppure passa a tuxguitar

Uhm non ho mai provato wine, ma dovrei installare la versione per windows?

@dragoncello: Grazie per il link ora guardo Smile

Ritratto di Lance
Lance
(Junior)
Offline
Junior
Iscritto: 24/11/2011
Messaggi: 14

Niente da fare, questa libreria ce l'ho già installata. Ho anche provato a disinstallare la mia versione con quella richiesta ma mi si apre una finestra di conflitto che dice che alcuni pacchetti (sudo, alien, perl etc) necessitano della ZLIB_2.3.3 e se voglio disinstallarla devo per forza disinstallare anche questi. Faccio notare che tra l'altro la libreria che usano è la stessa che GP dice di non riuscire a trovare...
o cerca nel posto sbagliato o non so...

Ritratto di FabioFender
FabioFender
(Geek)
Offline
Geek
Iscritto: 31/10/2006
Messaggi: 109

Lance ha scritto:

FabioFender ha scritto:

Prova a vedere se funziona la versione di windows con wine oppure passa a tuxguitar

Uhm non ho mai provato wine, ma dovrei installare la versione per windows?

@dragoncello: Grazie per il link ora guardo Smile

in teoria con wine è sufficiente andare sull'installabile di windows e cliccare col tasto destro apri con wine o cose simili, però aspetta a farlo, tanto serve anche a me, lo installo e ti dico se funziona (e soprattutto "come") però nel frattempo hai provato a installare Tuxguitar? è molto simile e compatibile con tutti i file di guitar pro, addirittura riesce ad aprire file che guitar pro 5 (il mio) non riesce perchè dev'essere aggiornato ... tuxguitar invece li apre tranquillamente.

Ritratto di Lance
Lance
(Junior)
Offline
Junior
Iscritto: 24/11/2011
Messaggi: 14

Ho fatto un passo avanti: da terminale ho notato che la libz.1.so nella directory opt/GuitarPro6 non era di colore verde come erano tutte le altre e come dovrebbe essere in quanto eseguibile (scusatemi se ho detto qualche boiata ma sono alle prime armi), quindi ho provato a renderla eseguibile con il comando chmod +x ma niente. Allora ho pensato di cancellarla e sostituire la mia libz con quella di GP, nell'intermezzo ho provato a far partire il programma e.... è partito!! Ora però c'è un nuovo problema: i tastini Offline Activation e OK della schermata che chiede di inserire ID e Key, rimangono grigetti senza che possa cliccarci sopra e quindi ne attivare il mio programma ne entrare nel caso avessi già un ID e la sue Key...
A questo punto ho provato ad aggiungere le librerie (dato che nella mia cartella lib ne ho due: libz.so.1 e libz.so.1.2.5) ma non cambia assolutamente nulla...

Ritratto di Lance
Lance
(Junior)
Offline
Junior
Iscritto: 24/11/2011
Messaggi: 14

Risolto!! Ora l'applicazione si apre perfettamente Smile
Purtroppo però c'è un nuovo problema: oltre alla musichetta di apertura non riesco a sentire le tracce... sarà che non ho installato alcun RSE?

Ritratto di Suse98
Suse98
(Guru)
Offline
Guru
Iscritto: 03/10/2010
Messaggi: 1711

Lance ha scritto:

Risolto!! Ora l'applicazione si apre perfettamente Smile
Purtroppo però c'è un nuovo problema: oltre alla musichetta di apertura non riesco a sentire le tracce... sarà che non ho installato alcun RSE?

Vedi nelle impostazioni audio del programma e di suse.
Ciao Wink

SUSE LINUX Rilascio 12.3 (Dartmounth) KDE 4.10 && GNOME 3.8