Installazione Moneymanagerex

5 risposte [Ultimo messaggio]
Ritratto di xdodo49
xdodo49
(Junior)
Offline
Junior
Iscritto: 06/02/2015
Messaggi: 9

Ho appena installato opensuse 42.3 kde su il mio portatile. Volevo installare un software di contabilità che utilizzo da anni su svariate piattaforme Moneymanagerex ma non riesco perchè continua a segnalare la mancanza di una libreria o dipendenza. Premetto che io bazzico da anni in ambiente linux ma sono assolutamente un dilettante e ho grosse difficolta con l'inglese. Il software che voglio utilizzare gira tranquillamente su ubuntu o mint e stando alla pagina di download, dispone anche della versione per opensuse (https://packagecloud.io/moneymanagerex/moneymanagerex/packages/opensuse/42.2/mmex-1.4.0-1.x86_64.rpm ).
Ora spero che qualcuno voglia aiutarmi a risolvere questo mio problema visitando la pagina di cui ho fornito il link sopra e verificando cosa posso fare per trovare una soluzione.
Grazie in anticipo.

xdodo49

Ritratto di max.riservo
max.riservo
(Geek)
Offline
Geek
Iscritto: 04/02/2012
Messaggi: 167

Presumo che tu abbia scaricato il file di installazione (.rpm) e poi che tu abbia tentato l' installazione da una Konsole (come root) e ti sia uscito l'errore di dipedenza fallita ....
Fai così :
- apri una konsole
- loggati come root (o se preferisci utilizza sudo)
- fai risolvere le dipende direttamente da zypper (sempre che tu abbia i repository che gli permettono di farlo) con il seguente comando
zypper in nomefiledainstallare.rpm

Se zypper non riesce a risolvere le dipendenze, mostraci quali dipendenze mancano ....

A volte sono presente anche in altri forum di programmazione ....

Ritratto di xdodo49
xdodo49
(Junior)
Offline
Junior
Iscritto: 06/02/2015
Messaggi: 9

Io ho scaricato il file rpm e ho fatto l'installazione automatica con l'applicazione installa e rimuovi software.
Adesso ho seguito il tuo consiglio ma non è cambiato nulla.
Allego la schermata che mi è uscita.

adolfo@localhost:~/Scaricati> dir
totale 5940
-rw-r--r-- 1 root root 321 15 dic 13.56 conflicts.txt
-rw-r--r-- 1 adolfo users 722539 15 dic 13.08 libwx_baseu-suse1-3.0.2-11.1.x86_64.rpm
-rw-r--r-- 1 adolfo users 5351215 15 dic 13.01 mmex-1.4.0-1.x86_64.rpm
adolfo@localhost:~/Scaricati> rpm -i mmex-1.4.0-1.x86_64.rpm
errore: Dipendenze fallite:
libwx_baseu_net-suse.so.1()(64bit) necessario a mmex-1.4.0-1.x86_64
libwx_baseu_net-suse.so.1(WXU_3.0)(64bit) necessario a mmex-1.4.0-1.x86_64
libwx_baseu_xml-suse.so.1()(64bit) necessario a mmex-1.4.0-1.x86_64
libwx_baseu_xml-suse.so.1(WXU_3.0)(64bit) necessario a mmex-1.4.0-1.x86_64
libwx_gtk2u_adv-suse.so.1()(64bit) necessario a mmex-1.4.0-1.x86_64
libwx_gtk2u_adv-suse.so.1(WXU_3.0)(64bit) necessario a mmex-1.4.0-1.x86_64
libwx_gtk2u_aui-suse.so.1()(64bit) necessario a mmex-1.4.0-1.x86_64
libwx_gtk2u_aui-suse.so.1(WXU_3.0)(64bit) necessario a mmex-1.4.0-1.x86_64
libwx_gtk2u_html-suse.so.1()(64bit) necessario a mmex-1.4.0-1.x86_64
libwx_gtk2u_html-suse.so.1(WXU_3.0)(64bit) necessario a mmex-1.4.0-1.x86_64
libwx_gtk2u_qa-suse.so.1()(64bit) necessario a mmex-1.4.0-1.x86_64
libwx_gtk2u_qa-suse.so.1(WXU_3.0)(64bit) necessario a mmex-1.4.0-1.x86_64
libwx_gtk2u_stc-suse.so.1()(64bit) necessario a mmex-1.4.0-1.x86_64
libwx_gtk2u_stc-suse.so.1(WXU_3.0)(64bit) necessario a mmex-1.4.0-1.x86_64
libwx_gtk2u_webview-suse.so.1()(64bit) necessario a mmex-1.4.0-1.x86_64
libwx_gtk2u_webview-suse.so.1(WXU_3.0)(64bit) necessario a mmex-1.4.0-1.x86_64
adolfo@localhost:~/Scaricati> zypper in mmex-1.4.0-1.x86_64.rpm
Per installare o disinstallare i pacchetti sono necessari i privilegi dell'utente root.
adolfo@localhost:~/Scaricati> sudo zypper in mmex-1.4.0-1.x86_64.rpm
[sudo] password di root:
Caricamento dati del repository in corso...
Lettura dei pacchetti installati in corso...
'mmex = 0:1.4.0-1' è già installato.
Nessun aggiornamento candidato per 'mmex-1.4.0-1.x86_64'. La versione più recente disponibile è già installata.
Risoluzione dipendenze dei pacchetti in corso...

Nessuna operazione da eseguire.
adolfo@localhost:~/Scaricati>

xdodo49

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2727

https://software.opensuse.org/package/moneymanagerex?search_term=+Moneymanagerex
potresti provare da qui,non so se va a buon fine.

SUSE Tumbleweed- kernel-5.2.14-1-1 kde-plasma-5.16.5- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.116.51- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di xdodo49
xdodo49
(Junior)
Offline
Junior
Iscritto: 06/02/2015
Messaggi: 9

Provato anche il suggerimento di Dragoncello: sembrerebbe che tutto vada a buon fine, ma in realtà viene installata la versione 0.9 del software che è incompatibile con la versione attuale 1.3 o 1.4. In ogni caso non parte e se anche partisse non sarebbe in grado di leggere l'attuale database.

xdodo49

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2727

xdodo49 ha scritto:

Provato anche il suggerimento di Dragoncello: sembrerebbe che tutto vada a buon fine, ma in realtà viene installata la versione 0.9 del software che è incompatibile con la versione attuale 1.3 o 1.4. In ogni caso non parte e se anche partisse non sarebbe in grado di leggere l'attuale database.

Prova a postare sul forum inglese il problema.
https://forums.opensuse.org/forum.php
chiaramente ti devi registrare,e ti aiuti con google traslation,ciao

SUSE Tumbleweed- kernel-5.2.14-1-1 kde-plasma-5.16.5- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.116.51- SSD samsung 850 pro 512 gb http://opensuse-community.org/