installazione pacchetti diversi

6 risposte [Ultimo messaggio]
Ritratto di elmarculin
elmarculin
(Junior)
Offline
Junior
Iscritto: 26/03/2008
Messaggi: 32

Salve a tutti,
è un pò di tempo che sto provando la Suse e la trovo carina ma non riesco a capire una cosa.
Usando yast da terminale...come faccio a scegliere di installare una versione diversa di un pacchetto (esempio heartbeat).
Se scarico gli rpm e poi installo ottengo il risultato ma è l'unico modo?
Non posso specificare versioni più aggiornate (tipo unstable) o versioni più vecchie?
grazie

Ritratto di Crismon
Crismon
(Guru)
Offline
Guru
Iscritto: 28/11/2006
Messaggi: 1715

Non ho ben capito quello ceh vuoi dire...
Comunque installi la versione dei software contenuti nei repository... al massimo puoi effettuare un downgrade,.... o un'aggiornamento...

www.crismonblog.org | Un blog targato openSUSE

Ritratto di elmarculin
elmarculin
(Junior)
Offline
Junior
Iscritto: 26/03/2008
Messaggi: 32

yast mi propone
programma-1.0
Come faccio a installare una versione più vecchia?Te hai citato il downgrade...ho provato a cercare ma non lo trovo (uso yast senza GUI)..grazie

Ritratto di ferdybassi
ferdybassi
(Guru)
Offline
Guru
Iscritto: 11/09/2005
Messaggi: 2668

Quote:

Non posso specificare versioni più aggiornate (tipo unstable) o versioni più vecchie?
grazie

Le versioni stabili di SUSe escono con i pacchetti congelati ad una certa versione, come fanno tutte le distro. Se vuoi avere pacchetti più aggiornati dalla versione unstable, devi configurare Yast per scaricare dai repository di suse factory.
Lasciati dire però che usare factory è un po'come usare Debian SID: andrebbe lasciato a chi ha un grandespirito di avventura, o a chi non interessa avere un sistema instabile, o a chi sa come metterlo a posto se si sfascia...

Ciao ciao

Amministratore di
www.it-opensuse.org

Ritratto di elmarculin
elmarculin
(Junior)
Offline
Junior
Iscritto: 26/03/2008
Messaggi: 32

già ma visto che che sto provando heartbeat (ed ha un BUG...già segnalato) come posso fare per risolverlo oltre che aspettare che facciano le patch?
So che se installo una versione precedente risolvo il BUG (ho una vecchia suse su un altro pc e non soffre di questo BUG perchè il pacchetto è la versione precedente)....
Posso in qualche modo dire a yast di installarmi la vecchia versione?
grazie

Ritratto di Il_Cjargnel
Il_Cjargnel
(Guru)
Offline
Guru
Iscritto: 04/08/2005
Messaggi: 1886

da quello che so io, nei repo ci stanno solo le ultime versioni, cosa anche ragionevole, perche se devono tenere tutte le versioni di tutti i programmi, posso immaginare che razza di server occorre, quindi nei repo "ufficiali" trovi solo versioni aggirnate!!!!

Come provvedere a versioni più vecchiotte... un modo che mi viene in mente è scaricare dal sito del produttore la vecchia versione da compilare (quindi tipo xxxx.tar.bz2) che di solito le tengono tutte e poi complilarle a mano!!

Oppure tentare sui motori di ricerca degli rpm e vedere se per caso ce qualche vecchia versionein giro, che però così a naso, non troverai versioni compilate per sistemi nuovi troppo datate..però tentar non nuoce.
Questo è quanto mi sovviene in mente alle 7.51... magari poi ci son anche altre soluzioni!

P.s. solitamente i bachi vengono "coperti" abbastanza in fretta...

OpenSuse 11.0+ OpenSuse 11.2

Ritratto di robermann79
robermann79
(Monster)
Offline
Monster
Iscritto: 07/02/2007
Messaggi: 342

In generale dovresti aggiungere su YAST il repository contenente le versioni alternative. Un elenco di repository potresti trovarlo qui:

http://packages.opensuse-community.org/index.jsp?searchTerm=heartbeat

(con 1-click install il repo viene aggiunto in generale)

Se vuoi scaricarti i pacchetti a mano, puoi sfruttare questo sito:
http://rpm.pbone.net/

tra i primi risultati:
<br />http://rpm.pbone.net/index.php3/stat/4/idpl/5885382/com/heartbeat-2.1.3.2008011323-1.1.x86_64.rpm.html<br />http://rpm.pbone.net/index.php3/stat/4/idpl/5885429/com/heartbeat-2.1.3.2008011323-1.1.x86_64.rpm.html<br />http://rpm.pbone.net/index.php3/stat/4/idpl/5885441/com/heartbeat-2.1.3.2008011323-1.1.x86_64.rpm.html<br />http://rpm.pbone.net/index.php3/stat/4/idpl/5885392/com/heartbeat-2.1.3.2008011323-1.1.i586.rpm.html<br />http://rpm.pbone.net/index.php3/stat/4/idpl/5885423/com/heartbeat-2.1.3.2008011323-1.1.i586.rpm.html<br />http://rpm.pbone.net/index.php3/stat/4/idpl/5885435/com/heartbeat-2.1.3.2008011323-1.1.i586.rpm.html<br />http://rpm.pbone.net/index.php3/stat/4/idpl/5885377/com/heartbeat-2.1.3.2008011323-1.1.i386.rpm.html<br />http://rpm.pbone.net/index.php3/stat/4/idpl/5885387/com/heartbeat-2.1.3.2008011323-1.1.i386.rpm.html<br />http://rpm.pbone.net/index.php3/stat/4/idpl/6142852/com/heartbeat-2.1.3-15.2.x86_64.rpm.html<br />http://rpm.pbone.net/index.php3/stat/4/idpl/6422751/com/heartbeat-2.1.3-15.15.i586.rpm.html<br />http://rpm.pbone.net/index.php3/stat/4/idpl/6142598/com/heartbeat-2.1.3-15.1.x86_64.rpm.html<br />http://rpm.pbone.net/index.php3/stat/4/idpl/6142626/com/heartbeat-2.1.3-15.1.x86_64.rpm.html<br />http://rpm.pbone.net/index.php3/stat/4/idpl/6142654/com/heartbeat-2.1.3-15.1.x86_64.rpm.html<br />http://rpm.pbone.net/index.php3/stat/4/idpl/6142682/com/heartbeat-2.1.3-15.1.x86_64.rpm.html<br />http://rpm.pbone.net/index.php3/stat/4/idpl/6142743/com/heartbeat-2.1.3-15.1.x86_64.rpm.html<br />http://rpm.pbone.net/index.php3/stat/4/idpl/6142776/com/heartbeat-2.1.3-15.1.x86_64.rpm.html<br />http://rpm.pbone.net/index.php3/stat/4/idpl/6142814/com/heartbeat-2.1.3-15.1.x86_64.rpm.html<br />http://rpm.pbone.net/index.php3/stat/4/idpl/6142890/com/heartbeat-2.1.3-15.1.x86_64.rpm.html<br />http://rpm.pbone.net/index.php3/stat/4/idpl/6142928/com/heartbeat-2.1.3-15.1.x86_64.rpm.html<br />http://rpm.pbone.net/index.php3/stat/4/idpl/6142966/com/heartbeat-2.1.3-15.1.x86_64.rpm.html<br />http://rpm.pbone.net/index.php3/stat/4/idpl/6143004/com/heartbeat-2.1.3-15.1.x86_64.rpm.html<br />http://rpm.pbone.net/index.php3/stat/4/idpl/6142871/com/heartbeat-2.1.3-15.1.i586.rpm.html<br />http://rpm.pbone.net/index.php3/stat/4/idpl/6142696/com/heartbeat-2.1.3-15.1.i586.rpm.html<br />http://rpm.pbone.net/index.php3/stat/4/idpl/6142710/com/heartbeat-2.1.3-15.1.i586.rpm.html<br />http://rpm.pbone.net/index.php3/stat/4/idpl/6142757/com/heartbeat-2.1.3-15.1.i586.rpm.html<br />http://rpm.pbone.net/index.php3/stat/4/idpl/6142795/com/heartbeat-2.1.3-15.1.i586.rpm.html<br />http://rpm.pbone.net/index.php3/stat/4/idpl/6142909/com/heartbeat-2.1.3-15.1.i586.rpm.html<br />http://rpm.pbone.net/index.php3/stat/4/idpl/6142947/com/heartbeat-2.1.3-15.1.i586.rpm.html<br />http://rpm.pbone.net/index.php3/stat/4/idpl/6142985/com/heartbeat-2.1.3-15.1.i586.rpm.html<br />http://rpm.pbone.net/index.php3/stat/4/idpl/6142584/com/heartbeat-2.1.3-15.1.i386.rpm.html<br />http://rpm.pbone.net/index.php3/stat/4/idpl/6142612/com/heartbeat-2.1.3-15.1.i386.rpm.html<br />http://rpm.pbone.net/index.php3/stat/4/idpl/6142640/com/heartbeat-2.1.3-15.1.i386.rpm.html<br />http://rpm.pbone.net/index.php3/stat/4/idpl/6142668/com/heartbeat-2.1.3-15.1.i386.rpm.html<br />http://rpm.pbone.net/index.php3/stat/4/idpl/6142729/com/heartbeat-2.1.3-15.1.i386.rpm.html<br />http://rpm.pbone.net/index.php3/stat/4/idpl/6186982/com/heartbeat-2.1.3-1.4.x86_64.rpm.html<br />http://rpm.pbone.net/index.php3/stat/4/idpl/6419637/com/heartbeat-2.1.3-1.32.i586.rpm.html<br />http://rpm.pbone.net/index.php3/stat/4/idpl/5885404/com/heartbeat-2.1.3-1.1.x86_64.rpm.html<br />http://rpm.pbone.net/index.php3/stat/4/idpl/5885417/com/heartbeat-2.1.3-1.1.x86_64.rpm.html<br />http://rpm.pbone.net/index.php3/stat/4/idpl/5885397/com/heartbeat-2.1.3-1.1.i586.rpm.html<br />http://rpm.pbone.net/index.php3/stat/4/idpl/5885411/com/heartbeat-2.1.3-1.1.i586.rpm.html<br />

ciao