jre

12 risposte [Ultimo messaggio]
Ritratto di drakkar
drakkar
(Junior)
Offline
Junior
Iscritto: 17/10/2004
Messaggi: 13

ciao a tutti,sono un 'utente di suse 9.0 ed ho una domanda:volevo installare la virtual machine del java ma non l'ho trovata sul dvd...(strano,no?) allora ho scaricato la jre 1.4.2_06 dal sito,l'ho installata (rpm) ma non riesco a farla funzionare...il comando java,contenuto in /usr/java/j2re1.4.2_06/bin,non viene accettato...
forse devo creare qualche link...?
grazie

Ritratto di auris
auris
(Guru)
Offline
Guru
Iscritto: 10/09/2004
Messaggi: 4923

Aggiungi queste due righe al file /etc/profile oppure nel file .bashrc:

PATH="$PATH:/usr/java/j2re1.4.2_06/bin:."
export PATH

Prova a testare prima Java col comando:
/usr/java/j2re1.4.2_06/bin/java -version

Se sei stanco di virus e schermate blu passa a Linux

Ritratto di drakkar
drakkar
(Junior)
Offline
Junior
Iscritto: 17/10/2004
Messaggi: 13

x l'utente è ok!ma non funziona da root...io l'ho scritto nel .bashrc dell'utente...
ho provato a scriverlo anche nel file /etc/profile,questo è l'ultima parte del file, se ti può servire:
#
# KSH specials
#
if test "$is" = "ksh" ; then
test -r /etc/ksh.kshrc && . /etc/ksh.kshrc
fi
if test "$is" = "ksh" -a -z "$_HOMEKSHRC" ; then
# loop detection
readonly _HOMEKSHRC=true
test -r $HOME/.kshrc && . $HOME/.kshrc
fi

export PATH JAVA_HOME CLASSPATH
PATH="$PATH:/usr/java/j2re1.4.2_06/bin:."
export PATH

#
# End of /etc/profile
#

thanx

Ritratto di auris
auris
(Guru)
Offline
Guru
Iscritto: 10/09/2004
Messaggi: 4923

Da root:
# gedit /etc/profile.d/java.sh (o qualunque altro editor)
Aggiungi la seguente riga:
export PATH=$PATH:/usr/java/j2re1.4.2_06/bin/
Salva il file.
Rendi eseguibile il file sempre da root:
# chmod +x java.sh

Se sei stanco di virus e schermate blu passa a Linux

Ritratto di drakkar
drakkar
(Junior)
Offline
Junior
Iscritto: 17/10/2004
Messaggi: 13

ok auris,sei puntuale e competente come sempre!!
se uso yast2,installazione pacchetti,esso non riconosce jre (nè come nome,sommario,fornisce),infatti non mi permette di installare eclipse (quello incluso nel dvd)...come posso ovviare a questo inconveniete?

un'altra domanda,forse off-topic,se apro una shell,come utente normale,riesco ad avviare i programmi,es. kwrite,mentre se faccio login come root ricevo l'errore:
linux:/home/matteo # kwrite
bash: kwrite: command not found
questo non avviene se accedo all'interfaccia grafica direttamente come root...la cosa è scomoda xchè ho dovuto riavviare l'interfaccia ed accedere come root, x poter creare il file che mi hai consigliato.

grazie ancora!

Ritratto di auris
auris
(Guru)
Offline
Guru
Iscritto: 10/09/2004
Messaggi: 4923

Hai installato jre inclusa nel DVD di SuSE oppure quella presente sul sito della Sun?
Nella seconda ipotesi, il problema consiste nel fatto che la versione presente nel DVD richiede una versione specifica di jre (ovvero quella utilizzata da SuSE) e che soddisfi le dipendenze. Un esempio di questo comportamento lo hai con OpenOffice.org incluso nei CD/DVD della SuSE (puoi installarlo solo se usi jre inclusa nei CD di SuSE).
Per avviare kwrite da root, apri una shell e digita questi comandi:
$ xhost +
$ su (password)
# export DISPLAY=:0
# kwrite

$ ---> utente normale
# ---> root

Se sei stanco di virus e schermate blu passa a Linux

Ritratto di drakkar
drakkar
(Junior)
Offline
Junior
Iscritto: 17/10/2004
Messaggi: 13

la jre installata è quella di sun...al comando che mi hai consigliato ho questa risposta:
matteo@linux:~> xhost +
access control disabled, clients can connect from any host
ti risulta?

Ritratto di auris
auris
(Guru)
Offline
Guru
Iscritto: 10/09/2004
Messaggi: 4923

Sì va bene

Se sei stanco di virus e schermate blu passa a Linux

Ritratto di drakkar
drakkar
(Junior)
Offline
Junior
Iscritto: 17/10/2004
Messaggi: 13

non va bene?non funziona...
ti posto i messaggi ricevuti:

matteo@linux:~> xhost +
access control disabled, clients can connect from any host
matteo@linux:~> su
Password:
linux:/home/matteo # export DISPLAY=:0
linux:/home/matteo # kwrite
bash: kwrite: command not found

Ritratto di auris
auris
(Guru)
Offline
Guru
Iscritto: 10/09/2004
Messaggi: 4923

Prova un altro editor: emacs, gedit, kate, vim, nedit, etc...
Vedrai che funziona.

Se sei stanco di virus e schermate blu passa a Linux

Ritratto di drakkar
drakkar
(Junior)
Offline
Junior
Iscritto: 17/10/2004
Messaggi: 13

negativo:
matteo@linux:~> xhost +
access control disabled, clients can connect from any host
matteo@linux:~> su
Password:
linux:/home/matteo # export DISPLAY=:0
linux:/home/matteo # kate
bash: kate: command not found
linux:/home/matteo # emacs
bash: emacs: command not found
linux:/home/matteo # nedit
bash: nedit: command not found