kiwi

12 risposte [Ultimo messaggio]
Ritratto di max73
max73
(Monster)
Offline
Monster
Iscritto: 22/11/2004
Messaggi: 212

Stò provando a creare un'immagine di opensuse aggiornata ad oggi ma kiwi alla fine mi dà sempre lo stesso errore "aufs non trovato".
Qualcuno ha mai provato ad usare kiwi?

Ritratto di capejeaspaje
capejeaspaje
(Geek)
Offline
Geek
Iscritto: 08/07/2007
Messaggi: 112

Se ti puo' servire ho scritto una guida all'uso di systemrescueCD per la creazione di immagini.
E' proprio in cima alla lista nella sezione Guide.
Ciao.

Ritratto di anubis
anubis
(Guru)
Offline
Guru
Iscritto: 07/04/2007
Messaggi: 3656

max73 ha scritto:

Stò provando a creare un'immagine di opensuse aggiornata ad oggi ma kiwi alla fine mi dà sempre lo stesso errore "aufs non trovato".
Qualcuno ha mai provato ad usare kiwi?

si, lo uso quotidianamente ormai, mi serve il log,

aufs puo' voler dire tutto... probabilmente manca il relativo pacchetto

OpenSUSE Member,Packman Packager, Education Project Admin, LXDE Project Admin
Powered by http://en.opensuse.org/HP_Pavilion_dv6855el

Ritratto di max73
max73
(Monster)
Offline
Monster
Iscritto: 22/11/2004
Messaggi: 212

@capejeaspaje
Grazie ci darò un'occhiata...
@anubis
Guarda ho installato aufs dal buildservice, poi ho ottenuto un nuovo errore riguardo cromfs, trovato anche quello nel buildservice, ora però mi sono fermato quì:

+ /usr/bin/zypper --non-interactive --no-gpg-checks --reposd-dir /var/cache/kiwi/zypper --cache-dir /var/cache/kiwi/zypper --raw-cache-dir /var/cache/kiwi/zypper --root /tmp/kiwi-cdboot.eoczvE/kiwi-cdboot-10980 install --auto-agree-with-licenses --no-recommends adaptec-firmware aufs aufs-kmp-default bind-libs bind-utils bootsplash checkmedia cromfs cryptsetup dhcpcd dialog file filesystem fribidi gawk gfxboot glibc glibc-locale grub hdparm hwinfo iproute2 kernel-default kernel-default-base kernel-default-extra kiwi-tools lvm2 make memtest86+ netcfg psmisc rpm squashfs sysconfig sysfsutils syslinux tar
+ SPID=11727
+ wait 11727
'kernel-default-extra' non trovato.
+ ECODE=104
+ echo 104
+ exit 104

Ritratto di max73
max73
(Monster)
Offline
Monster
Iscritto: 22/11/2004
Messaggi: 212

Purtroppo il pacchetto kernel-default-extra si trova nel buildservice per versioni del kernel precedenti quindi non posso proprio andare avanti.

Ritratto di Mirko
Mirko
(Guru)
Offline
Guru
Iscritto: 19/12/2005
Messaggi: 1602

E ti è proprio necessario quel pacchetto? Io non ce l'ho nemmeno nei repo, fai un po' tu...

Ritratto di max73
max73
(Monster)
Offline
Monster
Iscritto: 22/11/2004
Messaggi: 212

A me non è necessario, il fatto è che lo richiede kiwi durante la creazione dell'immagine e non sò se è possibile toglierlo dalle dipendenze.

Ritratto di anubis
anubis
(Guru)
Offline
Guru
Iscritto: 07/04/2007
Messaggi: 3656

per quale versione di suse stai creando l'immagine? la 11.2 non ha quel pacchetto, ed ovviamente assicurati che il repo "update" sia aggiornato.

posso vedere il file .kiwi che usi per costruire la iso?

(usa pastebin)

OpenSUSE Member,Packman Packager, Education Project Admin, LXDE Project Admin
Powered by http://en.opensuse.org/HP_Pavilion_dv6855el

Ritratto di max73
max73
(Monster)
Offline
Monster
Iscritto: 22/11/2004
Messaggi: 212

La versione è la 11.2, tieni conto che stò usando kiwi da yast senza modificare nulla a parte aggiungere i pacchetti aggiornati, il file di configurazione presente non l'ho modificato.
Guarda io vorrei aggiungere esclusivamente gli aggiornamenti per installare opensuse ad un mio amico che ha una connessione del cavolo, se c'è un modo veloce per farlo bene, altrimenti lascio perdere.
Pensavo fosse semplice come in questa guida ma forse non è così.
http://www.dedoimedo.com/computers/kiwi.html

Ritratto di Mirko
Mirko
(Guru)
Offline
Guru
Iscritto: 19/12/2005
Messaggi: 1602

Volendo puoi trovare il pacchetto qui:
http://software.opensuse.org/search

Ma guarda la lista dei repo in cui si trova, sono tutti dei repo home. Secondo me quel pacchetto non ti dovrebbe servire, ma se proprio te lo chiede, bisognerebbe sapere esattamente come ti stai muovendo con Kiwi

Ritratto di max73
max73
(Monster)
Offline
Monster
Iscritto: 22/11/2004
Messaggi: 212

Si infatti, anche secondo me non mi dovrebbe servire, come del resto aufs e cronfs che sono presenti solo nei repo home.
Kiwi praticamente non l'ho configurato, da yast, product creator ho solo aggiunto i repository e ho lasciato il file di configurazione presente senza modifiche.
Poi ho cliccato su crea immagine con kiwi e stop.