kopete

3 risposte [Ultimo messaggio]
Ritratto di lucadelu
lucadelu
(Geek)
Offline
Geek
Iscritto: 27/03/2006
Messaggi: 76

Oggi volevo aggiornare kopete, così sono andato su yast ma con mio grande stupore non ho avuto modo di aggiornarlo di li, così ho scaricato i binari e provati ad installare, durante il configure mi da questo errore:

in the prefix, you've chosen, are no KDE headers installed. This will fail.
So, check this please and use another prefix!

A che prefisso si riferisce?

grazie
ciao Luca

Ritratto di pernix
pernix
(Guru)
Offline
Guru
Iscritto: 07/07/2006
Messaggi: 995

dovresti usare il comando:./configure --prefix=/opt/kde3
devi avere installato il pacchetto kdebase3-devel... forse servirà anche qualche altro pacchetto devel, ma non ricordo quali, te lo diranno gli errori del configure.

In a world without walls and fences, who needs Windows ad Gates?

openSUSE 10.3 - KDE+Compiz
Dell Latitude D820N: Intel T7200 2GHz; 2GB RAM 667MHz; Nvidia Quadro NVS 120M 512MB

Ritratto di lucadelu
lucadelu
(Geek)
Offline
Geek
Iscritto: 27/03/2006
Messaggi: 76

Quote:

pernix ha scritto:
dovresti usare il comando:./configure --prefix=/opt/kde3
devi avere installato il pacchetto kdebase3-devel... forse servirà anche qualche altro pacchetto devel, ma non ricordo quali, te lo diranno gli errori del configure.

Ho provato, ma continua a darmi sempre lo stesso errore, ho provato ad aggiungere anche /bin oppure /include/kopete ma niente...la cartella dove ci sono i file per l'installazione deve stare da qualche parte di preciso o sulla home va bene?

Ritratto di rebelsoft
rebelsoft
(Junior)
Offline
Junior
Iscritto: 24/11/2006
Messaggi: 34

Quote:

lucadelu ha scritto:
Ho provato, ma continua a darmi sempre lo stesso errore, ho provato ad aggiungere anche /bin oppure /include/kopete ma niente...la cartella dove ci sono i file per l'installazione deve stare da qualche parte di preciso o sulla home va bene?

Metodo rozzo.
Apri Yast ed esegui il modulo Gestione pacchetti. All'altezza del label Filtro apri il menu a tendina e seleziona Modelli quindi scorri la lista fino alla categoria Sviluppo e seleziona la voce (spuntando il checkbox) Sviluppo KDE. A questo punto clicka sul bottone Accetta e permetti l'installazione delle eventuali dipendenze.

Una buona idea sarebbe quella di installare il software nella propria home:

$ ./configure --prefix=$HOME/kde && make && make install

soprattutto se non devi condividere l'applicativo con altri utenti.

(oppure usa checkinstall)

PS
Facendo in questo modo sono riuscito ad installare l'ultima versione di Kopete su di una OpenSuSE 10.2rc1

Fai un programma che anche un idiota puo'
usare, e soltanto un idiota vorrà usarlo.