krpmbuilder 1.2

4 risposte [Ultimo messaggio]
Ritratto di Utino
Utino
(Monster)
Offline
Monster
Iscritto: 14/10/2006
Messaggi: 212

Ciao a tutti, ho un problema con il programma krpmbuilder, premettendo che non l'ho mai usato, compilo tutto ma alla fine compaiono questi errori:
_______________________________________
checking tcl build dir... ./configure: line 2852: locate: command not found
using tcl library in /usr/lib64
checking tk build dir... ./configure: line 3000: locate: command not found
using tk library in /opt/kde3/lib
./configure: line 3052: /opt/kde3/lib/tkConfig.sh: No such file or directory
error: Bad exit status from /var/tmp/rpm-tmp.63092 (%build)
Bad exit status from /var/tmp/rpm-tmp.63092 (%build)

RPM build errors:
_______________________________________

tramite YAST penso di aver installato tutto ciò che ha a che fare con TCL, TK (che non so nemmeno cosa siano...) ma nulla è cambiato, cercando in giro non ho trovato guide (nemmeno sul sito ufficiale) ne info su vari forum... riuscite ad aiutarmi?

per completezza uso openSUSE 10.2

grazie in anticipo

Be free, use Linux! ma meglio se openSUSE...

Ritratto di barravince
barravince
(Guru)
Offline
Guru
Iscritto: 16/06/2005
Messaggi: 727

Ciao,
Non ti consiglio di usare krpmbuilder, bensì di creare lo spec file per i fati tuoi, ti rimando a queste pagine: http://www.rpm.org/RPM-HOWTO/build.html
Se non capisci l'inglese puoi tradurre pure col traduttore di pagine google.
Facci sapere

Vincenzo 8-)

Ritratto di Utino
Utino
(Monster)
Offline
Monster
Iscritto: 14/10/2006
Messaggi: 212

innanzi tutto grazie del link, ho provato ma al momento di fare il build con :

rpm -ba nome-versione-release.tar.bz2

compare il messaggio:

-ba unknow option

effettivamente guardando l'help non trovo l'opzione -b, peccato che non trovi nemmeno quale sia quella giusta da usare... qualcubo sa dirmi cosa scrivere?

Be free, use Linux! ma meglio se openSUSE...

Ritratto di Utino
Utino
(Monster)
Offline
Monster
Iscritto: 14/10/2006
Messaggi: 212

ok, un pezzo l'ho risolto, non devo usare il comando rpm ma rpm build, peccato che così facendo io ottenga lo stesso errore che avevo scritto precedentemente:
_______________________________________
checking tcl build dir... ./configure: line 2852: locate: command not found
using tcl library in /usr/lib64
checking tk build dir... ./configure: line 3000: locate: command not found
using tk library in /opt/kde3/lib
./configure: line 3052: /opt/kde3/lib/tkConfig.sh: No such file or directory
error: Bad exit status from /var/tmp/rpm-tmp.18388 (%build)

RPM build errors:
Bad exit status from /var/tmp/rpm-tmp.18388 (%build)
_______________________________________

c'è qualcosa da instalalre o configurare?
non riesco a trovare info da nessuna parte, una buon'anima che mi da una mano?? Sad

Be free, use Linux! ma meglio se openSUSE...

Ritratto di pernix
pernix
(Guru)
Offline
Guru
Iscritto: 07/07/2006
Messaggi: 995

Hai controllato di avere tk e tlc installati con gli eventuali pacchetti devel?

In a world without walls and fences, who needs Windows ad Gates?

openSUSE 10.3 - KDE+Compiz
Dell Latitude D820N: Intel T7200 2GHz; 2GB RAM 667MHz; Nvidia Quadro NVS 120M 512MB