Lettore smart card

6 risposte [Ultimo messaggio]
Ritratto di federico_231
federico_231
(Newbie)
Offline
Newbie
Iscritto: 20/11/2017
Messaggi: 3

buon pomeriggio a tutti.

mi scuso se già questa domanda è già stata postata e risolta: ho fatto una ricerca ma le indicazioni che ho trovato non mi hanno permesso di risolvere l'inghippo.
Sto cercando di 'installare' il software CRS (tesserea sanitaria lombardia) ma non riesco a vedere il lettore di smart card.
Ho seguito la procedura ripresa dal manuale di regione lombardia, ma quando devo aggiungere un nuovo modulo in Firefox (per configurare le librerie) ricevo il messaggio 'impossibile aggiungere nuovo modulo'.

non riesco ad uscirne...
se c'è già altro su questo argomento e volete re-indirizzarmi...grazie!

federico

Ritratto di jambolo70
jambolo70
(Junior)
Offline
Junior
Iscritto: 03/03/2012
Messaggi: 22

io con la versione Tumbleweed ho risolto seguendo questo post proprio ieri sera
http://trucchisuse.altervista.org/blog/installare-la-card-sanitaria-su-suse/

e finalmente mi ha iniziato a funzionare con la 42.2 non mi andava più e come smart card ho un Hamlet.

PS: per il programma CRS Manager per installarlo devi aprire il terminale
digitare

su
poi la tua pasword
cd /Scaricati (sempre che il file sia in questa directory)
chmod 777 CRSManager.run (dai i permessi di scrittura,lettura ed esecuzione)
./CRSManager.run  (installi il programma)

Una volta installato devi solo cercarlo all'interno del menu / Accessori
la prima volta che viene lanciato si aggiorna, poi puoi rilanciarlo.

ho appena concluso anche l'installazione sulla 42.3 e sembra funzionare tutto... D Oh
Saluti.

Mi piace tantissimo la ver. 12.1 dopo la 9.2 l'ho trovata ottima
attualmente utilizzo la 42.3 e Tumbleweed

Ritratto di federico_231
federico_231
(Newbie)
Offline
Newbie
Iscritto: 20/11/2017
Messaggi: 3

Ti ringrazio per la dritta.
Temo di aver qualche altro problema.
Quando tento di installare le librerie ricevo questo alert

nessun elemento fornisce libcrypto.so.10()(64bit) obbligatorio per opensc-0.12.0-3.fc14.x86_64.rpm

forzando l'installazione, poi, nell'editor dei runlevel non trovo il servizio Openct e non riesco poi cmq a caricare il modulo in Firefox...

D Oh D Oh At Wits End

Ritratto di jambolo70
jambolo70
(Junior)
Offline
Junior
Iscritto: 03/03/2012
Messaggi: 22

ma hai attivato in yast il repository :
http://download.opensuse.org/repositories/security:/chipcard/openSUSE_Leap_42.3/

Mi piace tantissimo la ver. 12.1 dopo la 9.2 l'ho trovata ottima
attualmente utilizzo la 42.3 e Tumbleweed

Ritratto di jambolo70
jambolo70
(Junior)
Offline
Junior
Iscritto: 03/03/2012
Messaggi: 22

federico_231 ha scritto:

Ti ringrazio per la dritta.
Temo di aver qualche altro problema.
Quando tento di installare le librerie ricevo questo alert

nessun elemento fornisce libcrypto.so.10()(64bit) obbligatorio per opensc-0.12.0-3.fc14.x86_64.rpm

forzando l'installazione, poi, nell'editor dei runlevel non trovo il servizio Openct e non riesco poi cmq a caricare il modulo in Firefox...

D Oh D Oh At Wits End


La prima operazione da fare è quella di aprire Yast
- Gestione Pacchetti (una volta avviato il programma)
- configurazione
- Repository ( o CRTL+R)
a questo punto
- aggiungi
-aggiungi i repository prima della comunità
poi aggiungi quello che ho postato prima
però se utilizzi la versione tumbleweed allora cambia con http://download.opensuse.org/repositories/security:/chipcard/openSUSE_Tumbleweed/
a questo punto dai l'ok e conferma le varie chiavi che ti verranno date dei repository inseriti
poi stampati in formato pdf il link "trucchi suse"
chiudi il browser e con la funzione cerca su yast cerca i vari file
libpcsclite1, pcsc-ccid, pcsc-acsccid, libopenct1, openct, pcsc-openct, opensc, pcsc-lite, libtowitoko2, libacr38ucontrol0, pcsc-gempc, pcsc-tools, pcsc-acr38, libpkcs11-helper1, pkcs11-helper
se ne hai qualcuno già installato di questi spuntalo lo stesso che faccia l'update/upgrade
una volta spuntati tutti accetta ed installa il tutto.
poi segui il terzo punto per attivare i servizi
da li in poi dovrebbe essere tutto in discesa, almeno spero per te...

Per attivare poi il servizio sul browser ad esempio non ho utilizzato la libreria segnalata ma
 /usr/lib64/pkcs11/opensc-pkcs11.so
mentre nella versione tumbleweed ho utilizzato onepin-opensc-pkcs11.so

In caso contrario va visto che versione hai e quali repository hai attivi su yast e ricominciare tutto da capo

Mi piace tantissimo la ver. 12.1 dopo la 9.2 l'ho trovata ottima
attualmente utilizzo la 42.3 e Tumbleweed

Ritratto di federico_231
federico_231
(Newbie)
Offline
Newbie
Iscritto: 20/11/2017
Messaggi: 3

Ho purtroppo riprovato più volte, partendo daccapo...
ma non ne esco.
devo aver qualcosa io nel sistema.

a questo punto rinuncerò all'utilizzo dello smartcard.

grazie cmq!

Ritratto di jambolo70
jambolo70
(Junior)
Offline
Junior
Iscritto: 03/03/2012
Messaggi: 22

Intanto per cominciare non seguire il manuale di CRS Lombardina, andava bene fino alla 13.x dalla 42.x non va più seguito, perché anche a me col passaggio alla 42 non funzionava più.
Quindi se puoi a ritroso da quel manuale disintalla tuttto;
una volta fatto inserisci il tuo lettore smart card (presumo sia collegato via usb)
e poi apri il temrinale konsole e digita
lsusb
poi posta cosa ti riporta
ripartiamo da questo, proviamo passo passo.

PS : sappimi dire anche il modello e marca che è di lettore e quale versione hai di OpenSuse installata.

Mi piace tantissimo la ver. 12.1 dopo la 9.2 l'ho trovata ottima
attualmente utilizzo la 42.3 e Tumbleweed