LibreOffice 6, crash in avvio

20 risposte [Ultimo messaggio]
Ritratto di Ramtaturis
Ramtaturis
(Geek)
Offline
Geek
Iscritto: 24/06/2008
Messaggi: 58

libKF5JS5 è installata, ma dice che il file è troppo corto (!)

Ritratto di Grinch
Grinch
(Guru)
Offline
Guru
Iscritto: 05/12/2011
Messaggi: 866

Zypper ve cosa dice ?
Guarda io ho 6 repository con Tumbleweed e se installo pacchetti di terze parti non aggiungo mai il repository da cui provengono .
Potresti provare da Yast a passare tutti i pacchetti al repo oss che è il principale di più non saprei

Ritratto di Ramtaturis
Ramtaturis
(Geek)
Offline
Geek
Iscritto: 24/06/2008
Messaggi: 58

Questo lo ho già fatto. Al momento tutti i pacchetti disponibili sono sotto i repo ufficiali, tranne vlc e sue dipendenze, perché quello di Packman funziona meglio.
Temo che il problema non sia una versione sbagliata di file, ma qualche file di troppo. Ho già provato a cancellare qualsiasi residuo di LibreOffice dopo l'ennesima disinstallazione, ma non mi ha aiutato. Deve esserci qualcosa con un nome non sospetto.
Visto che ci sono altre cose che hanno dei malfunzionamenti, alle quali adesso si è aggiunto anche Okular, sto cominciando a pensare ad un formattone purificatore per poi ricominciare con un uso più attento dei repository.

Ritratto di Grinch
Grinch
(Guru)
Offline
Guru
Iscritto: 05/12/2011
Messaggi: 866

Crea un nuovo utente , cosi verifichi subito se è un problema di file di configurazione

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1685

libreoffice dipende dalle librerie GTK e quello un suo errore.

Prova ad entrare in impostazioni-GTK e cambiare tema

Prova ad re-installare le GTK3 e gtk-3

SO: Linux desktop Sistema: OpenSUSE Leap 15 (32bit) TDE 4 / Mate
SO: Linux desktop Sistema: OpenSUSE Leap 15 (64bit) KDE 5
Miao

Ritratto di Ramtaturis
Ramtaturis
(Geek)
Offline
Geek
Iscritto: 24/06/2008
Messaggi: 58

Rispondo ad entrambi:
Ho creato un nuovo utente
Ho cambiato tema con gnome-tweak-tool
Ho reinstallato con yast (aggiorna incondizionatamente) tutti i pacchetti contenenti GTK3 e gtk-3

Nessun risultato

PS nel frattempo è uscito un aggiornamento di libKF5JS5 che ha risolto il problema con Okular

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1685

strano.... Thinking

prova da terminale come root

zypper ve

Che male non fa (verifica le dipendenze se ci son tutte)

Anche un
zypper inr

Che carica eventuali aggiornamenti dei pacchetti già istallati

SO: Linux desktop Sistema: OpenSUSE Leap 15 (32bit) TDE 4 / Mate
SO: Linux desktop Sistema: OpenSUSE Leap 15 (64bit) KDE 5
Miao

Ritratto di Ramtaturis
Ramtaturis
(Geek)
Offline
Geek
Iscritto: 24/06/2008
Messaggi: 58

zypper ve ha disinstallato un file di documentazione
zypper inr non ha fatto niente

Nessun miglioramento

Ritratto di Ramtaturis
Ramtaturis
(Geek)
Offline
Geek
Iscritto: 24/06/2008
Messaggi: 58

Dopo giorni di tentativi andati a vuoto, ho finalmente risolto.

Mauriziod aveva correttamente individuato il problema nelle gtk-3, suggerendomi di reinstallarle, ma non era servito.

Ho risolto invece disinstallando (e non reinstallando) il pacchetto "libreoffice-gtk3"
L'aspetto grafico è piuttosto diverso, ma funziona.
Se poi installo "libreoffice-gtk2" recupero anche la grafica a cui sono abituato.

Grazie a tutti quelli che mi hanno aiutato

Ritratto di carmalao
carmalao
(Geek)
Offline
Geek
Iscritto: 06/01/2009
Messaggi: 97

Buongiorno.
Mi aggancio a questo vecchio topic poiché da un paio di giorni ho un problema simile. Cercando di aprire gli ODS LibreOffice 6.1.3.2 va in crash immediatamente.
Tutto sembra cominciato quando ho installato il driver proprietario di una Lexmark MS510dn.
Ho una Leap 15.0 con Kernel 4.12.14 default.
Ho letto tutto il topic e non ho nulla di libreoffice-gtk2 o 3 in Yast. Ho lasciato solo i repo ufficiali ed eliminato gli altri.
Mi aiutate per favore? Grazie

P.S.: nel frattempo ho eliminato i PPD della Lexmark e disinstallato la stampante relativa, visto che comunque LibreOffice apriva xls o odt ma andava in crash selezionando solo quella stampante, non le altre di rete.

P.S.2: nel frattempo, sempre leggendo in giro, ho disabilitato OpenCL e riavviato LibreOffice. Ora apre gli ods. Provo a reinstallare i PPD e la stampante. Ah, non è più in italiano...

P.S.3: reinstallato i PPD e la stampante e anche se di rete con IP, YAST la mette poi come locale. Ovviamente LibreOffice va in crash quando seleziono questa stampante per la stampa. Ma almeno funziona in apertura ora... idee?

P.S.4: allora, LibreOffice va in crash con la stampante Lexmark ovvero con i driver PPD proprietari. Con il driverless del sistema, funziona. Grazie ugualmente.