Macchina Virtuale

97 risposte [Ultimo messaggio]
Ritratto di Eulero
Eulero
(Geek)
Offline
Geek
Iscritto: 31/03/2013
Messaggi: 54

Ciao a tutti,

Ho scaricato da poco la nuova versione di Backtrack Kali... purtroppo non riesco ad avviarla su macchina virtuale senza prima masterizzarla su CD o installarla su pennetta USB! Poichè avevo la vecchia versione di Backtrack 5 su CD ho provato ad usare la macchina virtuale con quella ma mi dà questo errore:

this kernel stay connected an x86-64 CPU but only detected an i686 CPU. Unable to boot. Please use a kernel appropriate for your CPU

Ho letto un pò di cose di Google ma la cosa strana che se avvio il pc con il cd funziona alla grande mentre la macchina virtuale mi dà questo errore! Allora ho pensato di scaricare Backtrack 5 a 32 bit per macchina virtuale ma quando lo vado a spacchettare mi dà errore... Quindi vorrei chiedervi due cose:

1) Come risolvo questo errore?

2) E' possibile avviare Backtrack Kali con macchina virtuale senza dover masterizzare un CD?

Grazie

Filippo

Ritratto di greywolf82
greywolf82
(Monster)
Offline
Monster
Iscritto: 07/07/2008
Messaggi: 240

Che usi per la macchina virtuale? VirtualBox? Da quello che so, è possibile usare con le ultime versioni di VirtualBox una versione a 64 bit su un SO a 32bit host, solo se la CPU ha abilitato da bios le estensioni per la virutalizzazione (se disponibili). E comunque sempre Forza Roma Smile

Ritratto di Eulero
Eulero
(Geek)
Offline
Geek
Iscritto: 31/03/2013
Messaggi: 54

greywolf82 ha scritto:

Che usi per la macchina virtuale? VirtualBox? Da quello che so, è possibile usare con le ultime versioni di VirtualBox una versione a 64 bit su un SO a 32bit host, solo se la CPU ha abilitato da bios le estensioni per la virutalizzazione (se disponibili). E comunque sempre Forza Roma Smile

Si uso VirtualBox (Oracle VM)... come faccio ad usare una versione a 64 bit su un SO a 32 bit? Perchè ora sono riuscito a far partire la macchina senza CD così: dall'opzione 'Generale' nella parte destra della finestra Manager ho apportartato le modifiche necessarie poi ho selezionato l'opzione di archiviazione per collegare il Kali immagine ISO Linux. Nella finestra Albero Archiviazione ho selezionato il controller CD-Rom poi all'interno del riquadro Attributi ho inserito il mio file ISO (ovviamente con Kali mi dà errore mentre con la vecchia versione parte ma si blocca sul loading dopo che ho avviato la macchina...).

Non so proprio come fare...

Grazie

DAJE ROMA DAJE

Ritratto di greywolf82
greywolf82
(Monster)
Offline
Monster
Iscritto: 07/07/2008
Messaggi: 240

Come ti ho detto devi abilitare le estensioni per la virtualizzazione nelle impostazioni della macchina virtuale. Queste impostazioni (sotto Processore/Accelerazione trovi "Abilita VT-x/AMD-V"), però, si basano sul fatto che il processore supporta queste estensioni e sono abilitate nel bios.

Ritratto di Eulero
Eulero
(Geek)
Offline
Geek
Iscritto: 31/03/2013
Messaggi: 54

greywolf82 ha scritto:

Come ti ho detto devi abilitare le estensioni per la virtualizzazione nelle impostazioni della macchina virtuale. Queste impostazioni (sotto Processore/Accelerazione trovi "Abilita VT-x/AMD-V"), però, si basano sul fatto che il processore supporta queste estensioni e sono abilitate nel bios.

Si infatti ci ho provato ma nelle impostazioni della macchina virtuale che ho installato non ho Processore/Accelerazione con "Abilita VT-x/AMD-V" ma ho olamente "Abilita PAE/NX" e nella BIOS non ho nessuna scritta che mi supporti queste estensioni... Devo reinstallare la macchina virtuale?

Grazie ancora

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2730

https://sites.google.com/site/norfeodf/guide-opensuse-linux/installazione-programmi/virtualbox

SUSE Tumbleweed- kernel-5.3.12-1.2- kde-plasma-5.17.3.1- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.132.51- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di Eulero
Eulero
(Geek)
Offline
Geek
Iscritto: 31/03/2013
Messaggi: 54

dragoncello ha scritto:

https://sites.google.com/site/norfeodf/guide-opensuse-linux/installazione-programmi/virtualbox

Grazie Dragoncello,

ma questo sito lo avevo già consultato e ho installato tutti i pacchetti che chiedeva e dovo essermi loggato come superutente mi appare:

nbfilippo:/home/filippo # /etc/init.d/vboxdrv setup
Recompiling VirtualBox vboxadd kernel module, NOT. It has been packaged. done
nbfilippo:/home/filippo #

Allora ho eseguito le istruzione come dal link:

Ora virtualbox è pienamente funzionante, se non lo fosse controllare se il proprio utente ha acquisito il gruppo "vboxusers":
1- Avviare Yast
2- selezionare "Sicurezza e utenti"
3- selezionare "Gestione di utenti e gruppi"
4- evidenziare il proprio utente e premere il pulsante "Modifica"
5- andare su "Dettagli" e selezionare "vboxusers"
6- premere "OK" e nuovamente "OK" per uscire
7- Disconnettere l'utente e riconnetterlo oppure riavviare il PC

ma la macchina virtuale non va e mi dà lo stesso errore... Poi ho provato a cambiare le credenziali come mi è stato suggerito ma non ho la possibilità di cambiarle!

Suggerimenti?

Grazie ancora

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2730

Eulero ha scritto:

dragoncello ha scritto:

https://sites.google.com/site/norfeodf/guide-opensuse-linux/installazione-programmi/virtualbox

Grazie Dragoncello,

ma questo sito lo avevo già consultato e ho installato tutti i pacchetti che chiedeva e dovo essermi loggato come superutente mi appare:

nbfilippo:/home/filippo # /etc/init.d/vboxdrv setup
Recompiling VirtualBox vboxadd kernel module, NOT. It has been packaged. done
nbfilippo:/home/filippo #

Allora ho eseguito le istruzione come dal link:

Ora virtualbox è pienamente funzionante, se non lo fosse controllare se il proprio utente ha acquisito il gruppo "vboxusers":
1- Avviare Yast
2- selezionare "Sicurezza e utenti"
3- selezionare "Gestione di utenti e gruppi"
4- evidenziare il proprio utente e premere il pulsante "Modifica"
5- andare su "Dettagli" e selezionare "vboxusers"
6- premere "OK" e nuovamente "OK" per uscire
7- Disconnettere l'utente e riconnetterlo oppure riavviare il PC

ma la macchina virtuale non va e mi dà lo stesso errore... Poi ho provato a cambiare le credenziali come mi è stato suggerito ma non ho la possibilità di cambiarle!

Suggerimenti?

Grazie ancora


Da yast installa dkms,poi apri la shell e come root dai:
/etc/init.d/vboxdrv setup
invio.
ciao

SUSE Tumbleweed- kernel-5.3.12-1.2- kde-plasma-5.17.3.1- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.132.51- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di Eulero
Eulero
(Geek)
Offline
Geek
Iscritto: 31/03/2013
Messaggi: 54

dragoncello ha scritto:

Eulero ha scritto:

dragoncello ha scritto:

https://sites.google.com/site/norfeodf/guide-opensuse-linux/installazione-programmi/virtualbox

Grazie Dragoncello,

ma questo sito lo avevo già consultato e ho installato tutti i pacchetti che chiedeva e dovo essermi loggato come superutente mi appare:

nbfilippo:/home/filippo # /etc/init.d/vboxdrv setup
Recompiling VirtualBox vboxadd kernel module, NOT. It has been packaged. done
nbfilippo:/home/filippo #

Allora ho eseguito le istruzione come dal link:

Ora virtualbox è pienamente funzionante, se non lo fosse controllare se il proprio utente ha acquisito il gruppo "vboxusers":
1- Avviare Yast
2- selezionare "Sicurezza e utenti"
3- selezionare "Gestione di utenti e gruppi"
4- evidenziare il proprio utente e premere il pulsante "Modifica"
5- andare su "Dettagli" e selezionare "vboxusers"
6- premere "OK" e nuovamente "OK" per uscire
7- Disconnettere l'utente e riconnetterlo oppure riavviare il PC

ma la macchina virtuale non va e mi dà lo stesso errore... Poi ho provato a cambiare le credenziali come mi è stato suggerito ma non ho la possibilità di cambiarle!

Suggerimenti?

Grazie ancora


Da yast installa dkms,poi apri la shell e come root dai:
/etc/init.d/vboxdrv setup
invio.
ciao

Ho installato dkms e quando digito il comando che mi hai dato da superutente mi ridà

nbfilippo:/home/filippo # /etc/init.d/vboxdrv setup
Recompiling VirtualBox vboxadd kernel module, NOT. It has been packaged. done
nbfilippo:/hom
e/filippo #

Non so proprio come fareeeeeeeee!

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2730

Installato kernel-devel,fai cosi apri yast gestioni pacchetti,in alto a sinistara visualizza,nel menu a tendina apri modelli,e spunta le caselle Sviluppo base e sviluppo in C/C++,poi sempre da yast cerca kernel,e installi il tuo kernel-default-devel,o desktop,a seconda del tuo kernel.

SUSE Tumbleweed- kernel-5.3.12-1.2- kde-plasma-5.17.3.1- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.132.51- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di Eulero
Eulero
(Geek)
Offline
Geek
Iscritto: 31/03/2013
Messaggi: 54

dragoncello ha scritto:

Installato kernel-devel,fai cosi apri yast gestioni pacchetti,in alto a sinistara visualizza,nel menu a tendina apri modelli,e spunta le caselle Sviluppo base e sviluppo in C/C++,poi sempre da yast cerca kernel,e installi il tuo kernel-default-devel,o desktop,a seconda del tuo kernel.

Si ci avevo già provato ma in "Gestione Pacchetti" mi dà errore perchè mi dice che PackegaKit è in esecuzione e non si può interrompere se non interrompo Yast!