Nuove patch per Zen

Ritratto di Ryoma
Ryoma
(Geek)
Offline
Geek
Iscritto: 31/05/2005
Messaggi: 149

Ciao a tutti Smile

Personalmente appena ho installato la 10.1 (3-4giorni fa) ho disabilitato dalla system tray Zen (l'cona a froma di mappamodno se non erro)

Adesso vorrei riattivarla e provare queste pach di cui parlava ap1978 ma non so come riattivarlo

inoltre sotto yast qual'è Zen??
Se non erro nella 10.0 non eisteva "Gestione pacchetti" è lui Zen??

Grazie mille

Ciao

Ryoma Laughing

Ritratto di ap1978
ap1978
(Guru)
Offline
Guru
Iscritto: 01/10/2004
Messaggi: 2972

Quote:

Ryoma ha scritto:
Ciao a tutti Smile

Personalmente appena ho installato la 10.1 (3-4giorni fa) ho disabilitato dalla system tray Zen (l'cona a froma di mappamodno se non erro)

Adesso vorrei riattivarla e provare queste pach di cui parlava ap1978 ma non so come riattivarlo

Se hai solo disattivato l'icona nella barra dell'orologio, vai in Sistema -> Configurazione -> Software di installazione

Dovrebbe riavviarsi Zen. Fai click con il tasto destro e scegli Configure. Nella scheda Preferences, metti la spunta sulla casella.

Quote:

inoltre sotto yast qual'è Zen??
Se non erro nella 10.0 non eisteva "Gestione pacchetti" è lui Zen??

Zen è indipendente da Yast. Nessuna icona di Yast corrisponde a Zen. Gestione pacchetti è il vecchio Aggiungi/Rimuovi pacchetti.

Ciao

ap Big Grin

Ritratto di Ryoma
Ryoma
(Geek)
Offline
Geek
Iscritto: 31/05/2005
Messaggi: 149

Ciao ap1978 Smile

scusami ma c'è sempre quello che tardo a capire Smile

Ho riavviato Zen ed è tutto ok

Quello che non ho capito è sequesto repository ftp://ftp.suse.com/pub/people/aj/10.1-packagemanagement-update-test
devo inserirlo in yast oppure in zen
L'ho aggiunto in Yast e andando su gestione pacchetti ho installato come da te scritto

autoyast2
libzypp
libzypp-zmd-backend
ruby-zypp
rug
suseRegister
yast2
yast2-installation
yast2-instserver
yast2-ncurses
yast2-online-update
yast2-packager
yast2-perl-bindings
yast2-pkg-bindings
yast2-qt
zen-updater
zmd

Dovevo farlo con Zen??

Il problema è che se adesso vado in yast e clicco su gestione pacchetti non si apre nulla
Se vado su Zen Software di installazione resta fermo ore si "Getting install list..."

Potresti aiutarmi a capire dove ho sbaglaito

Grazie mille anticipate

Ciao

Ryoma Laughing

Ritratto di ap1978
ap1978
(Guru)
Offline
Guru
Iscritto: 01/10/2004
Messaggi: 2972

Aggiungere un catalogo a Zen o a Yast è indifferente. La guida di Andreas Jaeger diceva di farlo con Yast, quindi hai fatto bene.

E' normale che resti fermo un po' sulla fase di aggiornamento, perché le patch hanno cancellato i metadati dei cataloghi e Zen deve scaricarli di nuovo.

Il fatto che non si apra nulla quando clicchi su Gestione Pacchetti non è chiaro. Probabilmente è perché il db dei pacchetti è in uso da Zen.

Ciao

ap Big Grin

Ritratto di Ryoma
Ryoma
(Geek)
Offline
Geek
Iscritto: 31/05/2005
Messaggi: 149

Ciao ap1978 Smile

Una volta effettuato l'aggiornamento delle patch posso aggiungere i repository presi da opensuse
http://en.opensuse.org/Additional_YaST_Package_Repositories
se si devo aggiungerli in Yast o in Zen??

Se è indifferenze uso Zen così comincio a capire come funziona

Ultima domanda per capire se un server funziona o no da repository devo sempre trovare i file content e directory.yast??

te lo chiedo perchè se aggiungo questo repository in Zen
ftp://ftp.gwdg.de/pub/linux/misc/suser-guru/rpm/10.1
mi da errore se lo faccio in Yast va tutto ok
Se dopo averlo aggiunto il Yast vado su Zen; sorpresa lo hacaricato in automatico da yast e funziona

Grazie mille

Ciao
Ryoma Laughing

Ritratto di umountbrain
umountbrain
(Guru)
Offline
Guru
Iscritto: 15/01/2005
Messaggi: 611

Che dire: ho appena installto le patch e zen mi ha trovato molti update (a dire il vero era parecchio che non lo avviavo!).
Devo ammettere che ora funziona bene, mi pare molto più veloce e anche nell'installazione delle patch non ha dato problemi di lentezza o altro.

Siamo sulla buona strada.

Ritratto di alessioo
alessioo
(Newbie)
Offline
Newbie
Iscritto: 07/06/2006
Messaggi: 3

ciao,
niente da fare zen non ne vuole sapere di funzionare.
Ho installato tutte le patch
autoyast2
libzypp
libzypp-zmd-backend
ruby-zypp
rug
suseRegister
yast2
yast2-installation
yast2-instserver
yast2-ncurses
yast2-online-update
yast2-packager
yast2-perl-bindings
yast2-pkg-bindings
yast2-qt
zen-updater
zmd

ma quando zen fai il controllo degli aggiornamenti ne trova solo 1
dhcp(noarch)
se lancio update
mi da

Dependency Resolution Failed
Unknown failure

Cosa sbaglio?? grazie

Ritratto di umountbrain
umountbrain
(Guru)
Offline
Guru
Iscritto: 15/01/2005
Messaggi: 611

Io ho installato da yast le patch. Quindi ho avviato zen-updater che però mi diceva che lo zmd era fermo. Avviato da root pure quello e successivamente zen-updater, ha fatto il controllo dei cataloghi in modo veloce (occupando la cpu per brevissimo tempo) e mi ha dato se ricordo bene 24 update (patch). Installate.
Tutto a posto.
Ora, ho zen-updater sempre avviato per le patch, smart per la gestione dei pacchetti via internet, yast per i pacchetti su dvd e ksmarttray l'ho disabilitata al momento, tanto non mi serve.
Ora se tutto continuerà ad andare bene penso di aver trovato la gestione ottimale.

Ciao

Ritratto di ap1978
ap1978
(Guru)
Offline
Guru
Iscritto: 01/10/2004
Messaggi: 2972

Quote:

umountbrain ha scritto:
Ora, ho zen-updater sempre avviato per le patch, smart per la gestione dei pacchetti via internet, yast per i pacchetti su dvd e ksmarttray l'ho disabilitata al momento, tanto non mi serve.
Ora se tutto continuerà ad andare bene penso di aver trovato la gestione ottimale.

Wow! Se preferisci, i pacchetti su DVD sono gestiti anche da Zen installer, che spesso ci mette meno di Yast ad installare, perché non devi aspettare che si carichi.

Mi piace l'idea di usare smart per i repository aggiuntivi, in modo da evitare che Zen si affolli di patch non ufficiali.

Ciao

ap Big Grin

Ritratto di umountbrain
umountbrain
(Guru)
Offline
Guru
Iscritto: 15/01/2005
Messaggi: 611

Quote:

ap1978 ha scritto:

Wow! Se preferisci, i pacchetti su DVD sono gestiti anche da Zen installer, che spesso ci mette meno di Yast ad installare, perché non devi aspettare che si carichi.

Mi piace l'idea di usare smart per i repository aggiuntivi, in modo da evitare che Zen si affolli di patch non ufficiali.

Ciao

Esatto, smart funziona da dio e quindi va benissimo per l'installazione. Ora anche zen mi sembra andar bene e quindi per gli update è ok.
Praticamente ho ristabilito la situazione delle suse precedenti (solo che prima usavo you per le patch e apt per il software aggiuntivo).

Se dici che va anche meglio di yast lo provo e se mi gusta riabilito i cataloghi per il dvd.

Ciao