openSUSE non si avvia correttamente dopo l'aggiornamento con tumbleweed

5 risposte [Ultimo messaggio]
Ritratto di Oms
Oms
(Newbie)
Offline
Newbie
Iscritto: 22/05/2013
Messaggi: 2

Ciao,
oggi ho messo la 12.3 e poi ho subito inserito i repo tumbleweed, seguendo e confrontando le più accurate guide in italiano ed in inglese in merito. Aggiorno con zypper dup e tutto procede bene (416 aggiornamenti). Al riavvio però non parte X/gdm, insomma si blocca a:
[ OK ] Reached target grpahical interface (o roba simile), lo schermo lampeggia e tutto rimane fermo lì. Ho provato a fare qualcosa in una shell ma non ho combinato molto. Con startx parte x e subito dopo si chiude.
Come fare?
Grazie

Ritratto di Grinch
Grinch
(Guru)
Offline
Guru
Iscritto: 05/12/2011
Messaggi: 892

Party erroreeeeeeeeee

Ritratto di Grinch
Grinch
(Guru)
Offline
Guru
Iscritto: 05/12/2011
Messaggi: 892

Dalla shell ridai zypper dup .

Poi rm -rf .gnome .gnome2 .gconf .gconfd .config

riboot

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1761

Note d'uso per il futuro:

Sappiamo che siete presi dal panico!!! Nail Biting

Ma diteci che errore, il più dettagliato possibile, riporta e come avete settato la macchina (versione Suse, KDE/Gnome/ecc., driver scheda video, ecc..) dato che non abbiamo i super-poteri o palle di cristallo. On The Phone

Può capitare che vi diciamo di fare cose SOLO perchè pensiamo che avete una certa configurazione e capita di sbagliarci perchè VOI non l'avete!

Siete pregati di scrivere il più possibile almeno in più di 300 parole il vostro errore. In cinque righe, insomma è un guaio!!!

----

Non usare zypper dup , ma zypper up che è meglio! Il perchè è spiegato qui.

Citazione:


zypper dup aggiorna tutti i pacchetti alla versione disponibile nel repository.. quindi se tu hai installato il pacchetto ciao-1.0-11.1.rpm ma nei tui repository esiste però ciao-1.0-1.1.rpm allora "dup" fa il downgrade alla versione + alta presente nei repository

zypper up (che io uso sempre con l'opzione '-t package') aggiorna ad una nuova versione punto e basta, quindi ritornando all'esempio precedente il pacchetto ciao rimane invariato

che più... ah si.. l'atteggiamento di zypper dup è utile appunto quando si vuole fare un aggiornamento dell'intera distro e si vuole essere sicuri di non avere pacchetti "sfusi"

Salvo il fatto che avete Apper o Yast che lo fa per voi ed è più sicuro!!!

SO: Linux desktop Sistema: OpenSUSE Leap 15.1 (64bit) KDEE 5.12
SO: Linux desktop Sistema: OpenSUSE Tumbleweed (64bit) KDE 5
Miao

Ritratto di Grinch
Grinch
(Guru)
Offline
Guru
Iscritto: 05/12/2011
Messaggi: 892

Citazione:

Non usare zypper dup , ma zypper up che è meglio!

Chi lo ha detto ? http://it.opensuse.org/Portal:Tumbleweed

Se vuoi passare alla Tumbleweed devi usare zypper dup o meglio zypper dup --from Tumbleweed , altrimenti non avrai la Tumbleweed , ma una ibrida .

Citazione:

Al riavvio però non parte X/gdm, insomma si blocca

Se parla di Gdm dovrebbe avere Gnome no!

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1761

Grinch ha scritto:

Citazione:

Non usare zypper dup , ma zypper up che è meglio!

Chi lo ha detto ? http://it.opensuse.org/Portal:Tumbleweed

Se vuoi passare alla Tumbleweed devi usare zypper dup o meglio zypper dup --from Tumbleweed , altrimenti non avrai la Tumbleweed , ma una ibrida .

Dice, testuali parole, di avere già messo la 12.3 e che non è che sta passando da un'altra versione! Se Tumbleweed NON usare zypper dup ma SOLO zypper dup --from Tumbleweed oppure (dato che è aggiornamento dei software) zypper up.

Il discorso iniziale era generale...

SO: Linux desktop Sistema: OpenSUSE Leap 15.1 (64bit) KDEE 5.12
SO: Linux desktop Sistema: OpenSUSE Tumbleweed (64bit) KDE 5
Miao