pacchetto

8 risposte [Ultimo messaggio]
Ritratto di The_Silence
The_Silence
(Junior)
Offline
Junior
Iscritto: 20/09/2012
Messaggi: 10

Scusate,
il pacchetto gnome-python2-gnome si trova per openSuSe? volevo installare Jupiter solo che richiede quel pacchetto e non sono riuscito a trovarlo, mi sapreste dire se si trova?
Grazie mille! =)

"Hello darkness, my old friend, I've come to talk with you again"

Ritratto di aksaf
aksaf
(Guru)
Offline
Guru
Iscritto: 08/03/2011
Messaggi: 957

ho cercato il pacchetto direttamente nel build service di opensuse https://build.opensuse.org/search ma non l'ho trovato (meglio ho visto solo pacchetti funzionanti per altre distribuzioni) quindi probabilmente stai installando un rpm generico o per qualche altra distribuzione?
Penso in ogni caso che l'equivalente del pacchetto che dici dovrebbe chiamarsi python-gnome. Dopo averlo installato tieni comunque conto che dovrai comunque forza l'rpm di jupiter quando yast te lo chiederà mentre installi il pacchetto, e, non avendo usato il pacchetto, non so se poi il programma funzionerà senza ulteriori interventi, se non funzionerà proprio, o se ci saranno problemi.

Ritratto di The_Silence
The_Silence
(Junior)
Offline
Junior
Iscritto: 20/09/2012
Messaggi: 10

Il pacchetto di jupiter che sto installando è: jupiter-0.1.4-1.noarch.rpm e durante l'instalazione si blocca e richiede quel pacchetto, python-gnome già c'è..

"Hello darkness, my old friend, I've come to talk with you again"

Ritratto di aksaf
aksaf
(Guru)
Offline
Guru
Iscritto: 08/03/2011
Messaggi: 957

Non tutte le distribuzioni chiamano i pacchetti allo stesso modo. Le "cose" dentro al pacchetto che indichi dovresti già averle sulla tua openSUSE, se usi GNOME. Quindi, secondo me, puoi scegliere tra queste 3 opzioni

  1. Installi il file rpm di jupiter lo stesso, quando yast ti presenta le due opzioni, selezioni la seconda, quella che inizierà con con "danneggiare jupiter..."
  2. aspetti che nel build service di openSUSE forniscano il pacchetto per openSUSE (per la tua versione), qualche progetto in merito ho visto che c'è, ma non ci sono ancora rpm disponibili
  3. opti per un'altra applicazione analoga, se non sbaglio jupiter serve ad impostare la frequenza della cpu, non conosco molto GNOME (e conosco soltanto la spartane applet per il pannello che mostra frequenza della cpu e profili da selezionare, nulla di più), ma mi pare che ci siano delle estensioni per GNOME Shell per controllare manualmente la cpu, prova a cercare qui http://software.opensuse.org/search?q=extension e qui https://extensions.gnome.org/

Ritratto di The_Silence
The_Silence
(Junior)
Offline
Junior
Iscritto: 20/09/2012
Messaggi: 10

ok grazie mille!=)
Mo vedrò come fare, comunque penso che aspetterò che escano per openSUSE sennò vedremo =)..
Grazie mille comunque.

"Hello darkness, my old friend, I've come to talk with you again"

Ritratto di aksaf
aksaf
(Guru)
Offline
Guru
Iscritto: 08/03/2011
Messaggi: 957

Scusa non avevo visto il tuo profilo ^_^'
allora, per quel poco che ci capisco come avrai visto anche tu qui (http://www.jupiterapplet.org/downloads.html) l'ultima versione dell'rpm è per Fuduntu che se non sbaglio è una specie di derivata di Fedora (?) i suoi pacchetti rpm *dovrebbero* essere compatibili con quelli di openSUSE ma non ci metterei un micron di unghia sul fuoco XD soprattutto se si troatta di servizi di sistema.
Mi spiace, ciao.

Ritratto di The_Silence
The_Silence
(Junior)
Offline
Junior
Iscritto: 20/09/2012
Messaggi: 10

ahahah tranquillo non ti preoccupare, ci mancherebbe altro! =)
Comunque ho provato ad installarlo solo che mi da lo stesso problema, gli manca sempre quel pacchetto!

"Hello darkness, my old friend, I've come to talk with you again"

Ritratto di aksaf
aksaf
(Guru)
Offline
Guru
Iscritto: 08/03/2011
Messaggi: 957

Certo l'errore di dipendenza mancante in fase di installazione è inevitabile, ma poi l'applet funziona?
Prova a lanciare da terminale jupiter e controlla eventuali errori nell'output, magari basta installare una libreria.
Se il programma non esiste prova a vedere il contenuto del pacchetto da yast > gestione pacchetti, per esempio se c'è qualche file in /usr/bin o /percorso/bin e a lanciarlo da terminale.

P.S.: scusa il ritardo nel rispondere, mi sono perso l'avviso nella mail, se mai è arrivato Smile

Ritratto di The_Silence
The_Silence
(Junior)
Offline
Junior
Iscritto: 20/09/2012
Messaggi: 10

No non funziona, praticamente arresta l'installazione..Quindi non risulta presente; non l'ho trovato presente in Yast.
Non ti preoccupare, ci mancherebbe altro =)

"Hello darkness, my old friend, I've come to talk with you again"