perche non mi installa il programma?

6 risposte [Ultimo messaggio]
Ritratto di daniloferrarott
Offline
Geek
Iscritto: 29/09/2007
Messaggi: 126

ciao a tutti,
ho provato ad installare un programma dai sorgenti: ho seguito la procedura del makefile: -/configure make make install . tutto semnra andare per il meglio solo che alla fine non trovo nelle applicazioni il programma da aprire e utilizzare. Invece con i file .rpm ho installato tramite yast e nelle applicazioni si trova il programma. Ho sbagliato nell'installazioni da sorgenti? vorrei imparare nel caso non trovassi .rpm disponibili, e come tentativo non è proprio andato a buon fine...

grazie mille della collaborazione

Danilo

Ritratto di anubis
anubis
(Guru)
Offline
Guru
Iscritto: 07/04/2007
Messaggi: 3656

quasi sicuramente chi ha fatto l'rpm ha inserito anche una icona per il menù..tutto qui! Wink

OpenSUSE Member,Packman Packager, Education Project Admin, LXDE Project Admin
Powered by http://en.opensuse.org/HP_Pavilion_dv6855el

Ritratto di daniloferrarott
Offline
Geek
Iscritto: 29/09/2007
Messaggi: 126

invece se avessi voluto fare da shell con i comandi che ho utilizzato come avrei potuto aprire il programma e magari metterlo nel menu?

ciao

Danilo

Ritratto di Mirko
Mirko
(Guru)
Offline
Guru
Iscritto: 19/12/2005
Messaggi: 1602

Click destro sull'icona del menù -> Editor menù
Scegli dove mettere il programma e poi clicchi su "nuova voce".

Scegli l'icona e stabilisci il comando che farà partire il programma Smile

Ritratto di daniloferrarott
Offline
Geek
Iscritto: 29/09/2007
Messaggi: 126

ciao, non mi è molto chiaro la parte del comando per far partire il programma, è uno in particolare dopo aver fatto eseguire il make install, come posso riconoscere tale comando?non sono molto epserto come puoi notare..

grazie

D

Ritratto di Maxwell
Maxwell
(Monster)
Offline
Monster
Iscritto: 10/06/2006
Messaggi: 323

allora...cerco di spiegare...nei pacchetti rpm (più o meno l'equivalente degli exe di win) molto spesso c'è già il collegamento e viene installato anche quello e messo sul tuo desk..quando invece lo compili a mano (ovvero ./configure,make & make install) spesso questo collegamento non c'è...quindi o avvii tutte le volte il programma da shell (utiligganzo la compilazione automatica del tasto tab) o se sai la sintassi esatta puoi eseguire il programma digitandolo nella finestra premendo Alt+F2 oppure creandoti tu il collegamento sul desktop o nel menù k.
Nel desk lo crei facendo tasto dx->link to application
nel menù avvio tasto dx sul geko->editor menù

spero sia chiaro

ciao ciao
Max

Ritratto di Mirko
Mirko
(Guru)
Offline
Guru
Iscritto: 19/12/2005
Messaggi: 1602

Quote:

daniloferrarott ha scritto:
ciao, non mi è molto chiaro la parte del comando per far partire il programma, è uno in particolare dopo aver fatto eseguire il make install, come posso riconoscere tale comando?non sono molto epserto come puoi notare..

grazie

D

Beh, dovresti andare a vedere nella cartella dove hai installato il programma. Solitamente è sempre il nome del programma

KNetworkManager -> knetworkmanager
ndiswrapper -> ndiswrapper

Apri il terminale, provi a inserire l'inizio del nome e premi il tasto tab. Se è giusto, te lo completa in automatico. Ci sono le eccezioni... nel caso non te lo completa, devi andare a spulciare tra le cartelle. Esempio:

Zend Studio -> ZDE (e non zendstudio come si potrebbe pensare, nè zde visto che spesso sono tutti in maiuscolo...)