Problema con gli aggiornamenti automatici

6 risposte [Ultimo messaggio]
Ritratto di rocking_horse
rocking_horse
(Geek)
Offline
Geek
Iscritto: 21/07/2006
Messaggi: 186

Ho grossi guai con l'aggiornamento automatico di Suse..... ecco quello che mi viene fuori:

da che dipende?? (cit. Jarabe de Palo)

openSuse Leap 15.1 - Packard Bell Imedia S Core i3 4 GB RAM - AMD Radeon HD 7350 1GB

Ritratto di SilverHawk
SilverHawk
(Geek)
Offline
Geek
Iscritto: 31/05/2014
Messaggi: 180

I pacchetti transcode e dvdauthor li hai installati a mano o da repository? Se da repository, possibile che siano "artigianali" e quindi non contengono tutte le dipendenze richieste (o almeno, non aggiornate)?

Ritratto di rocking_horse
rocking_horse
(Geek)
Offline
Geek
Iscritto: 21/07/2006
Messaggi: 186

mi sembra strano.... ho sempre seguito tutte le procedure per installare tutte le dipendenze..... il problema è che me lo fa con tutti i pacchetti, anche se gli dico di saltare questi due, mi dà lo stesso errore anche con gli altri

openSuse Leap 15.1 - Packard Bell Imedia S Core i3 4 GB RAM - AMD Radeon HD 7350 1GB

Ritratto di rocking_horse
rocking_horse
(Geek)
Offline
Geek
Iscritto: 21/07/2006
Messaggi: 186

I pacchetti in questione li ho installati da repository; il problema è che le dipendenze che richiedono sono già installate nella versione successiva, per esempio il pacchetto transcode richiede il pacchetto libMagickCore.so.5() ma sul mio computer c'è già installato libMagickCore-6_Q16-1 alla versione 6.8.6.9-2.12.1.
Ho appena scoperto però che tutti gli altri aggiornamenti me li fa senza problemi, mi sono rimasti da aggiornare solo transcode e dvdauthor07, entrambi dal repository ftp.gwdg.de-suse, per i quali mi si presenta il problema descritto

openSuse Leap 15.1 - Packard Bell Imedia S Core i3 4 GB RAM - AMD Radeon HD 7350 1GB

Ritratto di SilverHawk
SilverHawk
(Geek)
Offline
Geek
Iscritto: 31/05/2014
Messaggi: 180

Il problema è proprio quello: i due pacchetti incriminati non sono aggiornati quanto le loro dipendenze. In sostanza zypper ti dice: "i due pacchetti hanno bisogno della versione 5 di ImageMagick, ma non ce l'ho a disposizione; vorrei aggiornarlo, ma non posso".
Quindi hai due possibilità:
1) Tieni le versioni vecchie dei pacchetti da cui transcode & co dipendono
2) Trovi delle versioni di transcode & co più aggiornate (sempre che esistano) così che i pacchetti da cui dipendono possono essere aggiornati senza controindicazioni

Nel caso 2, cerca su software.opensuse.org una versione più recente di transcode e compagnia, e vedi se possono fare al caso tuo.
Facci sapere
Ciao

Ritratto di aksaf
aksaf
(Guru)
Offline
Guru
Iscritto: 08/03/2011
Messaggi: 957

Assicurati di stare installando transcode e soci dal deposito Packman per openSUSE 13.1. Lo puoi anche aggiungere rapidamente con: YaST > Repository dei programmi > Aggiungi > Repository della comunità > spunta Packman ( e libdvdcss che ti sarà utile per vedere i dvd) (rimuovi eventuali versioni del repo Packman installate per rilasci diversi di openSUSE, se presenti)

Ritratto di rocking_horse
rocking_horse
(Geek)
Offline
Geek
Iscritto: 21/07/2006
Messaggi: 186

Risolto: avevo dei repository ancora per la versione 12.3, li ho corretti; ho installato una patch necessaria da yast e poi sono riuscito a installare tutti gli aggiornamenti dei pacchetti da apper.... grazie

openSuse Leap 15.1 - Packard Bell Imedia S Core i3 4 GB RAM - AMD Radeon HD 7350 1GB