problema con installazione programmi

3 risposte [Ultimo messaggio]
Ritratto di ctlweb21
ctlweb21
(Newbie)
Offline
Newbie
Iscritto: 03/10/2006
Messaggi: 2

ciao a tutti! sono nuovo da queste parti, mi sono registrato qui per imparare qualcosa su linux e in particolare suse in modo da riuscire a capirci un pò di più, in modo di essere utile anchio in futuro Smile
dopo giorni di scervellamente nn sono riuscito a capire come risolvere questo problema:
quando scarico dei sorgenti di programmi li estraggo e da shell vado a fare ./configure ad un certo punto dell'operazione, visualizzo il seguente messaggio:

"checking for KDE... configure: error:
in the prefix, you've chosen, are no KDE headers installed. This will fail.
So, check this please and use another prefix!"

qualcuno sa dirmi cosa devo fare? cosa significa?

vi ringrazio anticipatamente x l'attenzione

bye

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

L'errore dice che non sono disponibili (o non trova) gli header di kde. Per risolvere bisogna almeno installare il pacchetto kdebase3-devel ed eventualmente altri pacchetti -devel, se richiesti.

Se sono gia` installati, allora bisogna indicare a configure dove sono, tramite un'opzione che non ricordo ma che puoi trovare con il comando ./configure --help

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde

Ritratto di Cagliostro
Cagliostro
(Monster)
Offline
Monster
Iscritto: 08/02/2006
Messaggi: 237

solitamente i pacchetti da installare in questi casi sono i pacchetti qt e kde3devel..

le dipendenze e i pacchetti aggiuntivi,dovrebbero essere risolti in automatico da yast stesso..fatto questo riprova e dovresti aver risolto tutti i tuoi problemi

Smile

SuSE 10.2 -- Gnome -- KERNEL 2.6.18.2-34-default -- Sempron 3200+ -- Asus M2A-VM -- 1GB RAM

Ritratto di ctlweb21
ctlweb21
(Newbie)
Offline
Newbie
Iscritto: 03/10/2006
Messaggi: 2

ok... stavo cercando di installare quel pacchetto... ma con yast mi dice questa cosa:

Novell.Zenworks.Zmd.Public.ZenException: database disk image is malformed

Server stack trace:

Exception rethrown at [0]:

in <0x006dc> System.Runtime.Remoting.Proxies.RealProxy:PrivateInvoke (System.Runtime.Remoting.Proxies.RealProxy rp, IMessage msg, System.Exception exc, System.Object[] out_args)

:'( è tipo un firewall?