Problema installazione codec multimediali

10 risposte [Ultimo messaggio]
Ritratto di maverick72
maverick72
(Geek)
Offline
Geek
Iscritto: 30/06/2008
Messaggi: 68

Salve, a causa di un problema all'HD ho dovuto reinstallare OS11.
Quando ho provato ha installare i codec multimediali con 1click install yast mi ha dato alcuni errori. Nello specifico non mi ha installato vlc in quanto mi dice che è richiesto libavcodec.so ma che non è possibile fornire questa richiesta.
Stesso problema con libxine1.
Ho visto sul forum che c'è una discussione con il mio stesso problema ma seguendo i consigli che ci sono (praticamente scegliere di sostituire ogni volta che yast lo richiede) a me non ha funzionato.
Avete altri consigli.

P.S.: i repo packman sono abilitati.

Ritratto di wal7er
wal7er
(Guru)
Offline
Guru
Iscritto: 21/09/2007
Messaggi: 572

usa libxine1 e kaffeine tramite yast

HP Pavilion dv5-1110el powered by OpenSUSE 13.2 64bit

http://linuxcounter.net/cert/432576.png

Ritratto di maverick72
maverick72
(Geek)
Offline
Geek
Iscritto: 30/06/2008
Messaggi: 68

provando a fare quello che mi hai detto yast mi dice:
sostituire di sostituire una versione di liboil con un'altra e di sostituire xine lib1 con libxine1, io scelgo di si ma mi entra in un circolo vizioso facendomi sempre le stesse richieste senza mai andare avanti.

Ritratto di wal7er
wal7er
(Guru)
Offline
Guru
Iscritto: 21/09/2007
Messaggi: 572

Quando succedono queste cose è una rottura...
Counque prova a disinstallare, nel caso ce sono gia' installati, vlc, xinelib, libxine1 e poi reinstalla libxine1 e kaffeine.

Sono anni che uso kaffeine + xine (di packman) e va sempre tutto ok.
Ne forum ho visto che molti hanno avito problemi con vlc e il relativo repo.

HP Pavilion dv5-1110el powered by OpenSUSE 13.2 64bit

http://linuxcounter.net/cert/432576.png

Ritratto di maverick72
maverick72
(Geek)
Offline
Geek
Iscritto: 30/06/2008
Messaggi: 68

Facendo quello che mi dici, quando provo ad installare libxine1 ottengo:

provider non installabili:libxine1-codecs-1.1.15-44.pm.0.i586[http:ftp.skynet.be/pub/packman/suse11.0/] libxine1-codecs-1.15-44.pm.0.i686[http:ftp.skynet.be/pub/packman/suse11.0/].

Avrò impostato male i repo?

Ritratto di wal7er
wal7er
(Guru)
Offline
Guru
Iscritto: 21/09/2007
Messaggi: 572

La soluzione è vicina forse sono impostati male i repo

HP Pavilion dv5-1110el powered by OpenSUSE 13.2 64bit

http://linuxcounter.net/cert/432576.png

Ritratto di maverick72
maverick72
(Geek)
Offline
Geek
Iscritto: 30/06/2008
Messaggi: 68

iniziavo a sospettarlo, non tenermi sulle spine però! Big Grin

Ritratto di wal7er
wal7er
(Guru)
Offline
Guru
Iscritto: 21/09/2007
Messaggi: 572

Controlla se l'indirizzo di packman che hai tu
corrisponde a uno di quelli in
http://en.opensuse.org/Additional_YaST_Package_Repositories#Packman

o in alternativa vai su yast -> sorgenti di installazione -> aggiunigi -> sorgenti installazioen della comunità e nell'elecnon ci dovrebbe essere anche packman,
se non compare e' perche' c'e' gia'.
Nel caso di problemi controlla la versone del pacchetto perche' le versioni diverse possono creare incompatibilità

HP Pavilion dv5-1110el powered by OpenSUSE 13.2 64bit

http://linuxcounter.net/cert/432576.png

Ritratto di MatStardust
MatStardust
(Junior)
Offline
Junior
Iscritto: 24/12/2006
Messaggi: 37

io avevo risolto con yast. infatti, rimuovendo xine lib yast mi selezionava automaticamente libxine senza fare storie... il tutto poi funziona...ah, avevo attivivati i repo packman, ma non quelli vlc...

openSUSE 11.1+ KDE 3.5.10 su AMD Athlon XP 2600+ 1GB ram + Nvidia GeForce4 MX Integrated GPU

Ritratto di wal7er
wal7er
(Guru)
Offline
Guru
Iscritto: 21/09/2007
Messaggi: 572

Quindi è tutto risolto adesso. :idea: :idea:

Comunque io continuo a NON usare vlc...

HP Pavilion dv5-1110el powered by OpenSUSE 13.2 64bit

http://linuxcounter.net/cert/432576.png

Ritratto di maverick72
maverick72
(Geek)
Offline
Geek
Iscritto: 30/06/2008
Messaggi: 68

Scusate se non ho risposto prima ma sono stato impegnato con il lavoro.
Ho risolto abilitando i repo VDLAN, ero sicuro fossero abilitati invece o è successo qualcosa o mi sbagliavo.
Grazie a tutti, alla prossima Wink