problema librerie : non si installa libc.so.6

19 risposte [Ultimo messaggio]
Ritratto di giovanniraf
giovanniraf
(Junior)
Offline
Junior
Iscritto: 27/02/2012
Messaggi: 42

salve a tutti
sto cercando di configurare il mio suse ma sono incappato in un problema che google non mi aiuta a risolvere Confused
ho installato openarena però non si apre da menu...
provandolo a reinstallare mi chiede se "non installare openarena" oppure danneggiarlo
a causa di una libreria chiamata libc.so.6

googlando sono arrivato ad un sito con i vari rpm desiderati....provando ad installare l'ultima libreria uscita mi da nuovamente un altro errore in quanto manca la glibc-2.14.....riprovo e mi chiede una versione più vecchia...cosi a ritroso fino a quando arrivati vicino la preistoria mi da questo errore

Citazione:

glibc-profile-2.11.3-12.21.1.x86_64 requires glibc = 2.11.3, but this requirement cannot be provided

come procedo?

p.s. yast mi da la possibilità di danneggiare il file...è sicuro? che rischi comporta fare una cosa del genere?
grazie mille

Ritratto di Andrea85
Andrea85
(Collaboratore)
Offline
Collaboratore
Iscritto: 22/12/2008
Messaggi: 801

Come hai installato openarena?

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1698

Da Yast digiti "openarena" ed esce una versione che si installa senza problemi. Almeno io non ricordo di averne avuti.

Se non compare addiziona il repo "game"
URL: http://download.opensuse.org/repositories/games/openSUSE_Factory/
o "games"
URL: http://download.opensuse.org/repositories/games/openSUSE_12.1/

Comodo anche se installi il repo
http://packman.inode.at/suse/12.1/

SO: Linux desktop Sistema: OpenSUSE Leap 15.1 (64bit) KDEE 5.12
SO: Linux desktop Sistema: OpenSUSE Tumbleweed (64bit) KDE 5
Miao

Ritratto di giovanniraf
giovanniraf
(Junior)
Offline
Junior
Iscritto: 27/02/2012
Messaggi: 42

Citazione:

Da Yast digiti "openarena" ed esce una versione che si installa senza problemi. Almeno io non ricordo di averne avuti.


sisi...ce l'ho pure io...infatti faccio così....
cliccandoci sopra mi esce questa scritta in quanto mancano le librerie....però io il pacchetto glibc l'ho installato...quindi non capisco il problema dov'è

Ritratto di Andrea85
Andrea85
(Collaboratore)
Offline
Collaboratore
Iscritto: 22/12/2008
Messaggi: 801

Cosa ti dicono questi?
zypper wp libc.so.6
ls /lib64/ | grep libc.so

Ritratto di aksaf
aksaf
(Guru)
Offline
Guru
Iscritto: 08/03/2011
Messaggi: 957

Innanzitutto la versione di glibc installata se hai openSUSE 12.1 e non hai installato da pacchetti prelevati in giro o repository strani dovrebbe essere:

Repository: Aggiornamenti per openSUSE 12.1 12.1-1.4
Nome: glibc
Versione: 2.14.1-14.18.1

se non è così verifica di aver lanciato YaST > Aggiornamenti in linea.
Se fosse necessario puoi anche reinstallare il pacchetto da YaST > Gestione pacchetti cerchi glibc lo selezioni e lo segni per l'aggiornamento dal menu visualizzato col clic destro del mouse.
Per scrupolo potresti anche incollare l'elenco dei repo attivati, ottenibile con:
zypper --no-refresh repos -d

ma va bene anche una schermata del modulo di YaST dei repo, naturalmente Smile

Ritratto di giovanniraf
giovanniraf
(Junior)
Offline
Junior
Iscritto: 27/02/2012
Messaggi: 42

Andrea85 ha scritto:

Cosa ti dicono questi?
zypper wp libc.so.6
ls /lib64/ | grep libc.so

facendo cos' mi da

Andrea85 ha scritto:

giovanni@linux-3ngs:~> zypper wp libc.so.6
Recupero dei dati del repository...
Lettura dei pacchetti installati...
S | Nome | Tipo | Versione | Arch | Repository
--+-------------+-----------+----------------+--------+---------------------
i | glibc | pacchetto | 2.11.3-12.21.1 | x86_64 | openSUSE-11.4-Update
v | glibc | pacchetto | 2.11.3-12.19.1 | x86_64 | openSUSE-11.4-Update
v | glibc | pacchetto | 2.11.3-12.17.1 | x86_64 | openSUSE-11.4-Update
v | glibc | pacchetto | 2.11.3-12.15.1 | x86_64 | openSUSE-11.4-Oss
v | glibc | pacchetto | 2.11.3-12.15.1 | x86_64 | openSUSE-11.4-Oss
v | glibc | pacchetto | 2.11.3-12.21.1 | i686 | openSUSE-11.4-Update
v | glibc | pacchetto | 2.11.3-12.19.1 | i686 | openSUSE-11.4-Update
v | glibc | pacchetto | 2.11.3-12.17.1 | i686 | openSUSE-11.4-Update
v | glibc | pacchetto | 2.11.3-12.15.1 | i686 | openSUSE-11.4-Oss
v | glibc | pacchetto | 2.11.3-12.15.1 | i686 | openSUSE-11.4-Oss
v | glibc | pacchetto | 2.11.3-12.21.1 | i586 | openSUSE-11.4-Update
v | glibc | pacchetto | 2.11.3-12.19.1 | i586 | openSUSE-11.4-Update
v | glibc | pacchetto | 2.11.3-12.17.1 | i586 | openSUSE-11.4-Update
v | glibc | pacchetto | 2.11.3-12.15.1 | i586 | openSUSE-11.4-Oss
v | glibc | pacchetto | 2.11.3-12.15.1 | i586 | openSUSE-11.4-Oss
i | glibc-32bit | pacchetto | 2.11.3-12.21.1 | x86_64 | openSUSE-11.4-Update
v | glibc-32bit | pacchetto | 2.11.3-12.19.1 | x86_64 | openSUSE-11.4-Update
v | glibc-32bit | pacchetto | 2.11.3-12.17.1 | x86_64 | openSUSE-11.4-Update
v | glibc-32bit | pacchetto | 2.11.3-12.15.1 | x86_64 | openSUSE-11.4-Oss
v | glibc-32bit | pacchetto | 2.11.3-12.15.1 | x86_64 | openSUSE-11.4-Oss
giovanni@linux-3ngs:~> ls /lib64/ | grep libc.so
libc.so.6

può essere che c'è qualche installazione di troppo??? o_0

allora la cosa mi sembra anomala...ho provato ad installare usando zypper e mi da una cosa del genere

Andrea85 ha scritto:

linux-3ngs:/home/giovanni # zypper in libc.so.6
Recupero dei dati del repository...
Lettura dei pacchetti installati...
'libc.so.6' non è stato trovato nei nomi dei pacchetti. Provo per capacità.
'glibc-32bit' fornice 'libc.so.6' che è già installato.
Risoluzione delle dipendenze dei pacchetti…

Nessuna operazione da eseguire.
linux-3ngs:/home/giovanni # zypper in glibc-32bit
Recupero dei dati del repository...
Lettura dei pacchetti installati...
'glibc-32bit' è già installato.
Nessuno aggiornamento candidato per 'glibc-32bit-2.11.3-12.21.1.x86_64'. La versione più alta disponibile è già installata
Risoluzione delle dipendenze dei pacchetti…

Nessuna operazione da eseguire.
linux-3ngs:/home/giovanni # zypper in openarena
Recupero dei dati del repository...
Lettura dei pacchetti installati...
Risoluzione delle dipendenze dei pacchetti…

Problema: niente fornisce libc.so.6(GLIBC_2.14)(64bit) necessario a openarena-0.8.1-3.62.x86_64
Soluzione 1: non installare openarena-0.8.1-3.62.x86_64
Soluzione 2: Danneggiare openarena ignorando alcune delle sue dipendenze

Scegli tra le soluzioni precedenti per numeno o scegli annulla [1/2/a] (a):

Ritratto di Andrea85
Andrea85
(Collaboratore)
Offline
Collaboratore
Iscritto: 22/12/2008
Messaggi: 801

Beh ma a lui serve la 2.14 mentre tu hai la 2.11, ma mi pare strana tanta differenza, non vorrei che avessi il repository games non per la 11.4, dacci la lista dei repo con il comando che ha scritto aksaf

Ritratto di giovanniraf
giovanniraf
(Junior)
Offline
Junior
Iscritto: 27/02/2012
Messaggi: 42

Citazione:

giovanni@linux-3ngs:~> zypper --no-refresh repos -d
# | Alias | Nome | abilitato | Attualizza | Priorità | Tipo | URI | Servizio
---+-----------------------------------+-------------------------------------------+-----------+------------+----------+--------+------------------------------------------------------------------------------+---------
1 | Packman Repository | Packman Repository | Sì | Sì | 99 | rpm-md | http://packman.inode.at/suse/openSUSE_11.4/ |
2 | download.nvidia.com-opensuse | nVidia Graphics Drivers | Sì | Sì | 99 | rpm-md | ftp://download.nvidia.com/opensuse/11.4/ |
3 | download.opensuse.org-Apps | openSUSE BuildService - GNOME:Apps | Sì | Sì | 99 | rpm-md | http://download.opensuse.org/repositories/GNOME:/Apps/openSUSE_11.4/ |
4 | download.opensuse.org-Education | openSUSE BuildService - Education | Sì | Sì | 99 | rpm-md | http://download.opensuse.org/repositories/Education/openSUSE_11.4/ |
5 | download.opensuse.org-Extra | openSUSE BuildService - KDE:Extra | Sì | Sì | 99 | rpm-md | http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_11.4/ |
6 | download.opensuse.org-Stable | openSUSE BuildService - LibreOffice | Sì | Sì | 99 | rpm-md | http://download.opensuse.org/repositories/LibreOffice:/Stable/openSUSE_11.4/ |
7 | download.opensuse.org-UpdatedApps | openSUSE BuildService - KDE:UpdatedApps | Sì | Sì | 99 | rpm-md | http://download.opensuse.org/repositories/KDE:/UpdatedApps/openSUSE_11.4/ |
8 | download.opensuse.org-games | openSUSE BuildService - Giochi | Sì | Sì | 99 | rpm-md | http://download.opensuse.org/repositories/games/openSUSE_11.4/ |
9 | download.opensuse.org-mozilla | openSUSE BuildService - Mozilla | Sì | Sì | 99 | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_11.4/ |
10 | download.opensuse.org-non-oss | openSUSE-11.4-Non-Oss | Sì | Sì | 99 | yast2 | http://download.opensuse.org/distribution/11.4/repo/non-oss |
11 | download.opensuse.org-oss | openSUSE-11.4-Oss | Sì | Sì | 99 | yast2 | http://download.opensuse.org/distribution/11.4/repo/oss |
12 | download.opensuse.org-webcam | openSUSE BuildService - Driver per webcam | Sì | Sì | 99 | rpm-md | http://download.opensuse.org/repositories/drivers:/webcam/openSUSE_11.4/ |
13 | games | games | Sì | Sì | 99 | rpm-md | http://download.opensuse.org/repositories/games/openSUSE_Factory/ |
14 | kde:extra | kde:extra | Sì | Sì | 99 | rpm-md | http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_12.1/ |
15 | nVidia Graphics Drivers | nVidia Graphics Drivers | Sì | Sì | 99 | rpm-md | ftp://download.nvidia.com/opensuse/11.4/ |
16 | opensuse-guide.org-repo | libdvdcss repository | Sì | Sì | 99 | rpm-md | http://opensuse-guide.org/repo/11.4/ |
17 | packman.inode.at-suse | Packman Repository | Sì | Sì | 99 | rpm-md | http://packman.inode.at/suse/openSUSE_11.4/ |
18 | repo-debug | openSUSE-11.4-Debug | No | Sì | 99 | NONE | http://download.opensuse.org/debug/distribution/11.4/repo/oss/ |
19 | repo-debug-update | openSUSE-11.4-Update-Debug | No | Sì | 99 | NONE | http://download.opensuse.org/debug/update/11.4/ |
20 | repo-non-oss | openSUSE-11.4-Non-Oss | Sì | Sì | 99 | yast2 | http://download.opensuse.org/distribution/11.4/repo/non-oss/ |
21 | repo-oss | openSUSE-11.4-Oss | Sì | Sì | 99 | yast2 | http://download.opensuse.org/distribution/11.4/repo/oss/ |
22 | repo-source | openSUSE-11.4-Source | No | Sì | 99 | NONE | http://download.opensuse.org/source/distribution/11.4/repo/oss/ |
23 | repo-update | openSUSE-11.4-Update | Sì | Sì | 99 | rpm-md | http://download.opensuse.org/update/11.4/

Ritratto di Andrea85
Andrea85
(Collaboratore)
Offline
Collaboratore
Iscritto: 22/12/2008
Messaggi: 801

Ne hai doppi e uno per la 12.1 che dovresti togliere ma non vedo problemi per openarena... non capisco perchè chieda la 2.14 se la maggiore disponibile per os 11.4 (anche sul sito) è la 2.11 Waiting
Prova con zypper in openarena con l'opzione 2 e vediamo che succede.

Ritratto di giovanniraf
giovanniraf
(Junior)
Offline
Junior
Iscritto: 27/02/2012
Messaggi: 42

si è installato.....si è messa un'icona in giochi...ma quando clicco non parte nulla