Problema VLC

15 risposte [Ultimo messaggio]
Ritratto di The Lex
The Lex
(Junior)
Offline
Junior
Iscritto: 16/03/2011
Messaggi: 15

Salve a tutti,

come da titolo, ho un problema con Vlc.

Da qualche giorno, mi è impossibile aprire file mkv e diversi avi.

Ad ogni tentativo (in questo caso mkv) appare il seguente messaggio:

Nessun modulo decodifica appropriato:
VLC non supporta il formato audio o video "h264". Sfortunatamente non c'è modo di risolvere il problema.

Ho provato a reinstallare Vlc ma la cosa non cambia.

Consigli?

PS

Mi accorgo solo ora che non riproduce più nessun tipo di formato video. Parte solo l'audio.

Opensuse FOREVER!!!!!

Opensuse 11.4 64 bit - KDE 4.6 - Sony Vaio FW56J - Ati Mobility Radeon HD 4650

Ritratto di The Lex
The Lex
(Junior)
Offline
Junior
Iscritto: 16/03/2011
Messaggi: 15

Risolto reinstallando tutti i pacchetti.

Scusate il disturbo.

Opensuse FOREVER!!!!!

Opensuse 11.4 64 bit - KDE 4.6 - Sony Vaio FW56J - Ati Mobility Radeon HD 4650

Ritratto di dmenek
dmenek
(Junior)
Offline
Junior
Iscritto: 15/11/2006
Messaggi: 16

ciao,
io non so come si fa. Potresti spiegarmi passo passo ?

L'ho installato ieri ed ho inseritoi repository Packman. Ma quando lo avvio sento solo l'audio e niente video.

Help me please !!!!!!!!!!!!!!!!

thanks

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1761

Installatelo dal SITO di Videolan
Raised Eyebrow

SO: Linux desktop Sistema: OpenSUSE Leap 15.1 (64bit) KDEE 5.12
SO: Linux desktop Sistema: OpenSUSE Tumbleweed (64bit) KDE 5
Miao

Ritratto di dmenek
dmenek
(Junior)
Offline
Junior
Iscritto: 15/11/2006
Messaggi: 16

da neofita ho scaricato il pacchetto vlc.ymp per la versione openSuse 12.2 dal sito e l'ho lanciato. Dopodichè VLC l'ho trovato installato.
Vedo anche installata la chiave ma i numeri non corrispondono a quelli del sito !!! Sono 40 cifre e diverse Sad
Ho ripetuto l'installazione da riga di comando ed ora trovo due repositiry !!!!!!!!!!!!! ma VLC funziona solo l'audio !

Che devo fare ?

Ritratto di greywolf82
greywolf82
(Monster)
Offline
Monster
Iscritto: 07/07/2008
Messaggi: 240

Ho aperto un post qualche giorno fa ma nessuno ha risposto, anche io ho lo stesso problema. Dopo un aggiornamento del primo novembre delle librerie libva, niente più vlc. Ho reinstallato tutto prima da packman poi da videolan, ma ho sempre lo stesso effetto, cioè il video parte ma dopo pochi secondi si blocca.

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1761

@greywolf82

Apri un terminale (esempio Kconsole)e fallo partire da comando sul terminale. Poi posta cosa dice.
Nerd

SO: Linux desktop Sistema: OpenSUSE Leap 15.1 (64bit) KDEE 5.12
SO: Linux desktop Sistema: OpenSUSE Tumbleweed (64bit) KDE 5
Miao

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1761

dmenek ha scritto:

da neofita ho scaricato il pacchetto vlc.ymp per la versione openSuse 12.2 dal sito e l'ho lanciato. Dopodichè VLC l'ho trovato installato.
Vedo anche installata la chiave ma i numeri non corrispondono a quelli del sito !!! Sono 40 cifre e diverse Sad
Ho ripetuto l'installazione da riga di comando ed ora trovo due repositiry !!!!!!!!!!!!! ma VLC funziona solo l'audio !

Che devo fare ?

Ti sei dimenticato di mettere i codec supplementari
http://opensuse-community.org/Restricted_formats/12.2

Poi cosa vuol dire che la cifra è diversa? Non capisco.

L'istallazione dal sito videolan aggiunge un repo di videolan (è sicuro) e quindi non preoccuparti di questo.

SO: Linux desktop Sistema: OpenSUSE Leap 15.1 (64bit) KDEE 5.12
SO: Linux desktop Sistema: OpenSUSE Tumbleweed (64bit) KDE 5
Miao

Ritratto di greywolf82
greywolf82
(Monster)
Offline
Monster
Iscritto: 07/07/2008
Messaggi: 240

 
VLC media player 2.0.3 Twoflower (revision 2.0.2-93-g77aa89e)
[0x80503f0] main libvlc: Esecuzione di vlc con l'interfaccia predefinita. Usa 'cvlc' per utilizzare vlc senza interfaccia.
[0x8548440] freetype spu text error: Breaking unbreakable line
[0x8338110] avcodec decoder error: more than 5 seconds of late video -> dropping frame (computer too slow ?)
[0x8338110] avcodec decoder error: more than 5 seconds of late video -> dropping frame (computer too slow ?)
[0x8338110] avcodec decoder error: more than 5 seconds of late video -> dropping frame (computer too slow ?)

Output di xvinfo:

X-Video Extension version 2.2
screen #0
 no adaptors present

Output di vainfo:

libva: VA-API version 0.32.0
libva: User requested driver 'fglrx'
libva: Trying to open /usr/lib/dri/fglrx_drv_video.so
libva error: /usr/lib/dri/fglrx_drv_video.so init failed
libva: va_openDriver() returns -1
vaInitialize failed with error code -1 (unknown libva error),exit

Update:
Non so perché usa di default fglrx io ho una intel 865g. Se modifico la variabile d'ambiente LIBVA_DRIVER_NAME e metto i965 per fargli usare il file i965_drv_video.so che cerca nella cartella /usr/lib/dri, mi esce questo nuovo output:

libva: VA-API version 0.32.0
libva: User requested driver 'i965'
libva: Trying to open /usr/lib/dri/i965_drv_video.so
vainfo: intel_driver.c:58: intel_driver_init: Assertion `dri_state->driConnectedFlag == VA_DRI2 || dri_state->driConnectedFlag == VA_DRI1' failed.
Abortito

Ci deve essere qualche incompatibilità tra la libreria libva e il driver intel. Al momento ho installate queste versioni:

libva1-1.0.15-19.1.i586
vaapi-drivers-1.0.17-19.1.i586

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1761

@greywolf82
probabile un bug di VLC per il tuo caso particolare... C'è /usr/lib/dri/fglrx_drv_video.so ???

SO: Linux desktop Sistema: OpenSUSE Leap 15.1 (64bit) KDEE 5.12
SO: Linux desktop Sistema: OpenSUSE Tumbleweed (64bit) KDE 5
Miao

Ritratto di greywolf82
greywolf82
(Monster)
Offline
Monster
Iscritto: 07/07/2008
Messaggi: 240

Si c'è ma è un link simbolico al file xvba_drv_video.so. Ho provato anche a scrivere sulla mailing list di packman, vediamo se c'è qualcuno che può dare una mano.